1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ade 1.01 Load Error

Discussion in 'Airport Design Editor' started by biberry, 7/12/07.

  1. biberry

    biberry

    Joined:
    7/12/07
    Messages:
    5
    Country:
    portugal
    Hi there,
    For your information
    ADE version 1.00 OK.

    Installed ADEH 1.01 & SDE LIB 1.01.

    When trying to load previous ADE files programme crashes.

    Could not find file 'G:\Utilities for FSX\Airport Design Editor\EGVA_ADE_BOB.ade'.

    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
    at ScruffyDuck.AirportDesignEditor.MainForm.openAdeProjectFile(String filename)
    at ScruffyDuck.AirportDesignEditor.MainForm.openAdeFile()
    at ScruffyDuck.AirportDesignEditor.MainForm.openADEMenuItem_Click(Object sender, EventArgs e)
    at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
    at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
    at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
    at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
    at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
    at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
    at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
    at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
    at System.Windows.Forms.ToolStrip.WndProc(Message& m)
    at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    Loading from previous compiled BGL OK.

    Operating system Windows Vista Home Premium.
    Flight Simulator X Deluxe Edition

    Regards from Portugal

    Bob Berry
  2. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    23,306
    Country:
    wales
    Bob

    Can you give us a bit more information please? What are you doing to cause this crash? Are you opening the Airport from Open Airport or from the Recent Airport List?
  3. biberry

    biberry

    Joined:
    7/12/07
    Messages:
    5
    Country:
    portugal
    Hi Jon,

    I am opening from Open Airport, but I think I may have found the reason. In the save work folder the files were read only.
    Don't know why? Maybe they always were.

    Still trying to solve it.

    Regards,

    Bob
  4. biberry

    biberry

    Joined:
    7/12/07
    Messages:
    5
    Country:
    portugal
    Hi Jon,

    Strange, It will now open from Recent files and not from Open airport,
    Can I send you the file?

    Regards

    Bob
  5. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    23,306
    Country:
    wales
    Yes send it and I'll check it out. I suspect it may be something to do with file permissions in Vista
  6. biberry

    biberry

    Joined:
    7/12/07
    Messages:
    5
    Country:
    portugal
    Hi Jon,

    File herewith, I have checked the the file permissions and they are all Full control.

    Regards

    Bob

    Attached Files:

  7. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    23,306
    Country:
    wales
    It loads fine here Bob. I am using XP however. Maybe one of the beta team using Vista will check it also
  8. Tim_A

    Tim_A

    Joined:
    29/5/07
    Messages:
    511
    Country:
    england
    I get the same problem in Vista. If you notice, the final part of the path ("\work") is missing.
  9. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    23,306
    Country:
    wales
    Bob

    I think we may have found the problem that is causing this. It will be included in the next release
  10. biberry

    biberry

    Joined:
    7/12/07
    Messages:
    5
    Country:
    portugal
    Hi Jon,

    Thanks for the prompt action.Hope it won't cause you too much work.

    Excellent programme,looking forward to the pro edition to see what extra goodies you are adding.

    Regards

    Bob

Share This Page