1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ADE compiling Error

Discussion in 'Airport Design Editor' started by yankeesfan12, 21/9/10.

  1. yankeesfan12

    yankeesfan12

    Joined:
    8/3/08
    Messages:
    35
    Country:
    us-connecticut
    Hello,
    I am getting this error when trying to compile an airport in ADE.

    ScruffyDuck Scenery Design Engine Compiling
    Using FSX BglComp....


    Parsing document: C:\Users\Matthew\Desktop\KOXC_ADEX_MM.xml

    INTERNAL COMPILER ERROR: #C2451: Display character expected at offset (1) in Taxiway Sign label: ll[C]m18
    INTERNAL COMPILER ERROR: #C2448: Invalid format for Taxiway Sign label: ll[C]m18
    INTERNAL COMPILER ERROR: #C2031: Failed element parse <TaxiwaySign>
    INTERNAL COMPILER ERROR: #C2032: XML Parse Error! Element tree follows:

    ERROR: <FSData
    ERROR: version = 9.0
    ERROR: >
    ERROR: <Airport
    ERROR: country = United States
    ERROR: state = Connecticut
    ERROR: city = Oxford
    ERROR: name = Waterbury-Oxford
    ERROR: lat = 41.4785556122661
    ERROR: lon = -73.1352500617504
    ERROR: alt = 725.994F
    ERROR: magvar = 14
    ERROR: trafficScalar = 0.7
    ERROR: airportTestRadius = 16404.2F
    ERROR: ident = KOXC
    ERROR: >
    ERROR: <TaxiwaySign
    ERROR: lat = 41.485123285995
    ERROR: lon = -73.1369957263282
    ERROR: heading = 350
    ERROR: label = ll[C]m18
    ERROR: size = SIZE3
    ERROR: justification = RIGHT
    ERROR: >
    ERROR:
    INTERNAL COMPILER ERROR: #C2607: Compilation errors detected, compilation failed!


    Parse complete!


    Here is the file: http://rapidshare.com/files/420451107/KOXC_ADEX_MM.ad2

    Please Help!

    -thank you
  2. glottis

    glottis

    Joined:
    5/1/07
    Messages:
    2,224
    Country:
    newzealand
    Matthew,
    the answer is in your Error :)

    the error is the the taxisign,
    you have two characters the same (l) at the beginning,
    you need to delete one of them
  3. Golf-HotelDelta

    Golf-HotelDelta

    Joined:
    20/12/04
    Messages:
    9,910
    Country:
    unitedkingdom
    In ADE, select "List/Taxi signs" then scroll down to:

    ||[C]m18

    Click on "Edit" and delete the first "|"

    [​IMG]
  4. yankeesfan12

    yankeesfan12

    Joined:
    8/3/08
    Messages:
    35
    Country:
    us-connecticut
    thanks! also one more thing. The airport I am making this AFCAD for has parking T's in some parking areas. So right click and click Add/Library Object/Category/Stock/ And click ga parking T white new. When I add it, I compile the airport into a bgl, put it in fsx, and go to the place it is suppost to be in, but it is not there? How can I make it appear in FSX?

    -thank you
  5. bobbyjack

    bobbyjack

    Joined:
    30/10/07
    Messages:
    1,523
    Country:
    unitedstates
    I don't have the same library objects you do. However, in ADE if the parking space lines up perfectly with the parking link, the T will not show. If you select the parking spot, grab the handle and rotate it just a smidge, the T should appear in FS.

    Bob
  6. yankeesfan12

    yankeesfan12

    Joined:
    8/3/08
    Messages:
    35
    Country:
    us-connecticut
  7. tgibson

    tgibson

    Joined:
    22/9/06
    Messages:
    4,564
    Country:
    us-california
    If they are visible on the ADE screen, delete them. If not, create a taxi sign exclude file(s) for them.

    Hope this helps,
  8. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    25,540
    Country:
    wales
    It might first be worth checking that there is not a duplicate airport somewhere on your system.
  9. yankeesfan12

    yankeesfan12

    Joined:
    8/3/08
    Messages:
    35
    Country:
    us-connecticut
    They are not visible on my ADE screen. I created the Exclude bos and checked taxiway signs, and tested it in fsx, but they were still there.

    Just checked, I do not see any duplicates.

    -thank you
  10. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    25,540
    Country:
    wales
    Did you run a scanner to look for duplicates?
  11. glottis

    glottis

    Joined:
    5/1/07
    Messages:
    2,224
    Country:
    newzealand
    just to add,
    do you have!! or have had (now deleted) any scenery addon at all for this area,
  12. yankeesfan12

    yankeesfan12

    Joined:
    8/3/08
    Messages:
    35
    Country:
    us-connecticut
    I ran the Fault Finder, and found nothing except a few orphan taxiways not even near the spot, but are suppost to be that way.

    There is no scenery for this area :)

    -thank you
  13. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    25,540
    Country:
    wales
    No - the fault finder will not find duplicates. What we are talking about is duplicate airport files. For FSX - FSX Airport Scanner can be used to see if there are any duplicate airports contained in other bgl files.
  14. yankeesfan12

    yankeesfan12

    Joined:
    8/3/08
    Messages:
    35
    Country:
    us-connecticut
    Thanks! I just searched for duplicates using the FSX Airport Scanner and it said what is in the pictures. KLCI and 4B9 are others I did in the past, but those should not be a factor... right?:confused:

    -thank you

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      45.1 KB
      Views:
      105
    • 2.jpg
      2.jpg
      File size:
      46.6 KB
      Views:
      118
  15. glottis

    glottis

    Joined:
    5/1/07
    Messages:
    2,224
    Country:
    newzealand
    what are you using for AI traffic?
    do you have any add-ons for this at all
  16. yankeesfan12

    yankeesfan12

    Joined:
    8/3/08
    Messages:
    35
    Country:
    us-connecticut
    I do not use any AI traffic, all I use is vatsim :p

    -thank you
  17. yankeesfan12

    yankeesfan12

    Joined:
    8/3/08
    Messages:
    35
    Country:
    us-connecticut
    Anything?

    -thank you
  18. tgibson

    tgibson

    Joined:
    22/9/06
    Messages:
    4,564
    Country:
    us-california
    Hi,

    Go to the Scenery Library and deactivate the layer containing your airport. Do they appear now?

    If not, then there is another file in that folder that contains them.

    If they still appear, start deactivating about half of your addon scenery layers at a time. Narrow it down until you find the problem layer. That layer's BGL files contain the problem.

    It they still appear when you have deactivated all your addon scenery, then they are part of the default airport and should be able to be removed by an exclude.

    Hope this helps,
  19. yankeesfan12

    yankeesfan12

    Joined:
    8/3/08
    Messages:
    35
    Country:
    us-connecticut
    Thanks for the reply!

    When I deactivated the layer with the scenery, the extra taxiway signs did dissapear, But the ones that dissapeared were the new ones I put in for new taxiways. I excluded the old ones, but they still pop up.

    -thank you

Share This Page