1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FS2004 AIFP3 is not a Valid Win32 Application

Discussion in 'AI Flight Planner' started by SVAVID, 7 Aug 2017.

  1. SVAVID

    SVAVID

    Joined:
    7 Aug 2017
    Messages:
    3
    Country:
    ireland
    Hi There,

    I have Upgraded AI Flight Planner from Version 3.2.06 to Version 3209. When opening the program i receive the Error "AIFP3.exe is not a Valid Win32 Application". I'm using Windows XP SP3 and FS9, Version 3.2.06 works perfectly.

    Any ideas what the issue could be??

    help appreciated

    Regards

    Dave
     
  2. Jaeyo

    Jaeyo Resource contributor

    Joined:
    19 Jun 2017
    Messages:
    35
    Country:
    england

    Try a reinstall of AI Flight Planner of possible. First do a restart
     
  3. SVAVID

    SVAVID

    Joined:
    7 Aug 2017
    Messages:
    3
    Country:
    ireland
    Thanks Jaeyo,

    Tried the reinstall/Restart but the error is still appearing.

    Dave
     
  4. gadgets

    gadgets Resource contributor

    Joined:
    8 Nov 2005
    Messages:
    6,526
    Country:
    ca-britishcolumbia
    Unfortunately, Dave, we've discovered AIFP 3.2.07 and later are not compatible with Windows XP. NET/Framework 4.5 is required to accommodate P3Dv4 and it and XP "don't get along". Short of supporting two streams of AIFP, I see no way of resolving the issue.

    Don
     
  5. SVAVID

    SVAVID

    Joined:
    7 Aug 2017
    Messages:
    3
    Country:
    ireland
    Hi Don.

    Thanks for the reply i fully understand, i`m well overdue an upgrade of both Windows and my Sim.

    Also, thanks for a great piece of software i`ve been using it for years and its a credit to you.

    Regards

    Dave
     
  6. Jaeyo

    Jaeyo Resource contributor

    Joined:
    19 Jun 2017
    Messages:
    35
    Country:
    england

    You can upgrade OS really easily these days
     
    SVAVID likes this.
  7. DirkDP

    DirkDP

    Joined:
    5 Jan 2015
    Messages:
    15
    Country:
    belgium
    First of all, great program, which I only discovered a few weeks ago.

    I got that error warning too when updating to v3208. I knew what it meant...
    I downloaded one of the development releases, v3208(f) I think, and that one still works with Win XP.
    I use an old PC with XP for editing/testing all my FS9 stuff. My "real" FS9 PC has Win7x64, so it's not really a problem for me.

    But it would be nice to mention on the AIFP home page or something that it is no longer compatible with XP.
    And maybe put up a link for the last version to work with XP, for those of us that can't let go of XP... ;)
     
  8. gadgets

    gadgets Resource contributor

    Joined:
    8 Nov 2005
    Messages:
    6,526
    Country:
    ca-britishcolumbia
    Thanks for the suggestion, Dirk. Good Idea!

    Don
     

Share This Page