1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Aircraft not showing up as AI

Discussion in 'Other' started by Funky, 28/2/08.

  1. Funky

    Funky

    Joined:
    24/6/07
    Messages:
    24
    Country:
    germany
    Hello,

    I have a number of aircraft that do not become visible when created as AI aircraft by certain tools like Traffic explorer, FSHOST, FS Recorder.
    The aircraft entry exist in the AI list, yet the visual model does not become visible.
    Otherwise, selected as user aircraft, they work perfectly.

    Does anybody have a clue on this?

    PS: Sorry, should have provided all available information. This happens in FSX/SP2 and is apparently related to the .MDL and/or textures of the aircraft, which are all either 3rd party or migrated FS9 aircraft.
    Last edited: 28/2/08
  2. gsnde

    gsnde

    Joined:
    21/3/05
    Messages:
    2,945
    Country:
    germany
    Hi Funky,

    Is this FS9 or FSX?

    If I understand you correctly, then you see the aircraft in question in the traffic tools, but don't find the visual representation on the screen.

    You say this is happening for a number of aircrafts; does this imply that you can see other aircraft types that you place the same way?

    Maybe you can post the lines of the flight plan here for some aircrafts that don't show up.
  3. gsnde

    gsnde

    Joined:
    21/3/05
    Messages:
    2,945
    Country:
    germany
    OK, I have seen your additions to you post.

    This is strange. Can you see in the traffic tool that the aircraft in question is indeed sleeping, then waking up, taxiing and finally starting? Or does it vanish at some point close before it becomes active?

    If you see the normal status changes, you might want to test (with crash detection turned on) if it is really physical available by trying to crash into it.
  4. Funky

    Funky

    Joined:
    24/6/07
    Messages:
    24
    Country:
    germany
    Hi gsnde,

    that happens while bypassing the ATC as if you were making a VFR aircraft. The red aircraft label is shown anyway.
    Usually I try it with the aircraft mode set to taxi, but I can do also with aircraft mode set to airborne. Then the label moves by with the appropriate aircraft speed and I hear the noise.
    I have tracked it down so far to the model-file, and maybe the texture, by replacing these two folders of an original FSX aircraft. The it happens there, too.
    What is weird, is that it does not happen with original FSX aircraft, which show up properly under all circumstances.
  5. gsnde

    gsnde

    Joined:
    21/3/05
    Messages:
    2,945
    Country:
    germany
    To be honest, that does not ring a bell. If you would not be able to see the same aircraft when selected as a user aircraft, but only as AI?

    What models are these?
  6. Funky

    Funky

    Joined:
    24/6/07
    Messages:
    24
    Country:
    germany
    Actually, it is vice versa. When selected as user aircraft everything is ok, when trying to create as AI by traffic explorer, or replaying as AI with FS Recorder, or being created as a multiplayer aircraft by FSHOST, the model remains invisible, just the label appears.

    Edit: Apparently all aircraft are affected, except from original FSX.
    Last edited: 28/2/08
  7. Golf-HotelDelta

    Golf-HotelDelta

    Joined:
    20/12/04
    Messages:
    10,108
    Country:
    unitedkingdom
    In Options/Display/Aircraft switch off "Aircraft casts shadows on ground"

    George
  8. Funky

    Funky

    Joined:
    24/6/07
    Messages:
    24
    Country:
    germany
    Hit! Had already googled for a while, but never got something reasonable. Wonder how to find out that.

    Is there a reasonable explanation for it?

    Still it's a bit of a pity to live without ground shadows of the aircraft. That is good piece of realism.

    thanx very much!

    best regards,
    Peter
  9. Golf-HotelDelta

    Golf-HotelDelta

    Joined:
    20/12/04
    Messages:
    10,108
    Country:
    unitedkingdom
    I don't know whether it is reasonable, but SP2 broke the backwards compaibilty of FS9 models. It is just fortuitous that switching off shadows works for most FS9 AI aircraft.

    George
  10. ccartmel

    ccartmel

    Joined:
    17/10/06
    Messages:
    127
    Country:
    unitedkingdom
    Dx10?

    Are you running this in DX10 preview mode? on many aircraft in my hangar the textures vanish and I am left with white bodied shells. I would not be surprised that due to issues with transparency layers introduced with SP2 that the whole aircraft went invisible.

    If they show in DX9 or can be tested on a FS9 installation we can isolate the FSX installation.

    I just gave up on a Quantas 747 i really liked!
  11. Funky

    Funky

    Joined:
    24/6/07
    Messages:
    24
    Country:
    germany
    No, it's just plain DX9 on XP.

    Cheers

Share This Page