1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Another Export from 3ds Max 8 problem

Discussion in '3D Objects General' started by EssieP, 6/2/08.

  1. EssieP

    EssieP

    Joined:
    23/1/08
    Messages:
    108
    Country:
    unitedkingdom
    I've been going round in circles with this:
    No matter what I do, I can not see my model in FSX at Sea-Tac (or anywhere else I set in the placement file xml).

    *Scenery density set to "Dense" in the sim.
    *I've tried exporting the Oil rig model without modification, but that doesn't appear either.
    * LOD export tool says" .x file has no GUID or FriendlyName, the Max file does have them however. I've tried exporting to an X file from the File menu, as well as the LOD tool. It is as if the X file exports succesfuly, but without a GUID or FriendlyName.
    *Another oddity that may be related- ACES Documentation and Aces Tools menus appear twice in 3DS Max! I've checked user paths under customise, and there is only one path that I made manually.
    * my PC is set to dot for the decimal point, not comma.
    Last edited: 6/2/08
  2. n4gix

    n4gix Resource contributor

    Joined:
    26/9/06
    Messages:
    9,235
    Country:
    unitedstates
    How are you exporting the file?

    I certainly hope you are using File/Export/Flightsimulator Direct X...
  3. EssieP

    EssieP

    Joined:
    23/1/08
    Messages:
    108
    Country:
    unitedkingdom
    I am indeed using File>export... (and not mdl!)

    Today I got as far as generating the x file without the LODexport tool thinking there are any problems.
    So there are no faults, just that it doesn't show up in the sim.

    I've updated the .net framework to version 3.5, and it has not made the slightest difference.

    Below is the error message that XtoMDL gernerates. I have no idea where to look up the meaning of those codes.
    [​IMG]
    Last edited: 11/2/08
  4. EssieP

    EssieP

    Joined:
    23/1/08
    Messages:
    108
    Country:
    unitedkingdom
    Would anybody who can open 3ds max 8 files and knows that their installation can successfully export to FSX try this file for me? Ideally, can you return the bgl file so I can drop it in addon scenery to try again?

    I've persisted with this problem for two weeks now, and am having to consider giving up on making scenery addons.:eek:

    Attached Files:

  5. n4gix

    n4gix Resource contributor

    Joined:
    26/9/06
    Messages:
    9,235
    Country:
    unitedstates
    Here you go. I suspect your problem with not seeing it in the sim is because you have only one LOD in the model. If you have only one, it must be LOD_400...
    Last edited: 25/3/09
  6. EssieP

    EssieP

    Joined:
    23/1/08
    Messages:
    108
    Country:
    unitedkingdom
    thanks very much n4gix,
    I've amended the _LOD number, thanks
    There is one big difference between your mdl and mine however, mine comes out at 0kb!

    Is that right, if not...
    any idea why that should be?
  7. n4gix

    n4gix Resource contributor

    Joined:
    26/9/06
    Messages:
    9,235
    Country:
    unitedstates
    Last edited: 10/2/08
  8. EssieP

    EssieP

    Joined:
    23/1/08
    Messages:
    108
    Country:
    unitedkingdom
    thanks very much. I have been to the point of despair on this, but talking to you guys has given me the feeling that I'm getting somewhere.

    I'll let you know how it goes.
  9. EssieP

    EssieP

    Joined:
    23/1/08
    Messages:
    108
    Country:
    unitedkingdom
    Latest: I have a 5KB MDL file.
    Still can't see the model in the sim. I say can't... I can see its shadow!(see screenshot).
    *scratches head*

    Does running Abacus' World landscapes somehow hide the model?
    [​IMG]
    Last edited: 11/2/08
  10. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,263
    Country:
    netherlands
    Maybe a stupid question, but do you have any missing textures or so? That could also prevent your object from showing.
  11. EssieP

    EssieP

    Joined:
    23/1/08
    Messages:
    108
    Country:
    unitedkingdom
    I have re-checked that, so no- it's not a stupid question. The LOD exporter is supposed to include converting the Photoshop texture (it uses only 1 512px tile, no transparency or alpha map/channel).

    Incidentally, I have not re-exported and the shadow has also disappeared. Good grief:confused:
  12. EssieP

    EssieP

    Joined:
    23/1/08
    Messages:
    108
    Country:
    unitedkingdom
    Perhaps some muck got into the Max file, because today, I had some success. After re-setting Max, and merging the mesh in. Then make a new FSX material and apply the texture bitmap seems to have done the trick.
    [​IMG]
    Ironically, that Church mesh was only a quick test to check out the export technique, a check that took two weeks to sort out!
    Last edited: 18/2/08
  13. n4gix

    n4gix Resource contributor

    Joined:
    26/9/06
    Messages:
    9,235
    Country:
    unitedstates
    Several times you've mentioned the "LOD exporter..."

    Oh, I see. It's a "Max only" script that's new for FSX SP2... Apparently it doesn't work very well! :eek:
    Last edited: 16/2/08
  14. EssieP

    EssieP

    Joined:
    23/1/08
    Messages:
    108
    Country:
    unitedkingdom
    Do you use another method?
  15. n4gix

    n4gix Resource contributor

    Joined:
    26/9/06
    Messages:
    9,235
    Country:
    unitedstates
    Yes. Call me a "Luddite," but I simply use the normal Export or Export Selected, then manually create the .mdl and .bgl files...

    I also manually convert my textures for use in the sim's appropriate \texture folder. :wizard:

    I distrust "automated tools" that others have created (such as ACES programmers) for their own "in-house use." Invariably I've spent far too much time debugging their .ms scripts to get them to function correctly in my development environment... :eek:

Share This Page