1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

autogen object "ag_usfactory03" untextured?

Discussion in '3D Objects General' started by fulfern, 13/3/08.

  1. fulfern

    fulfern

    Joined:
    18/1/08
    Messages:
    5
    Country:
    italy
    Hi all,
    I've found an untextured autogen object in FSX SP2 (+ UTX)

    With a short research (and plenty of luck...) I've identified it.
    It is: ag_usfactory03

    {3B6B1B79-66C6-460A-A9D8-C84054A54979}

    At first, I was thinking I had some missing textures, but a visit to:

    http://lc0277.nerim.net/sceneobjects/

    showed the object is not textured (at least the thumbnail on the page, see attachment).


    Of course, the other similar factory thumbnails are textured and the relative objects do show textures in FSX.

    Any idea or tips for repairing/retexturing this object?

    BTW, unfortunately, it is just at the end of the glide slope to LIMJ, and it's very annoying to see it untextured.

    Thanks in advance for any reply
    Cheers

    Fulvio

    Attached Files:

  2. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,304
    Country:
    netherlands
    Hi,

    I don't think this can be fixed very easy. If it is only missing textures, adding some textures might fix the problem. But if the object does not contain any texture mapping at this moment then it will not work. In that case we would be talking about replacing the MDL object inside a default BGL, not really the best things to do.
  3. fulfern

    fulfern

    Joined:
    18/1/08
    Messages:
    5
    Country:
    italy
    Hi Arno,
    thanks for your reply.
    As I wrote, I don't think I've lost some textures in my own FSX installation, because only the specific object thumbnail on the web page is grey, while the others are textured, so I'd rather think it's a general FSX problem
    Now the question is: is there a way to "repair" this object (e.g. finding the texture references inside the model and adding the missing textures) or is it "hard coded" in FSX and we must live with it?

    Thanks
    Fulvio
  4. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,304
    Country:
    netherlands
    Hi,

    If we would know in which BGL this objects is located, it would be possible to take a look and see if any texturing information is included.
  5. Torgo3000

    Torgo3000

    Joined:
    3/10/06
    Messages:
    18
    Country:
    us-washington
    That file should be referencing the texture "AG_USIndustrial01.dds" which is present in Scenery\Global\texture. However I do notice that the file has a Multi-Sub Material with only one sub-material. For a little while we had a bug where that would export no texture information. We fixed the bug, but after looking at the .x file, there is no texture information there, so it must have been exported while we had that bug. Good catch, we'll get it next version. Sorry for the untextured object in the meantime. :(
  6. Horst18519

    Horst18519 Moderator Staff Member Resource contributor

    Joined:
    7/4/05
    Messages:
    2,192
    Country:
    germany
    Yes, that one is for the bin actually... :D

    ...like some others before SP2/Acceleration. They seem to be fixed though.

    I'd say it's much easier and faster to create your own factory than try to fix the default one.
    I have to admit though that I use generic objects more often in FSX since some of them are just beautiful and the range of objects ist quite stunning. Well done, Aces. :)
  7. meshman

    meshman

    Joined:
    25/4/06
    Messages:
    896
    withdrawn.
    Last edited: 29/6/09

Share This Page