1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BGL Compile Problems SBuilderX

Discussion in 'Ground2k4, SBuilder, SBuilderX' started by jdhaenens, 26/7/07.

  1. jdhaenens

    jdhaenens

    Joined:
    6/8/06
    Messages:
    377
    Country:
    unitedstates
    I've installed SbuilderX 310 and mapped out about 3 miles of shoreline and everything seems to be working great.

    When I select the lines and try to compile, I get the error screen below.

    Could someone help please?

    Thanks,

    JimD

    Attached Files:

  2. Luis_Sá

    Luis_Sá Resource contributor

    Joined:
    16/9/04
    Messages:
    314
    Country:
    portugal
    Hi,

    May be you could create a small project and send it to me. Delete everything except those lines that cause the error and send me. I will try to replicate the error.

    Kind Regards, Luis
  3. jdhaenens

    jdhaenens

    Joined:
    6/8/06
    Messages:
    377
    Country:
    unitedstates
    Thank you Luis,

    The projects are below.

    JimD
    Last edited: 8/8/07
  4. José

    José

    Joined:
    10/11/06
    Messages:
    490
    Country:
    brazil
    Hi, Jimd

    With your permission, I download and compiled your two projects in SBuilderX without problems.

    You pointed out the folder to save your compiled blg:

    C:\Program Files (x86)\SBuilderX\Scenery

    Did you look in that folder, in your computer, to see if there's a compiled bgl there?

    Luis Sá can give more information on that.

    Regards,

    José
  5. jdhaenens

    jdhaenens

    Joined:
    6/8/06
    Messages:
    377
    Country:
    unitedstates
    Hi Jose,

    Yes, I did. The projects did not compile to that directory at all. It is probably my installation then. As a favor, could you upload the resulting .bgl's so I'll have them to use while I troubleshoot my installation?

    Thanks for the help!

    JimD
  6. José

    José

    Joined:
    10/11/06
    Messages:
    490
    Country:
    brazil
    Hi, Jim

    The two bgls are zipped in the file JIMD.zip

    Regards,

    José

    Attached Files:

  7. jdhaenens

    jdhaenens

    Joined:
    6/8/06
    Messages:
    377
    Country:
    unitedstates
    Thanks, Jose. Got them.

    JimD
  8. jdhaenens

    jdhaenens

    Joined:
    6/8/06
    Messages:
    377
    Country:
    unitedstates
    I've reinstalled again and still get the same error.

    JimD
  9. José

    José

    Joined:
    10/11/06
    Messages:
    490
    Country:
    brazil
    Hi, Jim

    Problably, that is related to your computer, since I could open and compile your project normally.

    If this could help, my installation shows up the following folders/files:

    [​IMG]

    I would ask you if you have tried others projects or if that is the first.

    Luis Sá would analyse the error you are getting.

    Regards,

    José
    Last edited: 29/7/07
  10. jdhaenens

    jdhaenens

    Joined:
    6/8/06
    Messages:
    377
    Country:
    unitedstates
    Jose,

    I have all the directories you have shown. The only file you have that I don't is the sbuilder.ini.bak. Yes the shorelines were my first project with SBuilder X.

    I don't know why it won't operate properly. I am running a 64 bit operating system, and have installed the proper dummy entries in the registry (one of the posts below). It installed both times, and is usable up until you ask it to compile. I can get backgrounds, connect with FSX, change lines to polys, etc.

    I can use other tools for just about everything SBuilder X does except to combine photoreal and default shorelines. SbuilderX is the only program I know that will allow me to build the changed shorelines around both the new shape and default shorelines due to it's connection with the sim.

    The bgl's you made from my project worked fine...except that I reversed the order of the ocean shoreline and have waves going from the land to the sea. :banghead:

    If you could compile it one more time?...

    Thanks for your help, Jose!

    JimD
    Last edited: 8/8/07
  11. José

    José

    Joined:
    10/11/06
    Messages:
    490
    Country:
    brazil
    Hi, Jim

    As you said your only problem with SBuilderX is about compilation, I would suggest you to review if the folders' names where the FSX compilers are in your computer are correctly informed or configured in your SBuilderX installation.

    Your compiled bgl (and the project I used to) are attached.

    Regards,

    José

    Attached Files:

  12. meshman

    meshman

    Joined:
    25/4/06
    Messages:
    896
    SBX will look for the SDKs and then copy some of the files from that location over into the SBX install. I'd look to see if you have the files as per the attached screen grab and if not then you might try manually copying them over. Doesn't address why the weren't moved in the first place, but it's a workaround.
    Last edited: 10/12/07
  13. José

    José

    Joined:
    10/11/06
    Messages:
    490
    Country:
    brazil
    DOS rules for files/folders names

    Hi, Jim

    Besides some remarks allready done, please, try to rename some folders and files SBuilderX uses for the compilation, following DOS conventions, related to invalid characters in those names, such as:

    ./\[]|<>+;,)?

    Instead, use underscore ( _ ) to separate words in long names.

    FSX compilers run in command line or DOS mode and ignore folders/files names that do not obey those conventions.

    Regards,

    José
    Last edited: 30/7/07
  14. scott967

    scott967

    Joined:
    3/2/05
    Messages:
    1,267
    Country:
    us-hawaii
    Just curious, after the compile fails, are there any files in the Tools\Shapes folder?

    scott s..
  15. jdhaenens

    jdhaenens

    Joined:
    6/8/06
    Messages:
    377
    Country:
    unitedstates
    The only thing I see is HLX_PROJECT.xml in the ...tools/shapes folder.

    Thanks for your interest.

    Jim

Share This Page