1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

By Antigate not working well.

Discussion in 'ActiGate' started by alton, 18/7/07.

  1. alton

    alton

    Joined:
    28/9/06
    Messages:
    12
    Country:
    hongkong
    My Antigate not working well.

    :confused:
    I've finished the moving airbridge with 2 animation for 747s and 777s.
    After exported in FS9, theres are no animation works after engage the parking brake... very confuse in this situation. I didn't get any error when exporting.

    Can any expert help me? Many thanks~ :eek:

    Attached Files:

    Last edited: 18/7/07
  2. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    20,503
    Country:
    netherlands
    Hi,

    It seems you did not use the IFMSK command to check if the parking brake has been set. As explained in the ActiGate manual, you need to use that command. Not the IFIN1 command that CAT uses by default to check the variable. You will have to manually tweak the ASM code for that.
    Last edited: 22/7/07
  3. alton

    alton

    Joined:
    28/9/06
    Messages:
    12
    Country:
    hongkong
    Would you mind to show me where to change the IFIN1 to IFMSK..
    i have read the manual.. but still very confused coz the sourcecode gen by the CAT is quiet massy for beginner like me.
    btw. other than this, do my code fine or not, i am afriad that my method is wrong, can any body teach me kindly once more time? many thz.. thz for giving a chance to me ----- a very beginner.
  4. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    20,503
    Country:
    netherlands
    Hi,

    This would be the piece of code where the brake status is checked:

    Code:
    VAR_BASE_OVERRIDE 0
    IFIN1 at_5, 031Ah, 1, 1
      IFIN1 at_6, 6h, 0, 0
        SETWRD 6h, 1
      at_6 label word
      BGL_JUMP_32 at_8
    at_5 label word
    You would have to change it into this:

    Code:
    VAR_BASE_OVERRIDE 0
    IFMSK at_5, 031Ah, 1
      IFIN1 at_6, 6h, 0, 0
        SETWRD 6h, 1
      at_6 label word
      BGL_JUMP_32 at_8
    at_5 label word
    I have not tested the rest of your code, but it looks OK to me. So my first try would be to use the correct trigger.

Share This Page