1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't see my 4.8m photomesh...

Discussion in 'Ground2k4, SBuilder, SBuilderX' started by Clutch Cargo, 26/5/06.

  1. Clutch Cargo

    Clutch Cargo

    Joined:
    7/3/06
    Messages:
    556
    Country:
    unitedstates
    Can someone explain why if I put my 4.8m photoreal textures in the main FS9/Scenery/Texture folder it works ok but when I put them in my addon scenery/texture folder FS2004 will not load?

    I see other photoreal addons that work just fine placing them in the Addon Scenery folders but the ones I create with SBuilder will not work there? Infact the others I see do not have gridlines where mine does?

    Please enlighten me
  2. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    Hi,

    That is the difference between placing the photos with resample or placing them with VTP polygons. In case they are placed with VTP polygons (as SBuilder does), your textures must be in the main texture folder. If they are placed with resample, you can place them in the local texture folder as well.
  3. Clutch Cargo

    Clutch Cargo

    Joined:
    7/3/06
    Messages:
    556
    Country:
    unitedstates
    Ah... interesting. A bit naive on the "resample" term. Is that a process or a program? My thoughts are if I use the resample method I might lose the texture gridlines as well?
  4. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    resample is the tool that MS provides with its terrain SDK.

    Yes, you would loose the gaps as well. But the negative side of it, is that you can no longer use the alpha channel to show textures only partly, as the alpha channel becauses water with resample.
  5. Clutch Cargo

    Clutch Cargo

    Joined:
    7/3/06
    Messages:
    556
    Country:
    unitedstates
    Musta caught ya right by the PC... instant reply :) Yea, I was just going through my files and came across the resample.exe. So it needs an inf file which Sbuilder does not provide (at least that I know of).

    So if I understand you correctly, you are saying if I use the resample method I will lose alpha channel capabilites completely or just DXT3 type files? Could I use DXT1? Or do people just use the resample method if they know there textures are just over land?

    So if I have a texture that spreads partly over water I could not use alpha to mask it? If I still can, how can I use resample with SBuilde (probably a Luis question).
  6. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    Hi,

    No, you still have the alpha channel, but instead of showing transparant it will show up as water. Sometimes this is what you want, but sometimes not :).

    I think it makes no sense to use DXT3 for photo textures, as far as I know it does not use the semi-transparancy information.

    I think you can not use it with SBuilder (but Luis can tell you for sure). You will have to create a INF file yourself (or there are some tools for that as well).
  7. Clutch Cargo

    Clutch Cargo

    Joined:
    7/3/06
    Messages:
    556
    Country:
    unitedstates
    Thx as always arno... much clearer. Gueess it's over to SBuilder to bug Luis for awhile :p

Share This Page