1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FSX dll.xml errors

Discussion in 'SDK installation' started by jeansy, 7/1/12.

  1. jeansy

    jeansy

    Joined:
    7/1/12
    Messages:
    3
    Country:
    australia
    Hello

    Im having a few problems with my dll.xml

    just recently, I lost all my addons in my addon menu with the exception of fsupic

    Ive just dont 4 reinstalls and I still cant not get any of them to show

    I can get the security warning when i flush out the fsx.cfg

    am I missing something ? ive installed the sdk each time and ran sdk.exe but nothing

    here is my dll.xml thus far

    im just after the payware addons instant scenery and helitraffic and the server program fsinn (fscopilot) to work
    Last edited: 7/1/12
  2. BASys

    BASys

    Joined:
    25/5/06
    Messages:
    1,239
    Country:
    scotland
    Hi Folks

    Matt -
    Please post your ADE-Check report.



    Have you run configsdk.exe in the SDK root ?



    Suggest first getting the 3 SDK components to run.
    They're all currently disabled.

    Set them to -
    Code:
    <Disabled>False</Disabled>
    Remove the 4 addon entries from your dll.xml.



    1)
    Launch FSX.
    Does the Tools menu now load ?



    2)
    If YES -
    Stop FSX,
    then reinsert the first addon's entry into your dll.xml



    Repeat 1) & 2)
    till your tools menu fails to load.



    PS
    I note that two of your entries are -
    Code:
    <Path>[COLOR="Red"][B][SIZE="7"]G[/SIZE][/B][/COLOR]:\Program Files (x86)\WHATEVER</Path>
    Is that drive letter correct ?
    Is UAC blocking them ?



    HTH
    ATB
    Paul
  3. jeansy

    jeansy

    Joined:
    7/1/12
    Messages:
    3
    Country:
    australia
    thanks Paul for the assistance so far

    here is the report as asked


    *************************************************************************************************
    Date of Report: 9/01/2012 7:42:52 PM
    Operating System: Microsoft Windows 7
    OS Service Pack: Service Pack 1 (1.0)
    OS Version: 6.1.7601 (64 Bit)
    OS Language: English (Australia) => separator: '.'
    Nodename: WINDOWS-PC
    ADE installed: no
    ADE Path: ADE not found
    ADE Install Version: n/a
    ADE File Version: n/a
    ADE Info: n/a
    FXS installed: yes
    FSX Path: G:\Program Files\Microsoft Games\Microsoft Flight Simulator X\
    FSX Version: 10.0.61637.0 (FSX-Xpack.20070926-1421)
    FSX Trailing '\' Error: False
    FX9 installed: no
    FS9 Path: n/a
    FS9 Version: n/a
    FS9 Trailing '\' Error: False
    RTM Simconnect: yes
    SP1 Simconnect: yes
    SP2 Simconnect: yes
    FSX SDK installed: yes
    FSX SDK Path: G:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\
    FSX SDK Trailing '\' Error: False
    BGLComp Version: 10.0.61637.0 (FSX-Xpack.20070926-1421)
    BGLComp >= SP1: yes
    Shp2Vec found: yes
    .NET 1.1 installed: no
    .NET 2.0 installed: yes
    .NET 3.0 installed: yes
    .NET 3.5 installed: yes
    XML3 installed: yes
    XML4 installed: yes
    XML5 installed: no
    XML6 installed: yes
    FSUIPC/FS9 installed: n/a
    FSUIPC/FSX installed: 4.754
    Connected to FS9 ok: no
    Connected to FSX ok: yes
  4. BASys

    BASys

    Joined:
    25/5/06
    Messages:
    1,239
    Country:
    scotland
    Hi Folks

    Matt -
    Look at your paths below
    from your ADE-Check and dll.xml files.

    Line 1 is your FSX
    Line 2 is your SDK
    Line 3 is your SDK Tools path, relative to your FSX

    See any discrepancies -
    Code:
    1 - G:\Program Files\Microsoft Games\Microsoft Flight Simulator X\
    2 - G:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\
    3 -                                     ..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll
    SDK Tools will never find FSX using that relative path.



    Quick & dirty solution is
    to correct your SDK Tools path's in your dll.xml,
    from RELATIVE to ABSOLUTE.

    e.g. Change your Visual FX tool's dll.xml entry to -
    Code:
    G:\Program Files\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll


    Had you just reinstalled either the SDK or FSX ?




    HTH
    ATB
    Paul
    Last edited: 9/1/12
  5. jeansy

    jeansy

    Joined:
    7/1/12
    Messages:
    3
    Country:
    australia
    Paul the Tower is being formatted to resolve the problem


    i just tried to replica it on the laptop and no problems

    so far all good on the laptop, the only thing different between the PCs are

    tower runs 64bit win7 while the laptop runs 32bit win 7

    the strange thing about it is, the 2nd time it happened, the tower was "as new" due to the PC format ( yes all updates were done before installing) and that time not installing the SDK

    and both times it happened after installed the lastest orbx products

    could 64bit win7 might be causing these issues?
    Last edited: 13/1/12

Share This Page