1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FS2004 MDL animations

Discussion in 'ModelConverterX' started by arno, 11/4/10.

  1. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,304
    Country:
    netherlands
    In the next development release there will be support for exporting animations to the FS2004 MDL format as well. Don't expect this feature to be completely stable yet though. On most of my test objects it works, but some still go wrong. So please let me know if you find any issues.

    To get MakeMDL export the animations correctly, I had to disable the LODs while exporting to the FS2004 MDL format. I don't think this is a big issue, since I was not sure they were working before anyway. I have put it on my todo list to check how to get them working properly.
  2. gsnde

    gsnde

    Joined:
    21/3/05
    Messages:
    2,930
    Country:
    germany
    That little sing and dance I just did was exclusively for you, Arno ;)
  3. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,304
    Country:
    netherlands
    I hope you won't find too many bugs :D.

    Oh, btw, I just run the "nightly build" script, so the new development release is available from right now.
  4. gsnde

    gsnde

    Joined:
    21/3/05
    Messages:
    2,930
    Country:
    germany
    That is already very very close, Arno. I have reconverted the APIs to MDLs and created a new library. First observation: all parts are now visible.

    When adding the freshly converted objects with "Instant Scenery", the animated parts are missing, which is normal and an indicator that this part has an animation. After reloading the sim the parts are visible as expected... but they don't animate (that is rotate in all my test cases here).

    Tell me what you need to investigate this :)
  5. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,304
    Country:
    netherlands
    Thanks for the feedback, I guess I will test here with some of your objects. I mainly tried now if MCX could import the animations again. But I did not test them all in FS to see if they really work.

Share This Page