1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FSX: Disappearing Shadows

Discussion in 'GMax and 3DS Max' started by Model10, 23/3/07.

  1. Model10

    Model10

    Joined:
    27/9/06
    Messages:
    52
    Country:
    unitedkingdom
    Hi
    Can anyone explain why my aircraft shadow disappears as I move along my custom runway texture. See Shots:

    Starts off OK.
    [​IMG]

    Moving along, shadow begining to vanish.
    [​IMG]

    Shadow gone.
    [​IMG]

    I created the initial runway in afcad2. Shadow no problem.
    In 3dsMax I created runway ground polys to place over the afcad runways, used a tiled texture, exported, tweaked the ASM code with the Addcat command, Layer 12. Shadow no problem
    Created another runway ground poly for an alpha texture created in photoshop for stains and tyre marks. DXT5 (Tried DXT3 also)
    Tweaked the ASM code, Layer 20. Ground Shadow Problems.
    My Afcad Airport and my airport flatten are both the same altitude in meters
    I'm not having any other problems with the textures such as flickering or anything.
    Thanks
  2. Model10

    Model10

    Joined:
    27/9/06
    Messages:
    52
    Country:
    unitedkingdom
    Hi
    Does anyone know what might be causing this?
    Cheers
  3. José Bourgoignie

    José Bourgoignie

    Joined:
    20/4/05
    Messages:
    1,039
    Country:
    belgium
    Hi,

    Tried layer 24 ?
    Tried DXT1 with alpha ?

    Greetz. José.
  4. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,254
    Country:
    netherlands
    Hi,

    No, I have not seen such trouble before. As Jose suggested you might want to try a different layer number for your alpha layer. Although I would sooner try a lower than a higher number.

    Also, do your normal and alpha layer have the same reference point?
  5. pks1414

    pks1414

    Joined:
    28/6/04
    Messages:
    286
    I had exactly the same problem with ground polys created with the FS2002 gamepack. Shadows worked great apart from one part of the airfield. I tried all sorts of layer numbers but as of yet no joy. I seem to recall that I read somewhere that it may have something to do with polys great than 100m square. My next plan is to place a 100m square poly where I know the shadows dissapeared and see if they work.

    By the way, how do you go about creating, or more to the point tweaking the asm code if you created the plane in 3DsMax?
  6. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,254
    Country:
    netherlands
    Hi Paul,

    The tweaking when using 3DSMax should be the same, as you still need to use MakeMDL to create the BGL file. So just tell MakeMDL to keep your ASM files. The biggest problem might be to get a X file that the Fs2002 MakeMDL can work with :).
  7. Model10

    Model10

    Joined:
    27/9/06
    Messages:
    52
    Country:
    unitedkingdom
    Thank you all for your suggestions
    I will give them a try
    Cheers

    Yes, they have the same reference point.

    I have no problem with 3dsmax .x files and the Fs2002 MakeMDL, and as Arno said the tweakiing is the same.
  8. Model10

    Model10

    Joined:
    27/9/06
    Messages:
    52
    Country:
    unitedkingdom
    Hi
    I'm still trying to solve my problem with shadows.
    I tried a simple test.
    Created a plane in 3dsmax, and mapped it with a variety of different textures I've created and in varrious dds formats and sizes. Still the same problem with the disappearing shadows.
    When I mapped the plane with a default FSX dds (taxi_macadam.dds) texture, I don't have the problem. This leads me to think I might be doing something wrong when creating my own .dds textures. Missing a switch or something. I create Mip Maps and have tried both the nvidia photoshop plugin and ImageTool when creating my .dds files. Its driving me nuts! :confused:
    Anyone have any ideas.
  9. Paavo

    Paavo

    Joined:
    20/5/06
    Messages:
    140
    Country:
    estonia
    This is probably the round earth problem.
    Earth is curved, but the plane you create is not.

    Shadows are always projected at ground level. If the plane is placed at ground level and your aircraft is near it's reference point, the the shadow will be projected at the same altitude as plane (but with higher layer number so it is on top of plane). As you move away from the reference point, the distance between you and the surface of earth starts to increase as earth curves away from it. The shadow is still projected and still at ground level -- the thing is that ground level is now below the plane:

    [​IMG]

    Fortunately, I found a very simple solution if your polygon is not very large. Create a copy of your plane, apply 100% transparent material to it and convert it to hardened surface with AttachTool. Then move it about 10-15cm above ground level. This way shadows will be projected onto the hardened surface, which does not curve. Of course, there's a small sideeffect: at about 1km away from the reference point the plane will be perhaps 30cm above the ground and when you taxi off the hardened surface, it may be quite bumpy, but, on the other hand, this can be seen as a feature.
    Last edited: 31/3/07
  10. Model10

    Model10

    Joined:
    27/9/06
    Messages:
    52
    Country:
    unitedkingdom
    Thanks Paavo
    I shall certainly give your suggestion a try, but I still don't understand why, when I apply one of the default FSX textures to my test plane and my taxiways, the shadows always appear.
    Cheers
  11. Model10

    Model10

    Joined:
    27/9/06
    Messages:
    52
    Country:
    unitedkingdom
    Hi
    I've just got somewhere with this.
    I had a look at the FSX texture I used where the shadow was OK and noticed it was a DXT1 texture, I had'nt tried DXT1 textures before because I needed greater levels of gradation in my alpha channel, so only worked with DXT3 and DXT5. I converted my texture to DXT1 and my shadows returned.
    My problem with using the DXT1 texture is that I get this black outline around the edge of my texture where I need my alpha channel to work as transparant.
    Can I get round this someway?
    I also noticed when using DXT3 and DXT5 textures the shadows are all OK when I am zoomed out a fair distance and only dissappear when I get closer. I picked this up when viewing in Top Down View. Could this be realated to Mip Map settings when creating DXT3 or DXT5 textures?
    Cheers
  12. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,254
    Country:
    netherlands
    Hi,

    That is a known bug in FsX at the moment, hopefully MS will solve this in the up coming SP1. At the moment here is not so much you can do about this.
  13. Model10

    Model10

    Joined:
    27/9/06
    Messages:
    52
    Country:
    unitedkingdom
    Thanks again Arno for your reply.
    It looks like my disappearing shadows might be related to this bug then.
    I hope they do get it sorted out.
    Cheers
  14. gregsoldo

    gregsoldo

    Joined:
    15/9/04
    Messages:
    26
    I had the same problem and converting the textures to DXT1 format solved it. Looks like SP1 fixed this bug.

Share This Page