1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FXEditor errors

Discussion in 'FXEditor' started by Avroman, 26/11/11.

  1. Avroman

    Avroman

    Joined:
    10/4/10
    Messages:
    25
    Country:
    canada
    Hi Bill and Arno and Everyone,

    I have not been on FSDeveloper for many months - real life has been keeping me very busy!

    Last year I was working on science fiction themed mission using FSX and successfully overcame the challenges of Gmax to install hardened landing decks (plane surfaces) in my floating scenery object (i.e. battlestar). This was a major victory and very exciting for a newbie! It can be done. Now I can land on these "runways".

    My next objective this winter is to put landing lights on the floating runways. I unsuccessfully pursued several different directions in developing landing lighting objects for this quest last winter. Now I would like to take another look at this.

    In this regard, Arno, your new tool is of interest - FXEditor. I have downloaded it and installed it, but am getting an error message. It is a path error which which is confusing as I have stripped all the "read-only" permissions off the folders in FSX so that the program can get there, but the error reads as follows;

    "Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately. Access to the path "C:....\_FSEditTemp.fx" is denied."

    I also don't understand the FSEditTemp file? In the program itself if you click continue you get a blank right screen. If you click restart effect you get a plane grid with a red cross ( x and y axis) on the screen.

    Any thoughts would be appreciated.

    Sincerely,

    John /Avroman
  2. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,251
    Country:
    netherlands
    Hi John,

    FXEditor saves the changes you make to a temp file in the effects folder first. It then reads that file again to update the preview as you make your changes. Only when you press the save button the original file is updated.

    I indeed assumed that users can write in that folder, but that might not be the case if you installed FS in the program files folder in Windows 7. Let me check if I can save the temp file in a temp folder.
  3. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,251
    Country:
    netherlands
    Hi,

    I have changed the tool now, from the next release the temp file is written in the Windows temp folder. So that should fix this error.
  4. Avroman

    Avroman

    Joined:
    10/4/10
    Messages:
    25
    Country:
    canada
    Hi,

    I have changed the tool now, from the next release the temp file is written in the Windows temp folder. So that should fix this error.
    __________________
    Arno

    Hi Arno,

    Thanks for your quick replies! I really appreciate this! Okay, interesting - yes, I have Windows 7. I hadn't given this much thought. Thanks again and I look forward to the next release.

    Best wishes on a rainy Sunday afternoon/evening!

    John /Avroman
  5. Roland58

    Roland58

    Joined:
    29/11/06
    Messages:
    12
    Error message when open FSX with a modified effect

    Hi Arno,
    I Had two problems with FXEditor and Modelconverter. I m trying to change de size of fx_IndustrialStm effect. When I am in FXEditor, everything works... I can changed some parametres and I can see the result in the right window. I put it in on my cheminey in ModelConveter, no problem. Then I use Wizards "Convert and place object" because If I use Export FSX BGL nothing works, no object appears in FSX. It s the first problem. The second problem, when I export with Wizards, most of the time when I lauch FSX I have an error message. I can see my object in fsx scene, but no effect on it.

    Can you help me?... I suppose I put wrong parametre in FXEditor, but honnestly I don't understand wich parametre is the cause. I joint a picture with the error message.

    Thx

    Roland

    Attached Files:

  6. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,251
    Country:
    netherlands
    Hi,

    That's a weird error, I have not seen it before. Maybe you can post your fx file as well?

    Exporting as bgl or using the wizard is almost the same. Except you need to add a position in the object information form first. Else your bgl only contains the object, but no placement.

    Send from my phone using Tapatalk, so excuse the short sentences and possible typos
  7. Roland58

    Roland58

    Joined:
    29/11/06
    Messages:
    12
    wrong effect file

    Thx for your reply Arno.

    In fact, when I save the new effect file in Effects folder, it s after that I have the error message. Yesterday I tried to changed some parametres and finally it works. I could be able to modified the size of the smoke. The best is to change one parametre at time, save and see if the effect file works.
    I delete the wrong file, but if I had it again I will post here.

    Thx again..

Share This Page