• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

P3D v4 Ground polygon wizard conveting issue

#1
Hi everyone,
I'm on to a project which is converting FS9 GPs to P3D ones. The others(e.g. taxi lines and brake skid) worked perfectly using GPW in MCX latest version of 1.4.
The problem came when converting surface polygon which lies on the photo-real ground. At first ,I checked "slice polygons", the process went perfectly but when I entered P3D to check ,it seemed some small parts of the surface polygon had been "misplaced" as I call it . The second time I tried to uncheck the "slice polygons", it turned out to be conflicting with the photo-real ground layer, which appears normal above a certain height, but covered by the photo-real layer under the certain altitude.
This is my first time converting FS9 GP to P3D, I don't know which step led to those consequences. If you guys have a solution to this ,please let me know.
2.jpg 1.jpg
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#3
Did you enter the altitude of your airport in meters in the wizard? Else the curvation might be calculated wrong.
 
#4
Did you enter the altitude of your airport in meters in the wizard? Else the curvation might be calculated wrong.
Hi Arno,
Thanks for the reply.
I entered the exactly precise elevation in meters of the airport, but problem still exists.
You mentioned curvation,may I ask how do I get rid of this?
Thanks.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#5
The wizard does add the curvation of the earth to your polygons. But that's on purpose, so you don't need to get rid of it.
 
#6
Something I've experienced with P3D v3/4 is that that it doesn't like the ground poly sharing the same space as the ground. You'll need to raise the ground poly model by at least .002 in the placement file.

Thanks,
Russ
 
#7
The wizard does add the curvation of the earth to your polygons. But that's on purpose, so you don't need to get rid of it.
Hi Arno,

Thanks for the reply, but my problem still exists. If I check poly slice (100m), I got strange random holes on poly, If I uncheck poly slice and group poly, I get a poly doesn't display in low height angle.

So I'm thinking that you may help me with this problem, because this is the final hard piece of problem of my whole project.

I'll attach the exact bgl file causing this , along with the airport default surface with flatten file.

Thanks,
Rustam
 

Attachments

#8
Something I've experienced with P3D v3/4 is that that it doesn't like the ground poly sharing the same space as the ground. You'll need to raise the ground poly model by at least .002 in the placement file.

Thanks,
Russ
Hi Russ,

Thanks for the reply, but I've tried every possible solution still got no progress :(

You may check the bgls I attached to Arno above the post.

Thanks.