1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help

Discussion in 'ObPlacer and ObPlacer XML' started by Abnrigger, 24/1/05.

  1. Abnrigger

    Abnrigger

    Joined:
    24/1/05
    Messages:
    8
    Country:
    unitedstates
    I am new to scenery design in FS2004. I downloaded the ObPlacer xml utility because I like being able to slew around for lat/long data etc. I have tried to place objects but cannot compile them, am I missing some files? I can access FS thru FSConnect but when it comes time to compile, it will not work...Help

    Bill
  2. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    20,572
    Country:
    netherlands
    Hi Bill,

    BGLComp is used to compile, but this is included in the download already. When you press the compile button do you get an error or what kind of message shows?
    Last edited: 25/1/05
  3. Abnrigger

    Abnrigger

    Joined:
    24/1/05
    Messages:
    8
    Country:
    unitedstates
    Arno,

    I am at work but will attempt to do it again tonight when I get home. I am assuming the MDL info, etc comes from the FS2004 directory? or do I need to load a library? I can select objects from the tree menu but it gives me an error. I will cut/paste the error message to you this evening.

    Thanks in advance for your help.
  4. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    20,572
    Country:
    netherlands
    If you are using the objects listed in the tree of the default MS objects then you don't have to load anything special. These objects are contained in the BGL files that come default with FS.

    If you want to load custom MDL objects or user libraries you need to add them to ObPlacer first, as described in the manual.

    If you show me the error message I am sure we will be able to figure out what is going wrong :).
  5. Abnrigger

    Abnrigger

    Joined:
    24/1/05
    Messages:
    8
    Country:
    unitedstates
    error message

    Arno, here is the error message:

    c:\ObsPlacerxml>c:

    c:\ObsPlacerxml>cd c:\ObsPlacerxml>

    c:\ObsPlacerxml>bglcomp compile.xml
    INTERNAL COMPILER ERROR C1003:Failed to create MSXML object! (0x8007045A)

    Parsing document: compile.xml

    ERROR C2470: Unrecoverable error parsing XML!
    ERROR C2006: Parse Failed (0x80004005)
    ERROR C2003: Failed to process file: compile.xml

    I installed all the files in the same directory (c:\ObsPlacerxml)

    Thanks in advance, bill
  6. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    20,572
    Country:
    netherlands
    Hi Bill,

    I think you don't have MSXML installed. This is needed by BGLComp to compile. You can download it from MicroSoft.
  7. Abnrigger

    Abnrigger

    Joined:
    24/1/05
    Messages:
    8
    Country:
    unitedstates
    Thanks, I'll download it and let you know if it works
  8. Abnrigger

    Abnrigger

    Joined:
    24/1/05
    Messages:
    8
    Country:
    unitedstates
    I downloaded MSXML 4.0 and installed it, same error message. Do I need to place the files in the same directory?
  9. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    20,572
    Country:
    netherlands
  10. Abnrigger

    Abnrigger

    Joined:
    24/1/05
    Messages:
    8
    Country:
    unitedstates
    OK, I'll try it
  11. Abnrigger

    Abnrigger

    Joined:
    24/1/05
    Messages:
    8
    Country:
    unitedstates
    I must be doing something wrong...same errors

    Let me run thru step by step and you can tell me if I am doing something wrong.

    I open FS2004 and are in slew mode, FSconnect is also loaded
    I open the program ObPlacerxml and then go back to FS and slew to where I want the object. I go back to the ObPlacer program and hit the "read from FS" key, lat/long data shows up, I then scroll thru the object tree on the left and choose the object I want to place at that particular location, then hit "place object" and the GUID information shows up. Now I hit compile xml and it errors out, obviously I am missing a step or something.

    I appreciate your patience
  12. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    20,572
    Country:
    netherlands
    Sorry, forgot to reply to this thread. Are you still having trouble?

    What you describe all sounds correct. Can you use BGLComp outside of ObPlacer without trouble? For example when you try to compile an XML file made by GMax.

Share This Page