1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to connect to the simulator from a remote computer.

Discussion in 'SimConnect' started by guodah, 25/1/07.

  1. guodah

    guodah

    Joined:
    9/10/06
    Messages:
    8
    Country:
    us-florida
    Dear folks,

    Could you anybody let me know how to connect to the simulator from a remote machine?

    I created a file, named SimConnect.cfg as follows and saved in "My Documents:

    Protocol=IPv6
    Address=<my ip>
    Port=1500
    MaxReceiveSize=4096
    DisableNagle=0

    I did this according to the SimConnect documents. But the OpenAndClose example does not connect.

    I really appreciate it if anybody could help.

    Thanks,
  2. badderjet

    badderjet

    Joined:
    21/12/06
    Messages:
    9
    Country:
    germany
    Hey folks,

    I'd also greatly appreciate some reply here for I can't get it to work either. I also had a search on other forums, tried all the hints that worked for others but they do not work here so I am quite a bit frustrated at the moment.

    Thanks in advance.
  3. ziporama

    ziporama

    Joined:
    28/9/06
    Messages:
    203
    Country:
    unitedstates
    Below are my working simconnect.cfg (client) and simconnect.xml (server).

    Note the use of IPV4, not V6 as that seems to require a special IP stack (new network card driver). Also, replace the IP address with the IP of the server (DNS name didn't work for me). Also, I had to set my scope to global to avoid pesky security issues.

    (simconnect.cfg in my documents on client PC)

    [SimConnect]
    Protocol=IPv4
    Address= 1.2.3.4
    Port=17200
    MaxReceiveSize=4096
    DisableNagle=0

    (simconnect.xml file in Documents and Settings\<alias>\Application Data\Microsoft\FSX folde on the server)

    <?xml version="1.0" encoding="Windows-1252"?>

    <SimBase.Document Type="SimConnect" version="1,0">
    <Descr>SimConnect</Descr>
    <Filename>SimConnect.xml</Filename>
    <Disabled>False</Disabled>
    <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>Auto</Protocol>
    <Scope>global</Scope>
    <Address>1.2.3.4</Address>
    <MaxClients>64</MaxClients>
    <Port>17200</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
    </SimConnect.Comm>
    </SimBase.Document>

    Hope this helps.

    Etienne

Share This Page