1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Invisable AI at modified airport...

Discussion in 'Airport Design Editor' started by Gypsy Baron, 25/1/08.

  1. Gypsy Baron

    Gypsy Baron

    Joined:
    4/3/07
    Messages:
    152
    Country:
    us-california
    I'm not sure if this is the appropriate place to seek help
    on this perplexing issue but since I'm using ADE to "reactivate"
    this former military airport I thought I'd at least
    start here.

    I've taken the stock LHTL ( Tokol ) airport that is
    located just south of Budapest Ferihegy and created
    a model which fits the Google Earth images with hardened
    shelters, lakes or ponds, and several other features.
    I've added lots of parking and also used Whisplacer
    to put down some additional scenery elements.
    I've used SBuilderX to create various polys to add
    LC elements for the various trees\forests within
    my extended airport boundry.
    All looks good and I've added some military AI into
    some of my existing flightplans.
    The problem is that even though the AI that I have
    added is listed in the Traffic Toolbox Explorer and
    I can hear the sounds and see the nav lights on departing
    traffic as well as the ATC interaction, the aircraft
    and helos are invisable at THAT airport.
    If I look at any that are enroute, they are fine.
    The very same aircraft I am using are visable at
    another airport I modified back in FS9 and inported into FSX.
    It is Sliac (LZSL) in the Slovak Republic.
    I have some Migs and IL's flying between Sliac
    and Tokol and on the Sliac end or enroute they are
    quite visable but at Tokol they are not.

    Is there anything in the airport record that might
    contribute to this problem or perhaps some scenery
    element? I am using some custom, SCASM generated
    shelter files but I also use them at Sliac where
    all is well. And Tokol is basically a FSX stock
    airport modified with FSX tools.

    I seem to recall a while back reading in one of the
    forums about some invisability problem related to
    scenery but I do not remember any of the particulars.
    perhaps someone here could point me in the right
    direction to fix this problem.

    Paul
  2. Golf-HotelDelta

    Golf-HotelDelta

    Joined:
    20/12/04
    Messages:
    9,132
    Country:
    unitedkingdom
    Switch off "Aircraft casts shadows" in the Settings/Display/Aircraft" tab.

    George
  3. Gypsy Baron

    Gypsy Baron

    Joined:
    4/3/07
    Messages:
    152
    Country:
    us-california
    I just discovered that, George, after doing some searching
    and reading of posts over in the Avsim forum.

    It seems this is yet another "SP2 induced" problem :(

    I did some further testing and removed my CVX poly
    BGL, my hardened shelter BGL's and my scenery BGL,
    leaving ONLY the ADE BGL and the problem is still
    there. So it's something in the airport file that
    causes the SP2 problem. As I mentioned above,
    the problem does NOT exist at my LZSL even though
    the file name tells me I ran that airport file
    through ADE after importing the AFCAD from my FS9 install.

    I was hoping to upload this "new old" Tokol but
    in light of the SP2 induced AI visibility problem
    I may decide not to. I really don't want to have to
    tell users they have to turn off "Aircraft casts
    shadows on the ground".

    This is with XP Pro BTW. Not Vista/DX10.

    It sure seems SP2 broke more that it "fixed", all for
    the sake of a neutered DX10 "preview". What a $^&**% boondogle! :(

    Paul
  4. Golf-HotelDelta

    Golf-HotelDelta

    Joined:
    20/12/04
    Messages:
    9,132
    Country:
    unitedkingdom
    Invisible AI in SP2 is normally caused by the inclusion of FS9 or earlier scenery objects. They may not necessarily be at your current position but could be some disatance away.

    George
  5. Gypsy Baron

    Gypsy Baron

    Joined:
    4/3/07
    Messages:
    152
    Country:
    us-california
    Thanks George. I do have some "old" scenery at
    some airports that I haven't yet gotten around to
    upgrading\modifying.
    I'll try to hunt those down and disable them
    to see if that is the case here.
    I did see that there are apparent "location specific"
    problems noted over in the Avsim posts I have
    read and this would certainly explain the
    results I am seeing.

    The linkage to "Aircraft shadows" however,
    boogles my logical engineering mind. I've got
    to assume this has something to do with the
    new SP2 shader code, which I think probably
    is also reponsible for the SP2-induced solid
    prop disc, opaque canopies and reflective
    VC texture issues....

    Paul
  6. kagazi

    kagazi

    Joined:
    3/10/07
    Messages:
    301
    Country:
    us-virginia
    There was some discussion of this at the Fly Tampa TNCM forum -some good reading on the subject.
  7. ccartmel

    ccartmel

    Joined:
    17/10/06
    Messages:
    127
    Country:
    unitedkingdom
    Another possible reason for missing AI

    Paul,
    This may be totally irrelevent, however I found that all my visible AI at Manchester UK (EGCC) mysteriously vanished after I added in extra traffic files. During the course of the session aircraft in flight landed and subsequently took off, however no AI was present from start up, although present at other airports.
    I run a full Ultimate Traffic schedule as well as several custom files which includes MyTraffic bgl for GA traffic.

    To 'resolve' this I took out ALL traffic files and slowly rebuilt checking EGCC each time. This worked until one file broke the system. Had to start again and found that the file which broke it went in OK earlier in the sequence, but that it broke again later on.

    Cannot tell you why though as nobody seems to know if there are limits as to how many files (unlikely culprit) or total file size allowable.

    It's working now and I have been able to add in smaller files without problems.

    Wierd.:(

Share This Page