1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Library Creator XML GUID problems

Discussion in 'Library Creator XML' started by arno, 14/7/04.

  1. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,300
    Country:
    netherlands
    I have received a few report now that the random GUID made by Library Creator is not always that random. After one of these reports I created a beta version that should fix it, and for the user reporting the problem it indeed did. Due to the problems with the website after that I forgot to officially release this version. The last days I heard the same problem again a few times, so I think it is time to see if this fix also solves these problems.

    A quick test showed me that when setting up this new website I put the new version online already, so everybody who downloaded the tool from this forum already has the new version.

    For everybody else, please download it from the sticky in the forum.

    To prevent problems when releasing your scenery I would advice everybody to recreate your library with the new version, so that you get new GUIDs. I understand that this also means you have to correct the placement, but it is the only way to prevent future problems with objects with the same GUID (of which I got an report already unfortunately).

    Please let me know if this new version does not seem to solve the problem with the random GUIDs, because I will search future in that case.
  2. flightsimstudios

    flightsimstudios

    Joined:
    8/2/05
    Messages:
    102
    Country:
    unitedstates
    Hey Arno, I'm wondering are you using the MS GUID generator tool in your process? Apparently this should create completely unique GUID's...

    I'm not sure the validity of the MS SDK claims but it might be worth looking into ;)
  3. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,300
    Country:
    netherlands
    This bug has long been solved :). It was a fault in initializing the randomizer.

    At the moment I do not use the MS GUID generator, because I could not find out how to link it into my VB tool. But the current code also works correct.
  4. rhumbaflappy

    rhumbaflappy Moderator Staff Member Resource contributor

    Joined:
    2/6/04
    Messages:
    2,515
    Country:
    us-wisconsin
  5. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,300
    Country:
    netherlands
    Thanks Dick, that article was easier to use then the ones I have seen before :). I have implemented it in Library Creator XML now. So when I release the next version the GUID will be determined by MS :).

Share This Page