• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Lighting Illumination Failed in P3Dv3[SOLVED]

#1
Hi,Im still new in Scenery development.I developing WMKP(penang int airport).I want to make the taxi edge light,but the illumination texture did appear when the view is overlapped with my ground poly.If its not overlapped by any ground poly,then its visible.Just like the image i attached.I used blender to do all the modelling and ps cs6 t do all the texturing.Any idea on how to fix this?
 

Attachments

#2
By design a ground polygon is drawn after just about everything else. This means that it covers landclass textures, photo real imagery, default runways, taxiways, aprons, runway edge lights, and taxiway edge lights and probably other things that I am leaving out. You will need to use some other form of lighting that will show over your ground polygon. If you look through the Wiki you will see tutorials on some of the other options.
 
#3
By design a ground polygon is drawn after just about everything else. This means that it covers landclass textures, photo real imagery, default runways, taxiways, aprons, runway edge lights, and taxiway edge lights and probably other things that I am leaving out. You will need to use some other form of lighting that will show over your ground polygon. If you look through the Wiki you will see tutorials on some of the other options.
Does that means my lightin textur is being blocked by the gp?
 
#4
From the your picture it looks like that is what is happening. You can try raising your light models a slight amount above the ground level to see if that improves things. I don't have P3D so I can't say exactly what is happening.
 
#5
From the your picture it looks like that is what is happening. You can try raising your light models a slight amount above the ground level to see if that improves things. I don't have P3D so I can't say exactly what is happening.
It was ok in FSX though.Only in P3d this problem occur.Tried using both fsx and p3d sdk.attached image is from fsx.
16651045_1469804873030173_411385681_o.png
 
#6
Two things more. First I believe that P3D v3 treats ground polygons differently than earlier versions. This may be causing the result. Secondly from your P3D image on the lights that are blocked by the ground polygon the texture that lights the ground at the base of the light is missing completely. This may be a clue as to what is happening.
 

dave hoeffgen

Resource contributor
#7
What Ed describes is quite a common issue occurring with P3D rendering ground polys:

I assume the light splashes do not Z-test alpha?
In that case they don't render in front of any other object with a material other than basic solid. (in both of the sims)

As P3D seems to render ground polygons as normal objects this issue occurs while FSX uses the legacy "ground call" which just seems to work differently.

There are a few possible solutions:
  1. Use an extra version for P3D with alpha testing. P3D does a better job blending a material against itself so that edgy border look shouldn't occur
  2. SimObjects have better quality Z-buffering and therefor always blend where they actually are. So placing the lights with SODE can solve this. For performance reasons I'd recommend to merge them into one model for that.
  3. Attach an effect instead of the light polygon. This works for small airfields, because it's quite performance consuming it is not recommended for large airports.

Hope this helps a bit :)
 
#8
What Ed describes is quite a common issue occurring with P3D rendering ground polys:

I assume the light splashes do not Z-test alpha?
In that case they don't render in front of any other object with a material other than basic solid. (in both of the sims)

As P3D seems to render ground polygons as normal objects this issue occurs while FSX uses the legacy "ground call" which just seems to work differently.

There are a few possible solutions:
  1. Use an extra version for P3D with alpha testing. P3D does a better job blending a material against itself so that edgy border look shouldn't occur
  2. SimObjects have better quality Z-buffering and therefor always blend where they actually are. So placing the lights with SODE can solve this. For performance reasons I'd recommend to merge them into one model for that.
  3. Attach an effect instead of the light polygon. This works for small airfields, because it's quite performance consuming it is not recommended for large airports.

Hope this helps a bit :)
Can you explain more about the 1st solution?
 

dave hoeffgen

Resource contributor
#9
Set "Z-Test Alpha" to true, the alpha test value so say 12 (play with it until satisfied) and the Alpha Test Function to "Greater". That's it.
What modeling program do you use btw?
 
#20
Thanks a lot! Just another clarification. In FSX version I used a dummy texture to represent day (destination and source blend set to one) and it worked perfectly. In P3D I get the desired result only with the texture set as diffuse which makes the lights also illuminate during day...

In simple words can I have the other half of the settings you use to see the whole picture? :wave:

-=Manwlo=-