1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ModelConverterX alpha 02 release

Discussion in 'ModelConverterX' started by arno, 9/9/07.

Thread Status:
Not open for further replies.
  1. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    Here is an new build of the ModelConverterX tool. Please refer to the announcement of alpha 01 for some more background information on how to use it.

    In this new version the following things have been changed:
    • Better error handling, so a more useful error message should be produced now (or at least useful for me during debugging the problem).
    • Fixed a problem that some API macros got in an endless loop while loading them.
    • Improved the way texture files are searched for the 3D preview as this could result in crashes as well. The way is still not perfect though, the tool will go a maximum of three levels up from the folder where your API macros is and then search down for the texture file. In future versions I will probably introduce a search path to make this more efficient.
    • Added more SCASM commands that are now recognised correctly.

    Please note I will be on vacation from tomorrow, so it might take a while before I respond to bugs in this version.
    Last edited: 28/9/07
  2. Ayrsimming

    Ayrsimming

    Joined:
    2/1/05
    Messages:
    110
    Country:
    scotland
    Hi Arno

    I now see my test object in 3D preview and have exported to X file but dropping the X file on XtoMDL gives me a MDL file of 0 bytes.
    I am having original reported problem with some other objects. Will hold back on fuller report until your return.
    Best wishes for a good vacation.

    Iain
    Scotflight
  3. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    Hi Iain,

    I am still here today :). What error message do you get from XtoMDL? Try to compile from the command prompt, because without the error message I have no idea if the problem is in the conversion or somewhere else.

    Also, please continuing posting bugs while I am away. I'll respond once I am back of course.
  4. bertvk

    bertvk

    Joined:
    22/6/04
    Messages:
    332
    Country:
    netherlands
    Hi Arno,
    I got the same problem as with the former version...:confused:
    Regards
    Bert
  5. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    Hi Bert,

    Can you give me the API macro you are trying to load in that case? All of the test API macros I received until now do work with the last version, but your macro might contain some different code in that case.
  6. bertvk

    bertvk

    Joined:
    22/6/04
    Messages:
    332
    Country:
    netherlands
    hi Arno,
    Here it is!
    bye
    Bert
    Last edited: 13/5/08
  7. Vora

    Vora

    Joined:
    18/9/07
    Messages:
    5
    Country:
    germany
    I tested with Al Simm's wonderful set of APIs.
    Same now with me... API shows up perfectly in the Converter, export to X works ok, but if dragged on XtoMDL it creates a 0 kb mdl file.

    Attached Files:

  8. Vora

    Vora

    Joined:
    18/9/07
    Messages:
    5
    Country:
    germany
    Oops, I forgot... the error message reads:
  9. bertvk

    bertvk

    Joined:
    22/6/04
    Messages:
    332
    Country:
    netherlands
    Hi Arno,
    No reply yet; no time left or was this API not good enough to look at?:confused:
    Regards
    Bert
  10. Ayrsimming

    Ayrsimming

    Joined:
    2/1/05
    Messages:
    110
    Country:
    scotland
    Hi Arno

    Hope your trip went well.
    I have a big error report when trying to compile my test object with command prompt and couldn't figure out way to copy to send.
    There area lot of errors similar to the error report posted earlier.

    Iain
  11. Vora

    Vora

    Joined:
    18/9/07
    Messages:
    5
    Country:
    germany
    Hi Bert,

    according to his blog Arno is on vacations in Spain. Expect an answer around next week.

    Regards,
    Volker
  12. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    Thanks, I'll see if I can reproduce the error here.
  13. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    Hi Bert,

    As mentioned in the first post in this thread, I was on vacation. So I will look at the macro later.
  14. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    Hi Iain,

    OK, I'll first test the other object for which the errors have been reported. If I can reproduce that, that might also fix your errors. If not, we'll have to look into them in a little more detail.
  15. bertvk

    bertvk

    Joined:
    22/6/04
    Messages:
    332
    Country:
    netherlands
    Sorry Arno; take your time!
    Bert
  16. ccartmel

    ccartmel

    Joined:
    17/10/06
    Messages:
    127
    Country:
    unitedkingdom
    May be me!

    Arno,
    Hope your break went well and you are fully refreshed.
    I came across your new tool when researching my SCA conversion problem posted elsewhere on your forums.
    I am using Vista and was unable to register your dll, however you intimated that this was for the 3d preview so continued on.
    I have old scenery which decompiled to .SCA files so hoped that your tool would progress this to X-file;). I received the error message attached when I tried to import.

    May be me but advice would be welcomed.

    Best Regards

    Charlie

    Attached Files:

  17. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    Hi Charlie,

    Does your SCASM file contain multiple objects? I guess that could be the reason of this error.
  18. ccartmel

    ccartmel

    Joined:
    17/10/06
    Messages:
    127
    Country:
    unitedkingdom
    Multiple objects

    Yep,
    92 of them to be exact according to the decompiler message.
  19. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,302
    Country:
    netherlands
    Hi Charlie,

    You could try to edit the SCA file and split it into pieces so that each file only contains one object (one Area - EndA block).

    I will see if I can add some support for files with multiple objects in a later version.
  20. ccartmel

    ccartmel

    Joined:
    17/10/06
    Messages:
    127
    Country:
    unitedkingdom
    splitting file

    Arno,
    Thanks for the advice. Will do that when the rains keep me indoors. I am only looking for 1 or 2 objects so must be trial and error.
    Will try to isolate the larger ones first.

    Thanks
Thread Status:
Not open for further replies.

Share This Page