1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Normals Flipped

Discussion in 'ModelConverterX' started by stevo, 1/6/09.

  1. stevo

    stevo

    Joined:
    12/6/04
    Messages:
    306
    Country:
    unitedkingdom
    Hi Arno

    In the latest release of ModelConverterX the normals seem to be flipped when opening my FS9 objects, as you can see in the picture below.

    The right picture is in the previous development release the left the latest.

    [​IMG]

    FSX objects are ok

    Stevo ;)
  2. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,300
    Country:
    netherlands
    Hi Stevo,

    Let me check, I thought I did not change anything, but it seems there is a problem. This happens on any FS2004 object, right?
  3. stevo

    stevo

    Joined:
    12/6/04
    Messages:
    306
    Country:
    unitedkingdom
    Hi Arno,

    Yes it only happens with FS9 objects.

    Interestingly when I first import the object the normals are correct, as soon as I click in the main window to rotate, zoom etc, only then does the normals flip.

    Regards

    Stevo ;)
  4. stevo

    stevo

    Joined:
    12/6/04
    Messages:
    306
    Country:
    unitedkingdom
    Hi

    Here's another FS9 MDL, exported as an FSX MDL, as you can see its inside out. LOL

    [​IMG]

    Stevo ;)
  5. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,300
    Country:
    netherlands
    Hi Stevo,

    I think I found the code that has the problem (it's a part I recently changed indeed). I am looking at it, but since I am now busy with preparing the FSDeveloper move it might take a few days.
  6. stevo

    stevo

    Joined:
    12/6/04
    Messages:
    306
    Country:
    unitedkingdom
    That's ok Arno, I'm glad you found the error.

    regards

    Stevo ;)
  7. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,300
    Country:
    netherlands
    Hi Stevo,

    I think the bug is solved now. I have commited the changes, you will find the fix in the next development release.
  8. stevo

    stevo

    Joined:
    12/6/04
    Messages:
    306
    Country:
    unitedkingdom
    All fixed Arno great work

    ;)

Share This Page