1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Partly Dissappearing Ground Polygons

Discussion in 'Airport Design General' started by blancfilms, 12/7/09.

  1. blancfilms

    blancfilms

    Joined:
    24/1/09
    Messages:
    27
    Country:
    argentina
    Hey there,

    since i´ve started to develop a Scenery for "Erfurt - Bindersleben" Airport (ICAO: EDDE) i had been on this site researching for Tutorials how to create Custom Runways and such, you know... , the basic stuff.

    So i came along Bill Womack's Great great Tutorial on creating High Quality Ground Polygons. Everything worked out nicely appart from one problem.
    When i'm for example in the Piper Cub Taxiing on those Ground Poly's they seem to disappear or flicker arround the Airplane.
    I really have no clue what is going and i hope some of you Pro's can help me out on this thing.

    On the Attachments i putted in some Screenshots of the Situation.
    Both the Taxiline and the Ground Poly´s were created in the same manner except that in the Taxiline ASM Code i inserted the number "12" instead of "8" because i wanted it to be above the Poly.

    Code:
    ADDCAT      OBJECT_0_SCALE, 12
    So, thank in advantage and excuse myself for my English, i speak German for living.

    Attached Files:

    • gp.jpg
      gp.jpg
      File size:
      95.7 KB
      Views:
      207
    • gp01.jpg
      gp01.jpg
      File size:
      96.2 KB
      Views:
      181
  2. blancfilms

    blancfilms

    Joined:
    24/1/09
    Messages:
    27
    Country:
    argentina
    Nobody has a clue?
  3. spotlope

    spotlope FSDevConf team

    Joined:
    10/6/04
    Messages:
    166
    Country:
    unitedstates
    Are you tessellating the ground polys so there's no more that approx. 100m between vertices? That's one reason we sometimes get visual anomalies. The far more common reason is that there's a problem with your underlying flatten. Make sure you've fully flattened the airport grounds, and that the flatten altitude agrees with the airport altitude.
  4. blancfilms

    blancfilms

    Joined:
    24/1/09
    Messages:
    27
    Country:
    argentina
    Yes, i already tried that out but it still does not solve my problem :(
  5. spotlope

    spotlope FSDevConf team

    Joined:
    10/6/04
    Messages:
    166
    Country:
    unitedstates
    Do you have the same problem with only one layer of polys or does it only happen when you stack a few on top of one another?
  6. flyscenery

    flyscenery

    Joined:
    25/4/09
    Messages:
    135
    What is the elevation of the object in the modeler, this happens to me when I place the taxiways to -0.1 so I can draw the taxi line.
  7. blancfilms

    blancfilms

    Joined:
    24/1/09
    Messages:
    27
    Country:
    argentina
    All the object in the Modeler are At 0,0m.
    The Taxiline on the Screenshoot was exported as an spearate BGL. I already tried putting it in the same BGL like the concrete but the Problem is still the same (flickering Concrete, 100% visible Taxiline) <-- Thats what i think is weird :confused:.
  8. flyscenery

    flyscenery

    Joined:
    25/4/09
    Messages:
    135
    What level is the taxiway line at, try using its level. Other than that I have no idea :confused:
  9. blancfilms

    blancfilms

    Joined:
    24/1/09
    Messages:
    27
    Country:
    argentina
    Like i have said, they are all at 0,0m
    Thats wahts weird
  10. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    20,551
    Country:
    netherlands
    Do you have a flatten active in the area?
  11. blancfilms

    blancfilms

    Joined:
    24/1/09
    Messages:
    27
    Country:
    argentina
    No i have not
  12. flyscenery

    flyscenery

    Joined:
    25/4/09
    Messages:
    135
    I mean the levels in the .asm, 8, 12, 16
  13. blancfilms

    blancfilms

    Joined:
    24/1/09
    Messages:
    27
    Country:
    argentina
    Like i´ve said, i had them in separate BGL on the Screenshots, the Concrete on 8 and Line on 12, however when i exported it in one BGL i set them all on the same Level and the problem persists.
  14. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    20,551
    Country:
    netherlands
    I would try to add a flatten then. Without that you are not sure if the ground is really flat. That, together with the distance between vertices of maximum 100 meters as Bill said, should make sure they display correctly.
  15. blancfilms

    blancfilms

    Joined:
    24/1/09
    Messages:
    27
    Country:
    argentina
    Ok, i tried adding a flatten by adding this line of code to the scenery.cfg

    Flatten.0=1036,N50 59.00,E10 55.98,N50 58.75,E10 59.09,N50 58.56,E10 59.08,N50 58.80,E10 55.98

    and IT WORKED.

    But i really want it to get into a BGL file.
    So i tried the tools Flattex, FSTflatten and SBuilder but i just couldn´t create a bgl with a flatten in it.

    Can somebody help me creating such a bgl?
  16. flyscenery

    flyscenery

    Joined:
    25/4/09
    Messages:
    135
    Last edited: 10/8/09
  17. blancfilms

    blancfilms

    Joined:
    24/1/09
    Messages:
    27
    Country:
    argentina
    I already used FSTflatten as mentioned in my post.

    Thanks for the link. I did it the manual way and in now got a flatten bgl and my Ground Polygons don´t flicker a bit.

    So thanks for all the support. This brings me a giant step further in my first scenery. :):)
  18. GaryGB

    GaryGB

    Joined:
    23/12/05
    Messages:
    1,385
    Country:
    us-illinois
  19. blancfilms

    blancfilms

    Joined:
    24/1/09
    Messages:
    27
    Country:
    argentina
    Yeah i tried FSTflatten but as i said it didn´t work out for me.

    When i start it it already gives me an Error 13 Type mismatch and then when i try to use the program it just bugs.

    I know how to handle it but it bugs
  20. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    20,551
    Country:
    netherlands
    Which FS version are you working with? For FS2004 I always used SBuilder and for FSX SBuilderX. In there it is quite easy to draw a flatten polygon and export it to a BGL file. If you say that does not work, maybe you can give more details on what does not work.

Share This Page