1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with exporting CAT mdl

Discussion in 'ObPlacer and ObPlacer XML' started by dr_psyser, 21/6/05.

  1. dr_psyser

    dr_psyser

    Joined:
    21/6/05
    Messages:
    17
    Country:
    australia
    G'day Everyone (this is my first post!)

    I am experiencing a problem while trying to use object placer to place a modified MDL (using CAT) - the problem is occuring in obplacer, but I am pretty sure it stems from CAT.

    I have placed a simple animation trigger (bounding area) on an animation of a car going by, I have no troubles in CAT, but when I go to compile the XML file in object placer, I get the following error message:

    C:\Program Files\SceneryDesign.org\ObPlacer XML>bglcomp compile.xml

    Parsing document: compile.xml

    ERROR C2014: Failed to load model data in file: C:\Program Files\SceneryDesign.org\Library Creator XML\MDLS\TESTCAR_cat.mdl
    ERROR C2149: Failed to load model data!
    ERROR C2340: Failed to finalize MODEL_DATA!
    ERROR C2032: XML Parse Error! Element tree follows:

    ERROR: <FSData
    ERROR: version = 9.0
    ERROR: >
    ERROR: <ModelData
    ERROR: name = 8268827B78294E55A7E740B6BBE86E93
    ERROR: sourceFile = C:\Program Files\SceneryDesign.org\Library Creator XML\MDLS\TESTCAR_cat.mdl
    ERROR: >
    ERROR:
    ERROR C2024: Failed to process closing element tag <ModelData> near line 1!


    Parse complete!


    Can anyone cast any light on the problem?

    Thanks Arno for all your work mate, you are a true legend!

    Cheers

    Jarrad
  2. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,304
    Country:
    netherlands
    Hi Jarrad,

    Can you take a look at the XML file created by ObPlacer XML? Does it contain quotes around the MDL filename? If they are missing that is probably the problem (due to the space in your path).
  3. dr_psyser

    dr_psyser

    Joined:
    21/6/05
    Messages:
    17
    Country:
    australia
    G'day Arno

    Yup I have quotations around model number.

    I have attached the XML file if you want to have a look at it.

    Cheers

    Jarrad
  4. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,304
    Country:
    netherlands
    Hi Jarrad,

    The file looks OK. How are you compiling the file? From ObPlacer XML or manual with BGLComp?
  5. dr_psyser

    dr_psyser

    Joined:
    21/6/05
    Messages:
    17
    Country:
    australia
    Thanks arno

    I'm compiling straight from ObPlacer after saving my changes to the XML. Would you recommend doing it manually?

    Cheers

    Jarrad
  6. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,304
    Country:
    netherlands
    Hi Jarrad,

    No, I thought it could be the problem if you did it manual :).

    Can you sent me your MDL file? Then I can test to compile here.
  7. dr_psyser

    dr_psyser

    Joined:
    21/6/05
    Messages:
    17
    Country:
    australia
    G'day Arno

    Thanks mate, here ya go

    Cheers

    Jarrad

    Attached Files:

  8. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,304
    Country:
    netherlands
    Hi Jarrad,

    If you are using the same file you sent me know, the problem is that they MDL name in the XML is different then the MDL file name. ANIMATE_CARS_cat.mdl vs ANIMATEDCAR_cat.mdl. Can you check if you use the correct filename? Once I change the name if compiles without errors here.

Share This Page