1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SBuilder and FSUIPC4.01

Discussion in 'Ground2k4, SBuilder, SBuilderX' started by jvile, 18/10/06.

  1. jvile

    jvile

    Joined:
    24/1/05
    Messages:
    8,020
    I ask this in another thread but it was missed.

    It appears that when I read these post some are saying they are using SBuilder with FSX. Is this TRUE or FALSE.

    When I load SBuilder ver 06 it says cannot communicate with FSUIPC when I try and place the aircraft on the grid.

    I have installed in their correct folders the FSX program plus SBuilder plus a registered version of FSUIPC 4.0

    Am I missing something on how to get Sbuilder to communicate with FSX? I am trying to slew around the Airport border so I can change the LC texture and make a VTP2 bgl.

    As a work around I did make the VTP2 poly with FS9 and then copied the bgl into FSX but I want to work directly in FSX so the airport texture is more precise in placement.

    Thanks for any help on this
  2. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    25,785
    Country:
    wales
    Well I can't answer the question Jim but I may be on the trail. I had several installations of FS9 and removed one of them when I installed FSX. My version of Sbuilder will no longer start - tells me that there is no FS2004 on my machine. I can't find anything in the ini file or registry at the moment which tells SBuilder where that FS9 install was. However I wonder if it can only see FS2004 and not FSX as I had FSX running - it must do more checks than just look for a running copy of FSUIPC. My
    programs work fine with version 4.01 so it looks just the same as version 3.xx.

    I will ask Luis.....
  3. jvile

    jvile

    Joined:
    24/1/05
    Messages:
    8,020
    Thanks

    I also see others saying that excludev2 works with FSX. Yes, exclude bgl's do work in FSX if you enter the lat/lon by hand in excludev2 but excludev2 also needs FSConnect.dll if you want to just click in the lat/lon box.

    I copied FSconnect.dll to various folders in FSX including the root but this also is not working. When I see post that says these utility's are working I keep thinking I am missing something. The utilities would work but it is the interface dll (FSUIPC, FSConnect) that does not understand where FSX is located based on what utility is in use.

    So far the only 2 programs that do find FSX by way of FSUIPC is the FSTflatten and AFCAD programs using FSUIPC 4.01.

    I have both FS9 and FSX installed in their default folders which is not a problem based on Registry entries.

    What is unique is that you can load a AFCAD airport in the AFCAD program and then start FSX and FSUIPC will interface the 2 together which is simular to how the FSTflatten program is working. I do understand the issues with flattens in FSX

    Maybe I am missing something in my FSUIPC settings to get a connection but like you say there is no path in Sbuilder to locate FSX and it seems to look for a ver 3.xx FSUIPC dll.

    I am going to try a FS9 FSUIPC 3.xx dll in FSX to see if Sbuilder can connect and if that works when I have my poly finished will revert back to the correct FSUIPC dll.
  4. jcboliveira

    jcboliveira

    Joined:
    8/6/04
    Messages:
    150
    Country:
    portugal
    Maybe sbuilder is checking FS version in FSUIPC Open. I will point this post to Luis.

    José
  5. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    25,785
    Country:
    wales

    Not sure that is the case Jose since my SBuilder will not load even if there is no FSX Running, neither if there is FS9 running
  6. jvile

    jvile

    Joined:
    24/1/05
    Messages:
    8,020
    My Sbuilder ver 2.5.0.6 loads fine with or without FS9/FSX running. I can start SBuilder and load saved files with no problem.

    As said earlier it is when I try to place the airplane crosshair on the grid that Sbuilder (when FSX is running) does not know how to find FSUIPC for the connection between the two.
  7. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    25,785
    Country:
    wales
    Hi Jim

    Yes there are two problems. Mine has nothing to do with FSX. For some reason my SBuilder can no longer find FS2004. If it is not present on your PC at the location specified in the Registry then SBuilder will not start. Guess that means do not delete your FS9 installation until Luis comes up with a fix.

    Second is the connection to FSUIPC and FSX. This may be related but may not. Luis has said that he will look at this over the weekend so maybe we will have something next week.
  8. BrBlazer

    BrBlazer

    Joined:
    15/7/04
    Messages:
    346
    Hi,

    I'm not sure if it happens to everybody, but in my case when I installed FSX, it removed for some reason I don't know, FS9 from the windows registry. Once I fixed that everything was ok. Hope it works for you.

    Kindly,

    Blazer
  9. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    25,785
    Country:
    wales
    Hmm maybe that's what happened but I am seeing an entry in the registry for FS9 - I have multiple copies installed but that did not cause problems for SBuilder before. How did you fix the registry? - maybe I am looking for the wrong thing :eek:
  10. spotlope

    spotlope FSDevConf team

    Joined:
    10/6/04
    Messages:
    173
    Country:
    unitedstates
    I'll cut in here to post my fix to the problem. The FS9 registry entry can be restored using any of a handful of utilities designed to do just that. The one I downloaded was from the TweakFS people. The site is in Flash, so I can't provide a direct link to the tool. To download, visit http://www.tweakfs.com/ and click the "Products" icon at the top, then the "Freeware Utitlities" link at the bottom left, then you can download the FS9 Reg Path utitlity. This will quickly and painlessly restore the registry entry for the FS9 path. This was all it took for me to get back up and running with SBuilder.
  11. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    25,785
    Country:
    wales
    Bill

    Pure Genius thankyou - seems that my registry entry was up the shoot but the utility fixed it and Sbuilder is back :) I had forgotten what a great set of tools Fermin has created.
    Last edited: 22/10/06
  12. Luis_Sá

    Luis_Sá Resource contributor

    Joined:
    16/9/04
    Messages:
    314
    Country:
    portugal
  13. scruffyduck

    scruffyduck Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    17/9/05
    Messages:
    25,785
    Country:
    wales

Share This Page