• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

[SOLVED] SODE not detecting traffic

#1
Hi,

Recently I have made my first successful jetway and it works with my own aircraft. However when it comes to AI detection, it seems SODE is simply ignoring them.

If I switch my own aircraft to one of the AI models the jetway works and their exits are configured properly. I have attached the log files generated in debug mode, I notice the aircraftMap is empty?

Latest version of P3Dv3, most up to date SODE available inc newest platform manager.

Help appreciated,

Andy
 

Attachments

#5
Thank you for responding Jacques!

I got the same as above, DetectionEnable set to True. The log file shows the settings by the way, so I can prove it! :D

Forgot to mention, if there's any more helpful information I could provide, just say, I will be more than happy to do so.
 
#6
Gents,

In both cases, the SODE internal aircraft map is empty, so it cannot resolve the paths to all the aircraft.cfgs of the AI aircraft (needed for extraction of the exit points).
While in JP's case, there is a SimObject path pointing to a MyTraffic/Aircraft folder, in Andy's case, I can't find a path pointing to any additional AI aircraft.
For case 1, I'd need info (or some screenshots) how the MyTraffic/Aircraft folder is organized (especially if there are aircraft.cfg files present) and for case 2, I'd need to know where the AI aircrafts are stored in the harddisk and how P3D is able to find them.
 
#7
Thanks Jeffrey.

My suspicions led me to believe that the empty aircraft map might be the culprit, good to see that I'm not totally crazy (yet, lol!)!

To try and answer your question:
First, it should be noted that the entire MyTraffic folder structure is outside of the P3D folder.
The MyTraffic\Aircraft folder is organized like Simobjects\Aircraft, with a lot of subfolders each containing one aircraft type, most with numerous paint schemes.
In each of the subfolders there is indeed an "aircraft.cfg" file for that type, as well as the usual folders "model", "texture.NN" and so forth.

(I considered posting a "dir /s" listing of the MT\Aircraft folder, but it would be a mile long!).

- JP
 
Last edited:
#8
Any chance to have a look at one of those aircraft.cfg files? There was one thing I changed from v1.4.1 to 1.4.2 to filter out non-prop and non-jet aircraft from the total folder scan (to keep the list short) Maybe the AI aircraft in mytraffic dont have that entry at all and are also being filtered out?
 
#11
After a couple of debugging sessions with Master Stähli, AI detection now works flawlessly. Here are some perfectly docked AI (and a single user aircraft) at EKBI Billund:


Just thought I'd leave this here as a small token of appreciation. Thank you very much Jeffrey! :)

- JP
 
#12
Hi JP

I have the exact same problem of AI not being detected by SODE. None of them are by the way (FAIB or TFS or etc..). SODE is working perfectly otherwise (windsocks for example).
In SODE log file it says no AI detection so maybe the problem has to do with the aircraft map.

I noticed you said that you went through some debugging sessions and fixed the issue. Could you explain what you did ? I would give it a try maybe (I have the latest version 1.4.2 version of SODE if that can help)

thanks in advance

Philippe
 
#13
Sorry Philippe, I didn't do anything except test and send Jeffrey new logs when he sent me a new test version.

There's really not much you can do on your own, except wait for a new release.

- JP
 
#14
Thanks JP

So Jeffrey if you would send me a test version of the SODE.exe I can do some testing as well at the airport that I am using as a test airport (Bordeaux LFBD using now the SODE animated jetways).
If you prefer that I send you first my log file I can do that too.

thanks in advance for your help.

Philippe
 
#17
Jeffrey

As I said problem solved with your latest version of the SODE .exe and .dll .

I will try tonight with more AI types (today my tests were done with a FAIB A319 and a FAIB A321 with success).

Philippe
 
#18
How do you change the SODE aircraft map?
Do I have to add the location of the SimObjects folder in P3D?

My log file is attached.
 

Attachments

Last edited: