1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FSXA Sound Location

Discussion in 'Sound' started by Sludge, 12/12/11.

  1. Sludge

    Sludge

    Joined:
    8/12/11
    Messages:
    12
    Country:
    us-nebraska
    Doug...

    Using your sound module, is there a way to make the sounds play only in the headset, in the same way ATC comes up ONLY in the headset?

    So instead of getting F/A-18 Betty sounds in the internal VC or external environments (via my speakers), I could get them to play in my headset.

    Later
    Sludge
  2. ddawson

    ddawson Resource contributor

    Joined:
    27/9/06
    Messages:
    397
    Country:
    canada
    Yes, if you are doing the XML coding, or are willing to change the XML gauge coding. You will need version 4.19 or later. If you don't have it, let me know.

    Doug
  3. Sludge

    Sludge

    Joined:
    8/12/11
    Messages:
    12
    Country:
    us-nebraska
    Doug...

    Excellent, that will work out really well. I should have v4.19, but I since I have NUKED recently and am re-installing everything, it will take some time. I'll holler if I don't come across the that version. Thanks.

    Sludge
  4. Sludge

    Sludge

    Joined:
    8/12/11
    Messages:
    12
    Country:
    us-nebraska
    Doug...

    After installing the latest FSX version of your DSD sound pack (DSD v4.30), I am able to get it to work as advertised (all sounds work thru the default speaker setup) w/the exception of NOT being able to get it to play in the headset.

    Maybe I'm just dense but after reading the instructions I've tried getting it to: play - using "load" (enum, 11); load/play - "load" (enum, 11), then "play" (enum, 1); then load/play/unload using - "load" (enum, 11), then "play" (enum, 1), then "unload" (enum, 10), all fail. Maybe something that I'm NOT enabling in the .INI file, specifying to enable the separate VOICE headset if avail? I see in the .INI part about "voice availability", but not sure how to use that syntax, if needed.

    Do you have anything that might help me? I have access to the Betty.XML that controls the Betty voice warnings but just dont "know how" to MOD it so that it plays in the headset only for those of us that have it, or in the main speakers for those that dont have a secondary VOICE setup.

    Later
    Sludge
    Last edited: 27/4/12
  5. Sludge

    Sludge

    Joined:
    8/12/11
    Messages:
    12
    Country:
    us-nebraska
    Doug...

    Good news, I got it fixed. What I ended up doing was doing the load command for each sound [ie. 11 (sound_Pull_Up, enum)] in an INIT.XML that runs once at startup. This loaded all the necessary sounds to the VOICE device, as the README says.

    Once I did this, the Betty sounds played only in the headset and when I DISABLED the headset in Win7, it played them thru the main speakers. Ding Dong, the Witch is dead!!

    Much thanks for this gauge, works like a champ, as advertised.

    However, FYI, in testing, another problem that came up was having multiple secondary playback devices enabled (by windows default), such as an X-Fi Titanium DIGITAL LINE-OUT, listed in the Windows playback section. This caused several other secondary sounds not to work on the main speakers, even after I had gotten the headset Betty calls working.

    For example: in using JR's Gun HUD, and Serge's BlackBox Betty gauge... I got the Betty calls working in the headset and the "gun blast" working on the main speakers but the "button clicks" for the HUD control panel (should go to main speaker) were going off to somewhere else. So I DISABLED all the other Win7 Playback Listings except the X-Fi Speakers (default speakers) and the Headset (default Comms) so now all main speaker sounds, such as "gun blast" (speakers), and "panel clicks" (speakers) work as they should.

    Later
    Sludge
    Last edited: 27/4/12
  6. ddawson

    ddawson Resource contributor

    Joined:
    27/9/06
    Messages:
    397
    Country:
    canada

Share This Page