1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trying to convert

Discussion in 'ModelConverterX' started by Grizzly_Air, 16/9/07.

  1. Grizzly_Air

    Grizzly_Air

    Joined:
    6/2/06
    Messages:
    26
    Country:
    unitedstates
    I am trying to convert some old .api macros to use in Abacus EZ-Scenery. I have a bunch of old objects I still want to use. I tries to use ModelConverterX to convert them. I guess I am not using the right tool or something.

    I need to compile them into a .BGL library to use. Here is one (attached) that would not load in modelconverter for me. None of them would load, so I guess it doesn't matter which one I send.


    I am not sure this is the right tool for the job.. any help in the right direction would be appreciated. The error I get, btw is this....


    [​IMG]

    Thanks

    Attached Files:

    • KRM.API
      File size:
      338 bytes
      Views:
      160
  2. pascal72

    pascal72

    Joined:
    3/11/04
    Messages:
    18
    Country:
    france
    hello,

    your Macro is just an Api placement of an object which is already in a library..

    if you have this library, you can certainly adapt the format for Ez-scenery and call the object, the guid is given in the api :

    3B249DA4 11D9FF8C 5C9CCF96 2678D710

    but it is normal that you cannot convert this api with ModelConverterX as the Api placement doesn't include the Model .

    I convert most of my old model EOD apis with success : I 'll post later a pack with the some ones which cause trouble..

    Best regards , pascal
  3. Grizzly_Air

    Grizzly_Air

    Joined:
    6/2/06
    Messages:
    26
    Country:
    unitedstates
    OK. I have the .bgl library, but for some reason EZ Scenery won't recognize it. So I guess it is an EZ Scenery issue then :)

    Grizz
  4. arno

    arno Administrator Staff Member FSDevConf team Resource contributor

    Joined:
    28/5/04
    Messages:
    21,285
    Country:
    netherlands
    Hi,

    It could be that your library is in the Fs2002 format then, which is not supported by EZ-Scenery (or any other XML based placement tool).

    What you could try is to decompile the library to SCASM code and then convert it to MDL objects with ModelConverterX. But that is something I have not tested before, so it might be a bit buggy still :).

Share This Page