April, 2017

HttpX and EarthProxy (GE View) Installation
OVERVIEW
One-time installations
 Install HttpX.dll and XMLTools.dll modules
o Copy HttpX.dll and XMLTools.dll to Modules folder
o Edit dll.xml file
 Install Compound_Rotation.xml in each aircraft you fly or in MiniPanel
o Copy Compound_Rotation.xml to Panel folder
o Edit panel.cfg
Run GE View
1. Start Flight Simulator
2. Double click EarthProxy.exe to start GE View

INSTALLATIONS
HttpX.dll
1. Copy HttpX.dll v.2.0 into FSX or P3D’s Modules folder. If this folder does not exist, it is
recommended to create one in the main FSX or P3D directory.
2. Locate the dll.xml file which should be in:
FSX:
C:\Users\username\AppData\Roaming\Microsoft\FSX\
or
C:\Documents and Settings\username\Application Data\Microsoft\FSX\
P3D:
C:\Users\username\AppData\Roaming\Lockheed Martin\Prepar3D v2\
or
C:\Documents and Settings\username\Application Data\Lockheed Martin\Prepar3D v2\
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3. Edit dll.xml to add the following within <Simbase.Document>
<Launch.Addon>
<Name>HttpX</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>Modules\HttpX.dll</Path>
<DllStartName>module_init</DllStartName>
<DllStopName>module_deinit</DllStopName>
</Launch.Addon>
If dll.xml is absent in P3D, copy the example dll.xml file shown at the bottom of this
document and paste into the Lockheed Martin\Prepare3D v2 folder, as above.
4. Start Flight Simulator in windowed, non-Full Screen view (Views>Full Screen toggle
OFF). If you like, change the Cockpit View Zoom factor to 0.50 (the + and – keys on your
keyboard will do this) to more closely match Google Earth zoom.
5. HttpX automatically loads each time Flight Simulator is opened.

XMLTools.dll
To enable 360 degree pan view capability in GE View, Tom Aguilo’s XMLTools for FSX or
P3D must be installed. XMLTools can be freely downloaded from the FSDeveloper
Resources site. Follow installation instructions contained in the download (it’s similar to
HttpX.dll installation).
XMLTools 2.01 for FSX:
http://fsdeveloper.com/forum/resources/xmltools-2-01-xml-expansion-module-for-fsx.148/

XMTools3D for P3D v3.x:
http://fsdeveloper.com/forum/resources/xmltools3d-for-p3d-v3-x.168/
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Compound_Rotation.xml
Compound_Rotation.xml is a small gauge that calculates Quaternion rotations necessary
to orient the Google Earth camera while panning. It’s a background calculation gauge
that won’t take up space on your cockpit panel. Tom Aguilo’s XMLTools module
(XMLEvents class) is used to capture the HAT switch azimuths needed for the rotations.
If XMLTools is not installed, GE View will still operate, but without pan view capability.
In that case, the Google Earth view will always look forward.
The essential entry in Compound_Rotation.xml is line 19:
54321 (>C:HTTP:port)
This line must be processed to enable EarthProxy communication with Flight Simulator.
Port number choice is arbitrary but must be the same as used in the EarthProxy.exe
application interface.
STANDARD INSTALLATION
1. Create a new folder named GE VIEW within the aircraft’s Panel folder.
Compound_Rotation.xml in that folder.

Place

2. Edit the aircraft’s Panel.cfg file to establish a separate Window for the gauge. As an
example:
[Window Titles]
.
.
.
Window15=GE VIEW
using whatever Windows number comes next (15 in this example).
3. Below the other 2D Windows in Panel.cfg, add the GE VIEW window parameters:
[Window15]
position=0
size_mm=110,90
visible=1
window_size_ratio=1.00
gauge00=GE VIEW!Compound_Rotation,

0, 0, 110, 90

It’s best to not set visible=0 because EarthProxy will not function until the GE VIEW
window is visible, allowing the GEViewInit initialization sequence (lines 16-21) to be
processed.
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MINIPANEL INSTALLATION
Users might find that installation of Compound_Rotation.xml in the MiniPanel folder is a
little simpler, a little faster, than adding it to each aircraft. The downside is that any
custom minipanel for an aircraft will be disabled (refer to step 4, below).
1. Unzip MiniPanel.cab. It will be found in the Gauges\MiniPanel folder.
2. Place Compound_Rotation.xml in the MiniPanel folder.
3. Edit MiniPanel.cfg by adding the lines in red, below:
[MiniPanels]
MiniPanel00=Mini Panel Gauges
MiniPanel03=GE VIEW
[MiniPanels Jet]
MiniPanel01=Mini Panel Gauges for Single Engine Aircraft
MiniPanel03=GE VIEW
[MiniPanels NoVacuum]
MiniPanel02=Mini Panel Gauges for Primitive Aircraft
MiniPanel03=GE VIEW
At the bottom of MiniPanel.cfg, add:
[MiniPanel03]
position=4
size_mm=110,90
visible=1
window_size_ratio=1.00
gauge00=MiniPanel!Compound_Rotation, 0, 0, 110, 90
4. In each aircraft you fly using GE View, edit its panel.cfg to disable the MiniPanel
window, if it exists, by adding “//”:
[Window Titles]
.
.
.
//Window07=Mini Panel
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GE VIEW DISPLAY

Compound_Rotation.xml generates a small display of some flight parameters that may
be useful to see while viewing the Google Earth screen. Right click on the GE VIEW
display window, Undock it, then drag it onto the Google Earth Window.
If the GE VIEW display isn’t wanted, it may be closed after it has been initially displayed
(confirming that the GEViewInit sequence was processed).
If you do not want the GE VIEW application to load at all, comment out the GE VIEW
window in the [Window Titles] section of panel.cfg:
//Window15=GE VIEW
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IF THE GE VIEW WINDOW DOES NOT APPEAR WHEN THE AIRCRAFT LOADS
In the event that the GE VIEW display does not appear when the aircraft loads, then
from the Flight Sim menu bar, select Views > Instrument Panel > GE VIEW and make
sure that GE VIEW is selected (checked), as shown in the picture below

The GE VIEW display should then appear which indicates the GEViewInit initialization
sequence is complete.
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OPERATION
EarthProxy.exe v1.2
1. The EarthProxy.exe file can reside anywhere, for example, your Desktop.
2. Double click EarthProxy.exe to open the application.

 Refresh Rate: Frequency at which HttpX queries FlightSim. Change if desired,
but values over 18 Hz won’t improve smoothness. Default is 16 Hz.
 Proxy Port: The EarthProxy port. Default is 10023. Change this in the event that
port 10023 is already being used.
 HttpX Port: This can be changed to any number between 1k and 65k. Default is
54321. It must match the HTTP:port number in Compound_Rotation.xml.
 HttpX IP: IP address of the machine running Flight Simulator. This feature
enables FlightSim to run on one machine and EarthProxy/Google Earth to run on
another, separate machine if desired. As long as both machines are connected
to the same network, they can communicate.
o If FlightSim and EarthProxy/Google Earth are run on the same machine,
then the HttpX IP box can be ignored. The default IP, 127.0.0.1, is
equivalent to “localhost” which is the pc running FlightSim and
EarthProxy. In a single machine setup, 127.0.0.1 is what you want.
o Alternatively, for a dual pc setup, determine HttpX IP by pressing the
Windows Key on the FlightSim host pc keyboard:
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then type CMD and press enter, then type ipconfig and press enter:

o The IP address is found on the IPv4 line. In this example, 192.168.0.107.
Enter that into the HttpX IP box in EarthProxy on the EarthProxy/Google
Earth machine.
o Confirm that Subnet Mask is the same for both the FlightSim host pc and
the remote pc running EarthProxy. Repeat the Windows Key, CMD,
ipconfig sequence on the remote pc and note the Subnet Mask.
3. Start Flight Simulator.
4. On Google Earth Proxy, click Start, and then click Open KML File. At that point,
Google Earth will open and will fly to the present aircraft position in Flight Sim.

If Google Earth opens but does not fly to the current aircraft location, then:
a) it is possible that the GEViewInit initialization sequence in Compound_Rotation.xml
was not processed or the HttpX Port numbers do not match, or
b) if you are using a 2 pc configuration, the machines may not be on the same network.
Check that Subnet Masks match and the FSX host machine IP address was entered into
HttpX IP.

8

Google Earth
Download and install Google Earth Desktop Client https://www.google.com/earth/. As
of this writing, the current desktop client Earth version is 7.1.8.3606 (Build Date 17
January 2017), but you need at least v.5.0 for the Touring tools. Either Google Earth or
Google Earth Pro are fine to use with GE View, but not Earth (v.9).
In Tools > Options > 3D View > Terrain:
 Set ‘Elevation Exaggeration’ = 1
 Click ‘Use high quality terrain’
 Click ‘Use 3D Imagery’
In Tools > Options > Navigation > Fly-To:
 Set Fly-To-Speed to 4.5000 (experiment, but >4.500 seems to yield poor results,
as does less than about 3.0000)

OTHER INFORMATION
HTTPX – EARTHPROXY ARCHITECTURE
HttpX starts an http server that reads FlightSim variables and returns their values as a
json object. EarthProxy also starts a server which takes requests from Google Earth,
proxies them to HttpX, and then converts the json to kml. Both of these servers need to
be bound to ports.

GENERAL USE
After the one-time installation of HttpX, XMLTools, and Compound_Rotation, just
double-click EarthProxy.exe to launch Google Earth .
While flying, use the joystick HAT switch to change Google Earth view direction.

TIP
To prevent automatic PAUSE of Flight Simulator whenever the Google Earth desktop
client window is clicked (which makes it the active window), de-select “Pause on task
switch” in Flight Simulator Settings:
Options > Settings > General > Program > Pause on task switch – de-select
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3D ROTATION REFERENCE
3D Rotation for Flight Simulator - Google Earth Application
(Quaternion and Euler Rotation algorithms)
http://fsdeveloper.com/forum/threads/ge-view.436365/#post-734395

JOYSTICKS, TRACKIR, AND CAPTURING PAN VIEW AZIMUTHS
To capture joystick HAT switch movement, I use Tom Aguilo’s XMLTools, as shown in
lines 5-12 of the Compound_Rotation.xml gauge. Compound_Rotation.xml, however,
may not function correctly with other FOV controllers like TrackIR.
Users that wish to edit Compound_Rotation for use with controllers like TrackIR or use
different software to capture HAT switch movement, such as javascript Gamepad API,
should keep the following in mind:
EarthProxy reads the following variables to properly orient the Google Earth camera:
 (L:GE TILT, degrees)
 (L:GE ROLL, degrees)
 (L:GE HEADING, degrees)
These L:Vars are the post-3D rotation product of the HAT switch azimuth and aircraft
attitude angles. Importantly, those three specific L:Var names are hard coded in
EarthProxy.
Users of other controllers or alternative HAT azimuth information will need to compute
proper 3D rotations and write the post-rotation camera angles to the L:Vars listed
above.
Refer to the 3D Rotation Reference, above, for additional information on Quaternion
and Euler rotation algorithms.

NEW VERSION OF GOOGLE EARTH
Google released a new version (9.0.31.6) of Earth on 18 April, 2017. It’s browser based
(Chrome only) so no download and install is necessary. Many features of desktop client
v.7 were removed, but some new ones were added to make it more informative than
before. Google has not yet provided a javascript API, so for the time being, a version of
G.E. View for use with Google Earth v.9 isn’t being developed.

10

As far as I know, there isn’t any word on Google’s plans for Earth Desktop Client (v.7) or
Desktop Client Pro (v.7). If Google eventually deprecates Earth Desktop Client, then GE
View users should switch to Earth Pro and still use HttpX.dll 2.0 and EarthProxy.exe 1.2.
It seems unlikely the Google will deprecate Earth Pro anytime soon as many businesses
use that product.

LICENSE
You may use HttpX.dll and EarthProxy.exe in both commercial and non-commercial
applications if acknowledgment is given to the author. You cannot sell HttpX.dll or
EarthProxy.exe or distribute the software through any means other than the
FSDeveloper or AVSIM sites or the BlackBox website,
http://robbiemcelrath.com/fs/blackbox/about.
This software is provided "as is", without warranty of any kind, express or implied,
including but not limited to the warranties of merchantability, fitness for a particular
purpose and noninfringement. In no event shall the authors or copyright holders be
liable for any claim, damages or other liability, whether in an action of contract, tort or
otherwise, arising from, out of or in connection with the software or the use or other
dealings in the software.
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Example dll.xml for P3D:

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
<Descr>Launch</Descr>
<Filename>dll.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>
<Launch.Addon>
<Name>HttpX</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>Modules\HttpX.dll</Path>
<DllStartName>module_init</DllStartName>
<DllStopName>module_deinit</DllStopName>
</Launch.Addon>
<Launch.Addon>
<Name>XMLTools</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>Modules\XMLTools3D.dll</Path>
<DllStartName>module_init</DllStartName>
<DllStopName>module_deinit</DllStopName>
</Launch.Addon>
</SimBase.Document>

12

