P3D v4 3DSMax 2017: Crash when trying to export *.x-file

#1
Hi there,

I have updated my 3DS Max version to 2017 recently. I also updated my Prepar3D to V 4.5.
So I installed the latest SDK as well to use the new gamepack in 3DS Max.

Here's my issue:
I cannot export my existing scenery project to x-files, althought the setup seems to work generally.
In detail: I tried to export a groundplane I have already created as a X-file to work with it in MCX. The export window appears as usual, but during the export process a warning window pops up to tell me that an error has occoured- and 3DS Max finally crashes.
I did a test. I created a simple cube, assigning a Prepar3D material (just a color), added GUID etc. and well- that worked so far.

My groundplane has worked well before updating my setup. Now what could be the point? I've also manually changed the assigned materials to "Prepar3D" (although they had already been ones).
That's quite annoying because I have nearly finished the project and now, so close to the end such a thing....

Any help highly appreciated!!!

Best,

Arne
 
#4
Well- I tried to export a newly created simple cube object out of the same scene-surprisingly, that worked fine. So I am afraid that the problem is only related to the already existing objects created with the older 3DS Max version (2015). That would mean that one has to rebuild everything! Could this be true? That would be kind of desaster :-(
 
#5
Okay here's what I've found out so far. The Issue has something to do with Multimaterial.
In my case, I have one groundplane consisting of 58 single planes. There's a Multimaterial assigned to that containing 58 sub-"Prepar3D"- materials.
I did an experiment to check if there's an error on the object itself. To do so, I assigned a new, single Prepar3D material with a plain color to the whole groundplane.
Export process then worked without any problems! I had a lot of work doing a whole new Multimaterial and reassign the submaterials I'd like to use on the groundplane to it and again- the same error and crash mentioned above.

My conclusion: The Exporter does not like (my?) multimaterial.
What is going on there? Has it something to do with the naming of the materials? Are 58 Submaterials too many? But they had worked well before...
Is Multimaterial simply not supported anymore?

What do you think?
 
#7
Its funny. That works. But its somehow unpredictable.
Yesterday we tested the scene on a system of a friend of mine wich is similar to mine. He also recently installed 3DS Max 2017 and the same latest Prepar3D gamepack. There the exporting process worked fine. So finally, I assume it must have something to do with the 3DS Max settings.
 
#9
Hi,

which 3DS-Settings are essential and to check?

The only important thing within 3DS is that the units have to be 1 Unit = 1 Meter - everything else is entirely up to you.

However - I have JUST had a similar-ish issue, my ground poly wouldn't display in sim - I tried everything to get it to work but nothing. I left it for a few minutes then tried again and it worked.
 
Top