FSX:SE ADE 1.78 won't compile a separate OBJ file.

I have upgraded to 1.78 from 1.76. I have imported a project which compiled properly from 1.76, but will not compile with a separate OBJ file in 1.78. All the libraries are imported, the Settings page is set correctly, and the 'More Options' on the compile dialogue shows that it is selected to save a separate OBJ file. So why won't it do so?

Separately, the program won't remember imported mdl files. Even though it'll show the footprint, each time I open the project, the mdl files are missing from the List view.

Lastly, the program is trying to save the xml files to the old 1.76 Project folder, which of course no longer exists. All the save routings are set correctly in Settings. Is it me, or is there a problem with 1,78?

EDIT: not only is no OBJ file compiled, but no objects appear in the sim. Yet all the objects are imported into Library Manager, and are known to ADE as can be seen from the screenshot below (yes, I know there are one or two 'black' objects).
 

Attachments

Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
OK load your project. Go to Help > Diangostics > Project Settings File. Use the Copy button and paste into a post here
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Did you import your settings from 1.76 to 1.78?
Did you create a new installation for 1.78 or did you update your 1.76 installation with 1.78?
 
Hi Jon. I’m just leaving for India, so I won’t be back on my desktop till Monday. I’ll upload the files then. It’s a new installation, not an update to 1.76 and I didn’t import the settings, I set them up manually. I did import all the project files, libraries and thumbs from 1.76 to 1.78. Fortunately I have 1.76 (and 1.77) on my laptop, so I should be able to continue working on that while I’m away.
 
Here you go, Jon:

ProjectName|EGXI_ADEX_TJC
ProjectFolder|E:\MSFS\FS Design Tools\RAF Finningley Project\RAF Finningley EGXI FSX
CompileLocation|2
culo|2
CustomCompileFolder|E:\MSFS\FS Design Tools\RAF Finningley Project\RAF Finningley EGXI FSX
CustomXmlFolder|E:\MSFS\FS Design Tools\Airport Design Editor 176\FSX\Xml
GpLayerOutOfBoundsAsked|false
CompileAirport|true
CompileGP|true
CompilePreLoad|true
CompileTerrain|true
KeepCvx|0
SaveXml|2
SplitCompile|true
CompileFileName|EGXI_ADEX_TJC
AirportIdent|EGXI
ProjectID|ca66fcbd-167e-4914-a71a-fbf55fab8225
Comment|
SyncCompileNameWithProjectName|true
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Close ADE and go to the FSX folder inside the 1.78 main folder. Find the folder called apsf. In there will be some project setting file. There will be one starting with the project name Probably be EGXI_ADEX_TJC - if it is there then delete it. Now start ADE and load the project. This is what the folder usually contains. Obviously these are my files and yours will be different

1578382668582.png


There is an issue with ADE moving project settings files from one version to another where folders listed are then deleted. If you delete the settings file then ADE will create a new one that should point to the folders listed in the main settings. These will appear as a new settings file once you re save the project.
 
Cheers Jon. I'm out doing the McDonald's health-food thing while my car is serviced! I'll give this a go when I get home later.
 
Jon, there are six different EGXI APSF files in that folder (plus the related EGCN removal files). That probably reflects the fact that this project is being worked on for FSX, P3Dv3 (because my laptop won't run anything later) and P3Dv4.5. I assume from what you say that it should be safe to delete all of them, but I thought I'd better check before I commit...
 
Hi Jon. OK, while waiting for a reply, I removed all of the APSF files to a separate folder. As you say, ADE has generated a new APSF file. However, despite all of the objects showing in ADE, it is still not generating an OBJ file and the objects are not contained within the core ADEX file. So I thought I'd try another project, this time for P3Dv4. Same result! I've attached the ad4 file in case that helps.
 

Attachments

Hi Tim,

Do you have a red rectangle at the bottom-left of the ADE screen? If so, click on it and it will give further information.

I didn't have your .mdl files so needed to remove them.

Having done so, I have bgl, CVX, GP and Obj files.
 
Hi Jon. Sorry - the mdl files are specials for me by John Young, and I'm not at liberty to share them. However, that raises another issue I'm having - ADE isn't remembering that I've loaded the models! As you can see from the attached image, the mdl objects (basically the hangars) are all black, even though I'd only just saved and closed the airport, and then reopened it. There's no red error rectangle. There are other issues in that several taxiway lines and a few surfaces are not showing in FSX:SE (which has no other addons or third-party products whatsoever). I'm beginning to wonder if there's some corruption in the chain somewhere, though this is a new PC, with a new installation of FSX:SE.
 

Attachments

Apologies, George, I didn't notice that it was you that replied, not Jon! The airfield has a number of problems in the sim, and I'm sure it's all related. I have aircraft taxiing in random directions, and taxiways and lines not showing properly. It was all behaving correctly until I transferred to 1.78. I have a feeling I'm going to end up doing a fairly comprehensive reinstallation! Fortunately, I have it working correctly on my laptop though I haven't yet tested to see if the product from that installation of of ADE works correctly, as the only sim on it is P3Dv3 and loading EGXI in that sim is too much for my old MacBook Pro to cope with!
 
Yes, the path seems to be ok - I have a special project folder for this airfield, and all the relevant mdl files are in there. ADE knows where to find them when I re-add them to the list; I don't have to redefine the path.
 
Ah. The program will compile OBJ files for new airports, but will not compile that particular one (see file attached above). I'm also getting a message "could not find a part of the path x:\blah\Airport Design Editor 176\FSX\Xml\EGXI_ADEX_TJC.xml". I've found reference to this message in another post, and I followed the instructions to delete the settings.ini file in the FSX folder, rebuild the Settings using the New User Wizard, and checked the settings when instructing the program to compile. As it attempts to do so, there's a flash of what appears to be a dialogue box, then I get that message. The other files are compiled, but no OBJ file - and no objects are included in the AD4 file. I really don't want to have to start again with this airfield!
 
Top