• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS ADE 2020 Alpha 18 Released

Instead of Add Folder try Add File. Does the same thing happen?
It wouldn't let me Add File because it already existed. I renamed the ADE-2020_Alpha folder, reinstalled Alpha 18 to G:\ADE-2020_Alpha, reapplied patch 4 so I have a fresh install again. I used Add File and it took a lot longer and gave no error messages. The Footprints now show correctly. Thanks.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
It wouldn't let me Add File because it already existed. I renamed the ADE-2020_Alpha folder, reinstalled Alpha 18 to G:\ADE-2020_Alpha, reapplied patch 4 so I have a fresh install again. I used Add File and it took a lot longer and gave no error messages. The Footprints now show correctly. Thanks.

Use Update if the LOM tell you that the file is already present

1618235632124.png
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Can you go to your task manage and check that ADE is running in 64bit mode?

1618236839422.png


Make sure there is no (32 bit) on the end of the name. If there is then I can tell you how to fix that. Meantime could you email me that library - jon AT scruffyduck DOT org

We do see errors since some of the models are very large - many time larger than the equivalent FSX/P3D models.
 
Can you go to your task manage and check that ADE is running in 64bit mode?

View attachment 71977

Make sure there is no (32 bit) on the end of the name. If there is then I can tell you how to fix that. Meantime could you email me that library - jon AT scruffyduck DOT org

We do see errors since some of the models are very large - many time larger than the equivalent FSX/P3D models.
The zip file is too large to email. You can download it at Flightsim.to unless you have another way I can get it to you.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
The mikeaat-assetpack has an object in it which ADE (using Arno's DLLs) does not like. Mikeatt-Glider-Fox. MCX doesn't decompile it either... but it can be shown and placed by the in-sim DevMode. (I'm using Arno's latest MCX DLLs in ADE and in MCX). MCX reports 'glTF binary chunk type is not valid'. I get the objects from the library into ADE excepting the Fox Glider. So this is an issue for Arno to resolve.

Untitled.png
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
The mikeaat-assetpack has an object in it which ADE (using Arno's DLLs) does not like. Mikeatt-Glider-Fox. MCX doesn't decompile it either... but it can be shown and placed by the in-sim DevMode. (I'm using Arno's latest MCX DLLs in ADE and in MCX). MCX reports 'glTF binary chunk type is not valid'. I get the objects from the library into ADE excepting the Fox Glider. So this is an issue for Arno to resolve.

View attachment 71983

Cross posted
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
The mikeaat-assetpack has an object in it which ADE (using Arno's DLLs) does not like. Mikeatt-Glider-Fox. MCX doesn't decompile it either... but it can be shown and placed by the in-sim DevMode. (I'm using Arno's latest MCX DLLs in ADE and in MCX). MCX reports 'glTF binary chunk type is not valid'. I get the objects from the library into ADE excepting the Fox Glider. So this is an issue for Arno to resolve.

View attachment 71983

If you can point me to the model, I'll have a look.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Draw Detailed Footprints is checked. Every object gives me this error. Also, this is a Microsoft install and not Steam.
View attachment 71965View attachment 71966

The error seems to come from the code that tries to read the model file. But given the code path shown in the error I don't understand it tries to do that. Jon, can ADE read gltf files directly as well or do you always load them via the bgl file?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
The error seems to come from the code that tries to read the model file. But given the code path shown in the error I don't understand it tries to do that. Jon, can ADE read gltf files directly as well or do you always load them via the bgl file?

ADE reads glTF files directly when they are added to a project via the ArtProj asset. They use your libraries to do it Arno. But in the case above they are gotten from the bgl file. In any case it seems the user was trying to load a folder for a file and the issue was solved?
 
I am occasionally having issues with my computer that causes a MEMORY_MANAGEMENT BSOD when running MSFS. I saved the airport that I am working on and clicked build which caused the BSOD loading MSFS. After rebooting the computer and loading the airport I got the error in the log. I have a 2 day old backup in another folder but is there any recovery of yesterday’s files? I tried to send the log but it just hung and never sent.

ProtoBuf.ProtoException: Invalid field in source data: 0
at ProtoBuf.ProtoReader.ReadFieldHeader()
at proto_232(Object , ProtoReader )
at ProtoBuf.Meta.TypeModel.DeserializeCore(ProtoReader reader, Type type, Object value, Boolean noAutoCreate)
at ProtoBuf.Meta.TypeModel.Deserialize(Stream source, Object value, Type type, SerializationContext context)
at ProtoBuf.Serializer.Deserialize[T](Stream source)
at ScruffyDuck.AirportDesignEditor.MainForm.OpenF20Project(String f20ProjectPath)
at ScruffyDuck.AirportDesignEditor.MainForm.OnMruListFileSelected(String path)
at ScruffyDuck.AirportDesignEditor.Helpers.MruFiles.openRecentFile(Object sender, EventArgs e)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
 

Attachments

  • F20Log_2021_04_13.zip
    2.4 KB · Views: 19

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
That is coming from the code that saves and loads files. Looks line this one was corrupted?

Is there a reason that you have commas in your file names?

1618320408693.png


I am not sure that is even possible
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
If the send log seems to hang it is probably trying to send a large project file. You can tell ADE not to send it

1618320511549.png


Uncheck Include Project State
 
That is coming from the code that saves and loads files. Looks line this one was corrupted?

Is there a reason that you have commas in your file names?

View attachment 72041

I am not sure that is even possible
That was the way that a sample that I saw did it. I haven't had any issue with that. The actual issue here is that Windows crashed loading MSFS during the build process. I can zip the project and send it if you want.
Bad-KTDF-V1,0.zip is the crashed one. KTDF-V1,0.zip is good from two days ago.
 

Attachments

  • Bad-KTDF-V1,0.zip
    272 KB · Views: 10
  • KTDF-V1,0.zip
    261.3 KB · Views: 17
Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
French decimal separator. Well it does seem to work here although I think I will stick to underbars or hyphens
 
Top