• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS ADE 2020 Alpha 21 HF5

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,891
Country
unitedkingdom
This is a quick and dirty fix to reflect the change in location for stock airports in SU9


Make backup copies of the four current files in your ADE main folder and replace them with the files from the zip

1651499479803.png


Run ADE 2020. You need to force the program to update its file path to the new location of stock airports. This is on the settings.ini file in the F20 sub folder inside the ADE main folder. You can force the change either by running the new user wizard from the Tools menu

1651499664347.png


or by temporarily changing the supplier of your version of FS 2020 (steam or MS) using Settings > Options > Folders

1651499749371.png


In either case save changes and restart ADE. You should change the source of your MSFS back to the correct one, The entry for fspath in settings,ini should point to the new location set by Asobo for stock airports

1651500433685.png


for Steam or

1651500688120.png
for MS

under the PATHS group

Test by adding a new project from stock.
 

Attachments

  • 1651499622953.png
    1651499622953.png
    9 KB · Views: 567
Worked great Jon, thanks! I went the Settings > Options > Folders route and after restarting and switching back it still didn't work but another program restart after that and it was good
 
If one is comfortable editing the settings.ini file, the update can be done with two steps.

1. Unzip the HF and copy the four files over the existing files.
2. Edit the Settings.ini file (in the FS20 folder) to change the FsPath as outlined above.

Start ADE and have fun!
...jim
 
Create Project from Stock isn't working for me. Steam. The INI seems right:

Code:
[F20]
suppliedBy=Steam
steamapplicationPath=D:\Programs\Steam\steamapps\common\MicrosoftFlightSimulator\
steamconfigsPath=C:\Users\dickl\AppData\Roaming\Microsoft Flight Simulator
steamcontentPath=D:\MSFS\Official\Steam
steamsdkPath=D:\MSFS\SDK\
steamusePackageToolForSteam=True
microsoftapplicationPath=C:\Users\dickl\AppData\Local\Microsoft\WindowsApps\Microsoft.FlightSimulator_8wekyb3d8bbwe\
microsoftconfigsPath=
microsoftcontentPath=
microsoftsdkPath=
microsoftusePackageToolForSteam=True
[PATHS]
SaveProjectFolderPath=D:\ADE_F20_Projects
FsPath=D:\MSFS\Official\Steam\Official\Steam\fs-base-genericairports
locPak=D:\MSFS\Official\Steam\Official\Steam\fs-base\en-us.locpak
LastLibraryPath=D:\MSFS\Official\Steam\microsoft-iberia-point-of-interest\scenery\microsoft\microsoft-iberia-point-of-interest
lastXml=D:\MSFS_Stuff\ADE_Alpha\ADE2020_Alpha_21\F20\xml
LastProject=D:\ADE_F20_Projects\test\test.ad20
lastBgl=D:\MSFS\Official\Steam\fs-base-genericairports\scenery\0302
 
Why do you have Microsoft Store stuff in your [F20] section? Here's mine:

Code:
[F20]
suppliedBy=steam
steamapplicationPath=G:\SteamClient\steamapps\common\MicrosoftFlightSimulator\
steamconfigsPath=G:\Users\jbwin\AppData\Roaming\Microsoft Flight Simulator
steamcontentPath=G:\FlightSim
steamsdkPath=G:\FSUtils\MSFS_SDK
steamusePackageToolForSteam=True
[PATHS]
SaveProjectFolderPath=G:\Projects
FsPath=G:\FlightSim\Official\Steam\fs-base-genericairports
locPak=G:\FlightSim\Official\Steam\fs-base\en-us.locpak
lastXml=G:\FSUtils\ADE2020\F20\xml
LastProject=G:\Projects\jb-airport-aypy-update\jb-airport-aypy-update.ad20
lastBgl=G:\FlightSim\Official\Steam\fs-base-genericairports\scenery\0000
lastImagePath=G:\Projects\CYUL-Montreal
Export=G:\Projects\CYUL-Montreal

...jim
 
Working well here. I used the wizard and then after I checked out the settings.ini file and the correct new path was there!. On Steam here.
Thanks again for the quick update
 
Worked for me too without even editing the .INI file.

Code:
[F20]
suppliedBy=Steam
steamapplicationPath=V:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\
steamconfigsPath=C:\Users\philip.STORMBAY\AppData\Roaming\Microsoft Flight Simulator
steamcontentPath=V:\Microsoft Flight Simulator
steamsdkPath=V:\MSFS_SDK\
steamusePackageToolForSteam=True
[PATHS]
SaveProjectFolderPath=V:\ADEprojects21
FsPath=V:\Microsoft Flight Simulator\Official\Steam\fs-base-genericairports
locPak=V:\Microsoft Flight Simulator\Official\Steam\fs-base\en-us.locpak
lastXml=V:\ADE_2020_Alpha21\F20\xml
LastProject=V:\ADEprojects21\ADE21HF5_YMHB\ADE21HF5_YMHB.ad20
LastLibraryPath=V:\ADEprojects21\YMLT_Launceston\Packages\airport-ymlt-launceston\Scenery\ironpot-ymlt-scenery
lastBgl=V:\MSFS_Addons\Scenery\Tasmania\nzasimulations-airport-ymhb-hobart\scenery
 
Create Project from Stock isn't working for me. Steam. The INI seems right:

Code:
[F20]
suppliedBy=Steam
steamapplicationPath=D:\Programs\Steam\steamapps\common\MicrosoftFlightSimulator\
steamconfigsPath=C:\Users\dickl\AppData\Roaming\Microsoft Flight Simulator
steamcontentPath=D:\MSFS\Official\Steam
steamsdkPath=D:\MSFS\SDK\
steamusePackageToolForSteam=True
microsoftapplicationPath=C:\Users\dickl\AppData\Local\Microsoft\WindowsApps\Microsoft.FlightSimulator_8wekyb3d8bbwe\
microsoftconfigsPath=
microsoftcontentPath=
microsoftsdkPath=
microsoftusePackageToolForSteam=True
[PATHS]
SaveProjectFolderPath=D:\ADE_F20_Projects
FsPath=D:\MSFS\Official\Steam\Official\Steam\fs-base-genericairports
locPak=D:\MSFS\Official\Steam\Official\Steam\fs-base\en-us.locpak
LastLibraryPath=D:\MSFS\Official\Steam\microsoft-iberia-point-of-interest\scenery\microsoft\microsoft-iberia-point-of-interest
lastXml=D:\MSFS_Stuff\ADE_Alpha\ADE2020_Alpha_21\F20\xml
LastProject=D:\ADE_F20_Projects\test\test.ad20
lastBgl=D:\MSFS\Official\Steam\fs-base-genericairports\scenery\0302
Dick

You seems to have \Official\Steam twice in the path. That suggests something wrong with the Content Path

1651556285047.png


Your content path is wrong for ADE

1651556432036.png


It should point to the top level folder for Content. That is D:\MSFS\
 
This is a quick and dirty fix to reflect the change in location for stock airports in SU9


Make backup copies of the four current files in your ADE main folder and replace them with the files from the zip

View attachment 81676

Run ADE 2020. You need to force the program to update its file path to the new location of stock airports. This is on the settings.ini file in the F20 sub folder inside the ADE main folder. You can force the change either by running the new user wizard from the Tools menu

View attachment 81678

or by temporarily changing the supplier of your version of FS 2020 (steam or MS) using Settings > Options > Folders

View attachment 81679

In either case save changes and restart ADE. You should change the source of your MSFS back to the correct one, The entry for fspath in settings,ini should point to the new location set by Asobo for stock airports

View attachment 81683

for Steam or

View attachment 81684for MS

under the PATHS group

Test by adding a new project from stock
Works for me. Thanks a lot!
 
Not sure what I messed up. But I deleted ADE and reinstalled, ran the wizard, and all now works.
 
On Alpha 21 HF5.

Mine keep failing too. It keep adding \Packages to the path

Was:
Code:
[F20]
suppliedBy=Steam
steamapplicationPath=E:\Games\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\
steamconfigsPath=C:\Users\James\AppData\Roaming\Microsoft Flight Simulator
steamcontentPath=E:\Games\MICROSOFT FLIGHT SIMULATOR\PACKAGES
steamsdkPath=E:\Games\MSFS-apps\MSFS SDK\
steamusePackageToolForSteam=True

Once I removed that then it works.

Code:
[F20]
suppliedBy=Steam
steamapplicationPath=E:\Games\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\
steamconfigsPath=C:\Users\James\AppData\Roaming\Microsoft Flight Simulator
steamcontentPath=E:\Games\MICROSOFT FLIGHT SIMULATOR
steamsdkPath=E:\Games\MSFS-apps\MSFS SDK\
steamusePackageToolForSteam=True

Edit: This morning it didn't want to open a stock airport again. I had to add PACKAGES\ back to the path to get it to work. Makes no sense to me.
 
Last edited:
Good evening after another update yesterday, when I build a project, I get a “Provided project definition file does not exist error” I made a new project to test, and I still get the same errorView attachment 81927

On Alpha 21 HF5.

Mine keep failing too. It keep adding \Packages to the path

Was:
Code:
[F20]
suppliedBy=Steam
steamapplicationPath=E:\Games\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\
steamconfigsPath=C:\Users\James\AppData\Roaming\Microsoft Flight Simulator
steamcontentPath=E:\Games\MICROSOFT FLIGHT SIMULATOR\PACKAGES
steamsdkPath=E:\Games\MSFS-apps\MSFS SDK\
steamusePackageToolForSteam=True

Once I removed that then it works.

Code:
[F20]
suppliedBy=Steam
steamapplicationPath=E:\Games\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\
steamconfigsPath=C:\Users\James\AppData\Roaming\Microsoft Flight Simulator
steamcontentPath=E:\Games\MICROSOFT FLIGHT SIMULATOR
steamsdkPath=E:\Games\MSFS-apps\MSFS SDK\
steamusePackageToolForSteam=True
I also deleted all the files in the folder and re-saved everything that worked for me
 
Every time I try to build a project it tries to run MSFS and freezes. I've tried with and without MSFS running No error message. Here's my settings file

[GENERAL]
HelpUrl=https://scruffyduck.screenstepslive.com/s/help_docs/
AutoConnectToFs=True
DesignerInitials=ev
MessageTimer=2
AutosaveInterval=5
AutoSurface=True
ShowGrid=True
ImageComplexity=6
[UNITS]
Distance=2
Dimension=0
Parking=0
Altitude=0
Coords=0
[VIEW]
LibraryObjects=True
GenericBuildings=True
Navaids=False
[PARKING]
DOCK_GA=20
FUEL=16
GATE_HEAVY=36
GATE_MEDIUM=23
GATE_SMALL=18
NONE=15
RAMP_CARGO=50
RAMP_GA=20
RAMP_GA_LARGE=18
RAMP_GA_MEDIUM=14
RAMP_GA_SMALL=10
RAMP_MIL_CARGO=44
RAMP_MIL_COMBAT=26
VEHICLE=5
[F20]
suppliedBy=Steam
steamapplicationPath=D:\Games\Steam\steamapps\common\MicrosoftFlightSimulator\
steamconfigsPath=C:\Users\evand\AppData\Roaming\Microsoft Flight Simulator
steamcontentPath=D:\Games\FS2020
steamsdkPath=D:\Games\FS2020\MSFS SDK\
steamusePackageToolForSteam=True
[PATHS]
SaveProjectFolderPath=D:\ADE\F20
FsPath=D:\Games\FS2020\Official\Steam\fs-base-genericairports
[WINDOW]
Top=50
Left=50
Width=900
Height=600
State=Maximized
[DEFAULTS]
DefaultLinkSurface=CONCRETE
DefaultLinkWidth=30.48
DefaultApronSurface=CONCRETE
DefaultGateType=RAMP_GA


EDIT: Nevermind. Uninstall and reinstall seems to have cleared it up
 
Last edited:
Every time I try to build a project it tries to run MSFS and freezes. I've tried with and without MSFS running No error message. Here's my settings file




EDIT: Nevermind. Uninstall and reinstall seems to have cleared it up
I have also tried this and everything else, nothing seems to help just keeps on giving an error guess I have to wait for a HF6
 
I feel like Microsoft or whoever is working on the sim, is isolated from 3rd party developers, (unless you're some well-reputed company like orbx)
they keep pushing updates that make addon developer change their whole assets to fit in the game :(
 
Updating the stock indexes is also not working after the location change for the generic airports.
 
Back
Top