P3D v4 AIPFv3: Error Message

#1
Hi everyone,

Just starting out with the AI world, so apologies for newbie question.

Have download and installed AIFPv3.2.09 and it appears to open and run OK, however when I go to the FILES menu and attempt to open/import a FLIGHTPLAN into AIPFv3, I receive the following ERROR message: (see Attachment).

I'm running AIFPv3 on Windows 10/64bit platform and AIFPv3 when launched recognises my P3Dv4 as the TARGET VERSION.

Any help or advice/guidance would be very much appreciated, or if there's any more info I can provide for you.

Many thanks for your time
John
 

Attachments

gadgets

Resource contributor
#3
I suspect your have one or more applications enabled using add-on.xml file(s) that declare simobjects, and AIFP is having trouble reading the associated .xml files. Please attempt to isolate which add-on .xml files is causing the difficulty and send me the add-on.xml.

You can either post the file or e-mail it to me at don at stuff4fs dot com.

Don
 
#4
Hi Don, Tom

Tom, I have tried several different flight plans but they ALL give the same error.

Don, I've only just switched to P3Dv4 from FSX so I'm still finding my way around. The only .xml file I can find that appears to be linked to SimObjects is my A2A simulation file. (I've attached a copy for your attention Below). If this is not the file you require please let me know and any suggestions on how I can Identify the culprit file for you.

I really appreciate your Help.
 

Attachments

gadgets

Resource contributor
#5
John, that file was the culprit. AIFP was checking it for additional simobjects (as it should), but loaded the XML incorrectly.

Please download Development Release 3.2.09(j) from http://stuff4fs.com. That fixes the problem - on my system at least.

Don
 
#6
Hi Don,

Have followed your link and advice, but the Development Release file available for download is version 3.2.09 (i) .......... and NOT (j)

I have continued to download the (i) version anyhow and try it out, but unfortunately I'm getting the same ERROR result using this 3.2.09 (i) version.

I'll try again tomorrow, just in case the (j) version becomes available.

Great site by the way.

Many thanks
John
 

gadgets

Resource contributor
#7
Oops! Forgot to update the control file on the website. Please try again,

Yes, (i) will have the same difficulty but, with a little luck, (j) won't.

Don
 
#8
Hi Don,

Ok, I've downloaded the (j) version and Installed it. The results are as follows:

1) Launched AIFPv3 and selected File menu / Open Flight Plan ....... and choose a Plan.
2) a NEW ERROR message was reported. (copy of Error Attached).
3) Have also attached a copy of the C:\Users\John\Documents\Prepar3D v4 Add-ons\AI Traffic - Aircraft\add-on.xml..... file in question the error referred to.
4) When I closed the ERROR window down, the Error window did indeed close,..... and the flight plan I chose/selected then proceeded to load into the AIFPv3 application window as expected. (pic attached).

Hope this info may help you.

John
 

Attachments

#12
Hi Don,

Thanks for the update,......... Absolutely Perfect.

and the best Technical Support I have ever received.

Have a great day Don and Many Thanks.

John
 
#13
I'M NOT SAFE IF THIS IS THE RIGHT PLACE FOR THIS MESSAGE.
Help:
I have installed Windows 10 64 bit. I was never able to start FSX.
1- The FSX screen appears, Displays the message "Completing the installation, Generating the scenery file indexes".
2- Next: "Generating a database for new scenery files.
3- Then the Windows message appears: "Fatal error, Windows is looking for a solution to the problem".
4- "Microsoft Flight Simulator is restarting". Restarts.
5- Repeat the message 3.
6- "The program stopped working correctly due to a problem. Windows will close the program and notify you if a solution exists.
THEN FSX CLOSES AND DOES NOT HAPPEN BUT NOTHING.
 

gadgets

Resource contributor
#15
Thanks for the kudos, John.

Bilia, FSX works fine under Win10/64. But, that being said, most of us will have installed FSX under an earlier operating system. Did you have FSX running under any other operating system on this computer? If not, perhaps FSX didn't install properly. Have you tried uninstalling and re-installing FSX? If FSX worked previously, why did you re-install it? Did you uninstall the previous installation? Is there anything unusual about this computer, the way you are attempting to use it or any unusual other programs installed? Are you having any other difficulties with this computer?

Until we have some insight into these areas, its impossible to assess where the problem might lie.

Also, this forum is devoted to AIFP, which is an addon application for FS/P3D. Perhaps you should also post in a more general FSX support forum.

Don
 
#16
First, make sure you have not installed FSX into any Program Files folder. If you did, uninstall it and reinstall into a different folder (I use FS/FSX).
 

Pyscen

Resource contributor
#17
It Works fine, in Windows 10 (even if it is installed in the Program Files folder, without "permissions" (UAC) being turned off).
 
Top