Aircraft.cfg help.

I just downloaded some AI aircraft for my FS9 including FSX AI Bureaus A320 and textures for Air Canada to United but i have two problems.The first is my United texture is missing it's model radius and parking spot and the other problem is some of my other airlines like Spirit and Jetblue I Heart Blue York and the Frontier Airlines Bighorn Sheep texture variants are not showing up in my AI Aircraft Editor on AI Flight Planner.I space them and renumbered them fine like i always do but it's still doesn't work.
 

gadgets

Resource contributor
I just downloaded some AI aircraft for my FS9 including FSX AI Bureaus A320
Are the aircraft compatible with FS9?

my United texture is missing it's model radius and parking spot
Model radius is normally defined in the .mdl file. Do you mean aircraft.cfg wingspan? If so, look up the wingspan on the web and insert it yourself. Parking spot is not defined in the aircraft.cfg. It is determined by Flightsim. But, if you mean Parking Type, once again, you can supply that.

the other problem is some of my other airlines like Spirit and Jetblue I Heart Blue York and the Frontier Airlines Bighorn Sheep texture variants are not showing up in my AI Aircraft Editor on AI Flight Planner
Can't hep you there. If the aircraft are properly installed in the Aircraft folder, AIFP will find them.

Don
 
I downloaded only the FS9 versions from Flightsim.com.My United .mdl file can't be found according to AIFP so yes the model radius is not there,is there anyway to fix this on AIFP.As for the other textures that are missing,the A320 IAE & CFM aircraft folders show up fine on the editor in AIFP,but when i go to Use Selected aircraft,only some of the airline textures show up while the others are missing.
 

gadgets

Resource contributor
.My United .mdl file can't be found according to AIFP
That suggests the installed aircraft is not in a standard format. Without seeing the aircraft, I can't comment further.

the A320 IAE & CFM aircraft folders show up fine on the editor in AIFP,but when i go to Use Selected aircraft,only some of the airline textures show up while the others are missing.
This reinforces my earlier thought.

Rather than continuing to generalise, please attach the flight plan data you are using (AIG archive, fileset or traffic file) and (a link to) the downloaded aircraft file(s) so I can replicate your situation

Don
 
Where's your flight plan? As I said above, I need it to replicate your situation.
Sorry,but i don't have flight plans.I usually download AI aircraft first from the many freeware websites like FS.com & Avsim and then check on the AIFP AI Aircraft Editor first to make sure the aircraft textures are there,then i make the flight plan,unless i'm doing it wrong.The other flight plans i have already are working fine because their listed in the AI Aircraft Editor on AIFP.
 
Last edited:

gadgets

Resource contributor
The aircraft file you designated is a the base aircraft file. You've obviously downloaded some repaints as well, but you haven't told me which ones. Unless I know exactly what aircraft data you are looking at, I can't help you.

Since no one else is reporting issues with AIFP's Aircraft Editor, I think you can assume the issues probably lie with the aircraft/repaints. (Not everything you download from the Internet is "good" - though given the developer, the base aircraft is likely "solid".

As for how to fix the issues, AIFP has told you what's wrong. If you wish to use those aircraft, you'll have to "dig into" the aircraft.cfg file and replace whatever is missing that's needed for AI.

Don
 
The aircraft file you designated is a the base aircraft file. You've obviously downloaded some repaints as well, but you haven't told me which ones. Unless I know exactly what aircraft data you are looking at, I can't help you.

Since no one else is reporting issues with AIFP's Aircraft Editor, I think you can assume the issues probably lie with the aircraft/repaints. (Not everything you download from the Internet is "good" - though given the developer, the base aircraft is likely "solid".

As for how to fix the issues, AIFP has told you what's wrong. If you wish to use those aircraft, you'll have to "dig into" the aircraft.cfg file and replace whatever is missing that's needed for AI.

Don
Thanks,i think it is the repaints that i have always had problems with.I just downloaded DJC,Evolve AI A320-200 and i downloaded Jetblue and Frontier repaints for it but only the JB repaints show up while the Frontier ones don't.Even the AI Aircraft Editor by Owls Nest doesn't have the Frontier repaints listed.
 

gadgets

Resource contributor
So, compare the aircraft.cfg file from one of the bad ones with that from one of the good ones and ensure the [Fltsim.x] items (like "Model") point to existing files. Doing so should highlight both missing and erroneous items. The SDK contains an exhaustive description of aircraft.cfg files.

Don
 

tgibson

Resource contributor
Post the fltsim sections of one model's aircraft.cfg file and let us know which ones show up and which ones don't.
 
After experimenting with the aircraft.cfg file.I found out that need to add a different name for the title below the [flightsim] section by adding Frontier 2 to the cfg file and now it shows up.I guess you need to number them if there the same airline repaint.I also fixed the model radius for one of them by copying and pasting another aircraft model to it.
 

tgibson

Resource contributor
Each title= and ui_variation= line must be unique - no other aircraft or livery should duplicate them.
 
Top