FSXA Airport ground polygon gap lines

Hi there,
I made an airport photo ground polygon with GMAX, for mapping the textures (1024x1024px), I used UVW Map for each polygon . I did not have a trouble on FS9 but in FSX, the gap lines between polygons appeared clearly .
What did they come from : either Mapping or export problem ? I'm using MCX for export ground polygon and I've also set the altitude for my ground polygon at the same elev. with in afcad file .

Trieu
 

Attachments

hcornea

Resource contributor
This is usually due to mipmaps and mapping close to the edge.

Pull your mapping in from each corner by 5px.

Alternatively, you can remove mipmaps, but this will create visual artefacts in most circumstances.
 
This is usually due to mipmaps and mapping close to the edge.

Pull your mapping in from each corner by 5px.

Alternatively, you can remove mipmaps, but this will create visual artefacts in most circumstances.
Are you talking about re-mapping the texture with UVW Map for each polygon ? For each polygon when I use UVW Map, it shows the map aeria is 1025.24x1025.24 in meters . I tried to remap it to 1024x1024m but the gap lines still there .
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

You need to map the texture so that the outer 1 or 2 pixels are not used. That will fix the problem. So instead of going from 0 to 1, your UV coordinates should go from 0.002 to 0.998.
 

hcornea

Resource contributor
Maps are expressed as fractional units (ie from 0.00 to 1.00, as Arno has)

Are you perhaps referring to the size of the geometry that carries the mapped texture?
 
Thanks all,
I've mapped all textures again with Unwrap and re-position the vertexes . It worked fine now :) I don't know why in FS9, I don't need to do these steps but it still work ;)
Regards,
Trieu Pham
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

In fs2004 we had this issue already as well, I can't remember if it was less severe than in fsx.
 
Top