FSXA Alpha Channels Not Transparent Using DXTBmp As Final Texture

#1
I have never had this happen before but for some reason my alpha channels are not transparent in sim. The materials I am using were imported from Rhino 3D where I built and textured the model. I have passed the model through GMax to rig it and apply the textures that have already been placed in Rhino. I believe the issue is because some of the materials had their own alpha maps and have carried over but I have deleted all of them so it is all just a defused map output.. Any Ideas?...
 
#3
I tried a bunch of stuff early on so I really couldn't say for sure... How can I check?.. Is it as simple as clicking on the Set Default Opaque?..
 
#4
If you want alpha to control transparency just make sure the Source Blend is SrcAlpha and Destination Blend is InvSrcAlpha. The 'Set Default Transparent' button is just a shortcut to that blend setting. To ignore alpha, pressing Set Default Opaque gives you One/Zero as the blend. The FSX SDK section on Materials explains all the blend modes.
 
#5
Alright, that was it... A big THANK YOU!.. Now I'm wondering how I created this almost exact process two years ago without knowing this. It looks god now though. Thanks again...
 
Top