FSX Autogen annotator not showing results

#1
i'm having an issue where after comleting and saving the agn files, they do not appear in fsx. This is affecting vegitation boxes and polgons, and buildings.

The scenery project features a photo background over a heavily modified airport made with ADEx.

My question is, does the airport flatten affect the ability to show agn files? The background is flatten only, no classmask or autogen suppresion required because its a photo background that suppresses default autogen already.

Any tips from other more experianced users of annotator are greatly appreciated.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

It could be that runways and other scenery objects are excluding the autogen. Did you only place autogen close to the airport or does it also happen further away? A flatten should not exclude autogen normally.

And your photo background is a photo scenery made with resample?
 
#3
I've tried clearing any objects away from my autogen regions. I may go through the scenery list and make sure everything is listed <NoAutogenSuppression>, but I'm pretty sure that's not the issue. Double check is always worthwhile though.

I have successfully placed autogen in other areas, not on the airport itself.

I compiled the background photo with resample.
 

HolgerSandmann

Resource contributor
#4
Hi there,

I've see issues with autogen suppression if an object exclude box with the tag "exclude all" was used even though the Terrain SDK (BGL Compiler section, ExclusionRectangles subsection) specifically states that this would not affect autogen. Thus, I usually uncheck the "exclude all" box and use the other options as needed instead.

Cheers, Holger
 
#6
Ok...jeez now I'm getting frustrated. I can't get the annotator to save anything I do. I consistently get a message "error saving". See the image attachment.
To outline the problems...first I had the issue described above. I tried to fix it by deleting the previous autogen files, tweaking the excludes in ADE, then opening annotator to start again.
And now this problem. What am I doing wrong here?
 

Attachments

#8
Yes I have the folder structure. This is very frustrating because the whole project is complete with the exception of the autogen in the region around the airport. I had generated autogen files already, however as described above, they were not rendering in FSX. So I deleted all the .agn files that weren't doing anything and started fresh with annotator.

Now I'm stuck at this unknown error, with no idea what is causing it.

Is it possible that the previous .agn file generation has caused some sort of attribute to the photo background BGL? Or perhaps annotator is calling on the terrain.cfg or scenery.cfg file that somehow are modified from the previous .agn files that are now missing (because I deleted them)?

If I can't figure out why this is happening I may have to resort to using scenery object vegetation and buildings, but this is obviously not a desirable solution.
 
#9
Try moving your photo .bgl to a folder on your desktop and then try the annotator again, my guess is UAC won't let the annotator write .agn files into Program Files (x86).
 
#10
Good call...
I seem to think I already tried to run it through my scenery working file on another drive, but I'll give this a shot and report back.
 
#11
Try moving your photo .bgl to a folder on your desktop and then try the annotator again, my guess is UAC won't let the annotator write .agn files into Program Files (x86).
Ok that takes care of that problem. Thank you for the solution.

The problem noted in the OP continues to persist however. I can't put my finger on it. It aeems to be only happening over the background image bgl for that region. I have 3 background image bgl files to cover the airport at the desired LOD, and autogen will show onall but this one...

Scratching my head...
 
#13
Yes, all required bgl files are in the same scenery folder. The agn files are correctly located in the associated texture folder.
There has to be something I'm missing with an exclude or something, but I'll be darned if I can figure out what might be causing it. I'll keep tinkering and let you guys know if I find any success.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#14
I'm afraid most of us have run out of ideas as well by now. Without the files to actually test it with, it's hard to tell what is going on.

Are you sure the missing area matched one of the photo scenery files exactly? Because then it might be something with that file.
 
#15
I would try moving everything out of the scenery folder except for the 3 photoreal .bgls. That should tell you if it's an exclude problem or an actual problem with the .agn files. If the agn works then you could put the .bgls back a few at a time until you figure out which one is causing the problem. Does the airport have a ground poly?
 
#16
I would try moving everything out of the scenery folder except for the 3 photoreal .bgls. That should tell you if it's an exclude problem or an actual problem with the .agn files. If the agn works then you could put the .bgls back a few at a time until you figure out which one is causing the problem. Does the airport have a ground poly?
This is exactly the method I'm going to have to resort to when I get some time.
The ol' scenery refresh button is in for a workout...
 
#17
Testing has revealed the following information thus far....
The ground Poly BGL generated with ADE seems to be a partial source of the problem. I tried running the GP.bgl file through bgl2xml, but it told me the file was not created with BGLcomp...? :?

Anyhow, a couple screen captures to illustrate the issue....

Here is the scenery with the ground poly BGL removed. The autogen looks just fine, showing up nicely over the airport flatten and the photo bgl...
kosh_GPbgl removed.jpg



And then I put the ground poly bgl into FSX, and it erases the autogen in a line that appears to coincide with the westernmost limit of the ground poly draws...
kosh_GP bgl added.jpg
 
#18
Yes, GPs will exclude autogen to an extent. The effect can be minimised using the create options (see the GP manual supplied with ADE).

GPs are not created by BglComp so can not be decompiled by Bgl2Xml.
 
#19
Thank you George for the point in the right direction.
After reading the GP manual from ADE, I understood the issue a little more. I researched a little into the dummy scale command, and quickly realized the dummy was me.:banghead: I will skip that solution for the time being.

I used the bottom radio button option when compiling the GP's to make the regions 100 meters. This produced good results. I will experiment with the effect of modifying that number, but for now, the problem is resolved for my liking.

Thank you to all for the assistance!:wave:
 
Top