• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

autogen anotator components crash after start

After installing the SDK, upgrading it over the service packs to ACC I tried to use the autogen anotator.

But sadly all I got was a crash to desktop.
I quickly found the reason for the MSXML error message but even after placing default.xml, the problem persisted.

Over this weekend I tried to install the SDK on 4 more machines (my developer gear at work), including a nearly clean XP-SP2.

Always the same result.

Finally on one of the developer machines I selected debug on the crash screen and started VC2005. There I could trace the problem to the xceed-components (same directory as Annotator.exe) which throw an exception on initialisation.

I even tried to exchange these with more recent once, but then you get a different error message (they don't fit to the Annotator.exe)

If anybody has an idea whats going, please tell me, I'm stuck.:confused:
 
Last edited:
Ok one more try

This is the error message that is raised.

EventType : clr20r3 P1 : annotator.exe P2 : 10.0.61637.0
P3 : 46fada69 P4 : xceed.dockingwindows P5 : 1.0.6279.0
P6 : 447af1a9 P7 : 3bc P8 : d6 P9 : system.typeinitialization

So does anybody know whats wrong with this **** dot.net crap ?
 
Hello,

I have the same problems !!!
On my old PentiumIV machine with XP pro absolute no problem. But on my E6600 and E8600 machines with XP pro no chance. Shortly after start of annonator I have a ctd!
I'm in the same situation as TheDoctor.
Does noone has a solution for that? Are we the only ones having such difficulties or does noone use this little program??

Bernhard
 
Hi Folks

LOL
Somehow missed these threads,
I've been having the same issue since ~June 2008. :confused:

I somehow got past the exceed error.

Now get a -
.NET Runtime 2.0 Error Reporting

EventType clr20r3,
P1 annotator.exe,
P2 10.0.61637.0,
P3 46fada69,
P4 mscorlib,
P5 2.0.0.0,
P6 492b834a,
P7 3ee,
P8 a,
P9 n3ctrye2kn3c34sgl4zqyrbfte4m13nb,
P10 NIL.


ATB
Paul
 
I have no problem with annotator except for the bewildering assortment of windows and dialogs :eek:



And a misplaced area of the photographic scenery :rolleyes:
 
Hi Folks

OK -
Got annotator.exe working again. :D



Side question -
Do either of you have Visual Studio 2008 Express installed ?



Following actions were primarily performed while resolving the Missions - Go To Briefing - CTD (FSX/A) issue.



None of the following worked -
- Uninstalling/reinstalling the SDK, (fully correctly configured).
- Copying across a mate's version. :rolleyes:
- Removing an incompatible .NET version set, (MFC80.dll v1833).
- Uninstalling/reinstalling ALL .NET versions.
- Applied all MS updates.
- Applied all VCredist versions.
- Turning off advanced text services.
- Running in a lower OS compatibility mode.
Still not working. :confused:



From what I can see -
annotator.exe utilises an aspnet_client
and a .NET misconfiguration may be the underlying cause.



Take a look in -
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
Find mscorlib.dll
Check its version, (should be v3082 or later).



Ensure you've applied ALL possible MS updates,
including -
Microsoft .NET Framework 3.5 Service Pack 1
which managed to break the relevant .NET 2 functionality.

Then apply the appropriate version from -
An update for the .NET Framework 3.5 Service Pack 1 is available



Now try first launching AutogenEditor.exe
Then launch annotator.exe
Does it work now ?

If so,
on subsequent attempts
annotator.exe should launch directly.



HTH
ATB
Paul
 
Last edited:

rhumbaflappy

Administrator
Staff member
Resource contributor
Hi Paul.

Thanks for another good catch!

When I try to get the newer update, I get to the link using your URL just fine. But clicking on their


Download the Microsoft .NET Framework 3.5 Family Update for Windows XP x86 and Windows Server 2003 x86 package now.

...sends me off to an unavailable web page. So I'm stuck for now.

I wonder what else VS 2008 updates have broken?

Dick
 
Hi FOlks

Dick -
Was your annotator not working either ?

microsoft.com downloads can be slow to respond.

Working for me ATM.

HTH
ATB
Paul
 
Last edited:

rhumbaflappy

Administrator
Staff member
Resource contributor
Hi Paul.

Persistance pays off, and I was able to download the 3 files.

My Annotator is / was working fine. And I find this odd, as I have been using the standard .NET 3.5 updates, and use VS 2008 Express C# VB and C++, and have been using VS 2005 Express.

Why some are bitten by the bug, and I'm not is a mystery.

I figured I would like to have copies of the fixes in the eventuality that I might get the Annotator crash.

Dick
 
Hi Folks

Cheers Dick.
I do think they're two seperate issues.

The non-working annotator
was recognized months before the mission issue.

Though I can't guarantee I'd tried loading any missions during the intervening period. :D



I think my annotator issue
probably stemmed from installing one of -
- XP SP3 (very unlikely as most XP users would be having problems)
- MS Office Basic 2003 (again very unlikely, as it's an older product than FSX RTM)
- AutoCAD Map 3D 2009 (most likely)

Possibly some other Windows Update,
though again,
I'd expect that to be more widely reported.



HTH
ATB
Paul
 
Top