Autogen suppression and GPs elevation

#1
Hi, I have some problems with GP and autogen in the airport (LIPH) I'm creating to practice. When I run P3D v4.3 the airport compiled with "FS8 style GPs", the ground is flatten but the autogen around is a little bit suppressed (as the photos show):
2019-2-18_21-21-36-278.jpg 2019-2-18_21-21-51-895.jpg
When the option is unchecked this is the result (you can see the difference in trees around the river):
2019-2-18_21-17-50-378.jpg 2019-2-18_21-19-10-913.jpg

I hope anyone knows a solution for this thing.

P.S.: sorry for my bad english
 
#2
Hello:

You may wish to review the concept in this thread:

https://www.fsdeveloper.com/forum/threads/how-to-prevent-autogen-and-
scenery-interfering.16077/

That thread discusses changing assigned Altitude AMSL for placement via edits to the XML source code prior to compilation by SDK BGLComp.

AFAIK, a comparable result might be achieved for your legacy format G-Poly by changing assigned Altitude for placement via edits to the *.SCA source code for the RefPoint prior to compilation via SCASM.

If necessary, the G-Poly VTP Layer number can be changed after first editing the RefPoint Altitude offset value in Meters AMSL.

If that BGL has already been output by MCX G-Poly Wizard, it can be decompiled with BGLAnalyze. version 3.1 or ScDis version 2.3 to make the above cited edits.

If you have an example G-Poly BGL you want tested, package the BGL with the mapped texture(s) in a ZIP file and attach it to a reply in this thread.

GaryGB
 
#3
Thank you for the reply. I used ADE for the GP objects. I tried open bgl file with the BGLAnalyze, but when the file isn't compiled with fs8 option the program refuses to open it. I tried many times with different approaches in MCX but without any result. I don't know if there is another quick way to do ground poly, because apparently is the only solution for me. I attach GP bgl file and textures. Thanks in advance!
 

Attachments

#4
The G-Polys made via ADE GP Editor tool are not compiled with SCASM, and are in a different BGL format, so some versions of MCX may have a problem importing that type of file.

In some cases, one may 'edit' a SCASM decompiled *.SCA file derived from a ADE G-Poly so that MCX can import it. ;)


However, with no edits, I am able to successfully import your BGL into MCX 1.4x development version from December 6, 2018.


FYI: In the MCX G-Poly Wizard, the option checkbox: "Prevent Autogen Exc;usion" ...has not been 'checked'.


I do not have P3D to test with, but this legacy format SCASM / ASM type of G-Poly should display in both FSX and P3D.

However, it will have limited "Material Properties"; if that is not your goal, and you actually want to implement a greater number of "Material Properties and Functions", you could export it as a P3D MDL-based G-Poly from MCX G-Poly Wizard.


If you had not planned to implement any "Material Properties and Functions" with your G-Poly, you might save yourself some headaches by instead using a custom photo-real imagery BGL ...which is compiled via SDK Resample. :idea:


Do you have a current development of MCX installed on your computer ? :scratchch

https://www.fsdeveloper.com/forum/resources/modelconverterx.92/

GaryGB
 
Last edited:
Top