Autogen vegetation out of bounds

#1
Hi,
I created autogen vegetation with Scenproc to match with my photo scenery.
Used QGIS to define accurate vegetation zones and types (see right image).
In QGIS everything seems to be strictly within limits, but in FSX the vegetation sometimes gets out of bounds (left image).

1523552272740.png

Have no clue why this happen.
Thank you for your help.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

First thing is that while rendering the FS engine doesn't use the polygons. It converts them to a raster again with a certain resolution. This resolution is a setting and by default not very high. As a result of that vegetation can be placed a bit outside of the polygon. You can increase the setting of course.

Second, what kind of vegetation are you using? It almost seems like your tree models are groups of trees. If the models are bigger, it is harder to keep them inside the polygon of course.
 
#3
Hello Arno,
thank you so much for your reply.

I will apply your recommendation concerning the "resolution".
Where do I find this setting ?

I use the following GUID values for my vegetation

#CREATE VEGETATION
CreateAGNPolyVeg|FTYPE=POLYGON;type=city-park;treetype=mixed|{b7c05b80-45e9-4faf-9548-6a3e59c02dd6}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=Forest-mixed|{5c8a0426-3db1-4032-b7db-83eaccde7baa}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=define|{5c8a0426-3db1-4032-b7db-83eaccde7baa}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=scrub|{6dc2e489-bb03-4cf6-adc9-0e95edbf099f}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=city-park;treetype=platane|{40d962d9-e236-4015-8e63-425ad5aca940}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=city-park;treetype=hetre|{dbd96f34-ab55-4a12-8b7c-a2abe1ae94c8}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=city-park;treetype=bouleau|{edc0dc64-8bd5-4ecb-96e8-3bf157d8901c}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=city-park;treetype=maronnier|{a6f8cecb-66ea-4288-ad97-f436d6c92ee4};{33c037bf-6fb5-47ed-bdf6-d7b4bb3b4ada}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=Forest-Laub|{577426c2-538c-45df-8222-72713b61e5b1};{8EF6A032-8AA8-48F0-80EA-90A16B3696DD}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=city-park;treetype=peuplier|{4900d03d-a791-42b5-9d52-b2bd8baba0b8};{36ef9d19-4c8b-4dda-ae5f-c0d257125caf};{77b006a5-2233-479e-9eee-fc054d96a988}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=Forest-Tannen|{0a7dd9ef-9e7f-4140-9ae8-5d1d5047176b};{6dc2e489-bb03-4cf6-adc9-0e95edbf099f}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=orchard|{3bc47dea-ccc4-46b4-bd2a-2bb6d9dedc11};{66ee71a0-a29e-42de-95ce-7f403d515a58}
#
CreateAGNPolyVeg|FTYPE=POLYGON;type=vineyard|{3a639b74-23c0-4207-ada1-2cd093aa0137}

Thank you again
Chris
 
#5
Added this line to my fsx.cfg and now it's almost perfect :))

1523632958754.png


Now I still have to find out why autogen appears and disappears everytime I change the view angle with my hat-switch.
My PC is almost new and the components are rather high-end : so I guess it might be another settings issue.

Thanks again.
Chris
 
#6
If you are on FSX, then the autogen will pop up at a certain distance depending on other settings indeed.
By the way, not everything will be perfect because in between the kind of autogen vegetation you are using, there will be vegetation groupings that have a bigger area than the ones where no groupings are in (you could try to change the weight of those but no 100% guarantee there).
 
#8
Yes, Dave, that is where it should go. But are you sure you added it to the correct fsx.cfg?
The one that is normally in C:\Users\User\Appdata\Roaming\Microsoft\FSX?
Just write in (without the quotation marks): IMAGE_PIXELS_FOR_AUTOGEN_POLYGONS=1024
 

dave hoeffgen

Resource contributor
#9
Yes, Dave, that is where it should go. But are you sure you added it to the correct fsx.cfg?
The one that is normally in C:\Users\User\Appdata\Roaming\Microsoft\FSX?
Just write in (without the quotation marks): IMAGE_PIXELS_FOR_AUTOGEN_POLYGONS=1024
Yes, I did so. Is it still possible that trees stand in rivers? Maybe if the river is narrow enough?
 
Top