• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSXA Automatic Mipmapping with DX9?

Horst18519

Moderator
Resource contributor
I've only used DX10 mode for quite a time now, so my development also builds on DX10. In order to use BGL Lights without problems I now switched back to DX9 - and was surprised to find my ground polys getting totally blurry. :eek:
I use DXT 3 with no mipmaps. In DX10 they're 100% sharp, but with DX9 they get blurred just like if I used mipmaps.
Has anybody solved this problem for DX9 users?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Often those blurries are caused by textures that do not have mipmaps. Did you try to add them?
 

Horst18519

Moderator
Resource contributor
Unfortunately, quite the opposite, see attached images.
No matter if I use mipmaps or not (no difference with DXT1, DXT3 or DXT3 either), the only way not to have a blurred runway is to use DX10 and no mipmaps. :(

But that surely can't be the solution here. There must be some trick to get the textures stay sharper.
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Humm, that looks quite bad indeed. Did you check in the ASM file if the texture scale is correct in the texture list? That affects the selection of mipmaps.
 

Horst18519

Moderator
Resource contributor
The object is an FSX model, so no ASM tweak there. As the runway is sloped I couldn't see a way to use a 2002 groundpoly. Maybe it would work better with FS9 materials?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Ah, I assumed that it were ground polygons :). For FSX MDL objects I have not seen such big blurries before, let me think a bit more about this.
 

Horst18519

Moderator
Resource contributor
I've also taken some time to consider what might be going wrong and I'm still lost. The bitmaps are DXT1 or DXT3 1024x1024, there's no apparent reason for them to blurr like this.
In fact the left lower part (behind the PAPI) is a cutout that I made with FS2002 groundpolys (just a small area around the PAPI to make sure that doesn't vanish behind the ground object) and the blurring is exactly the same there as you can see. So no matter if I use FSX FS9 or FS2002 materials, 3D MDL or groundpoly - the blurring is there. Maybe it's just my gfx card? (ATI Radeon 4850)
 

Horst18519

Moderator
Resource contributor
OK, forget everything I wrote. :banghead:

For some reason the "MipBias=..." entry in my fsx.cfg got lost - and the result is what you've seen above. Interesting how DX10 doesn't care much about it if you don't use mipmap textures.
Anyway, putting the line back into my fsx.cfg and using a value of 4 or 5 saved the day. Thanks Arno, after your last reply I knew it must've to do with my gfx settings! :)

I will surely keep this in mind for customers complaining about blurred textures. Lesson learned. :D
 

Horst18519

Moderator
Resource contributor
A short addition. In my case FSX does not seem to like MipBias=4 - or it's the default value. If I run FSX and end it, the entry is gone. MipBias=5 works well, but ends in some textures being just a bit too sharp. :eek: lots of Moiree...
But in combination with medium or "performance" MipMap settings in the Catalyst Control Center of the gfx card this seems to be ok too.
 

Horst18519

Moderator
Resource contributor
Sure, because everything alse than =4 also stays. I guess =4 is the default value so FSX deletes it because it thinks it's unnecessary.
I will try 7 though, allthough I didn't find any difference between 5 and 6.
 
Top