BGLComp Will No Longer Compile - MSXML 4 Bad Install

Hi fellars,

I tried finding a solution to this problem at the FlightSim forums and although my friends over there have tried to help, things are not working out. Although I've been simming for years and have become fairly adept at customizing my sim, this is my first post in this important site. I'm glad to be part of the community.

First of all, my current system specs:

OS: W7-64HP
CPU: Intel i5 M460 @2.53GHz
RAM: 4GB
GPU: ATI Mobility Radeon HD 5730 (2GB)

Secondly, I use FS9 and FSX. However, FS9 is my simulator of choice. That sim has grown to some 120GB. I have no addons on FSX, except FSUIPC4 4.70c (the latest, but unregistered).

The simulators are installed in the following paths:

* C:\Flight Simulation\Flight Simulator 9 [addons are inside the last folder]

* C:\Flight Simulation\Microsoft Flight Simulator X

The issue:

About ten days ago, I installed all the Microsoft FS9 SDKs (except Traffic Toolbox, which I already had). These were all downloaded directly from MS, btw.

Shortly after installing them, I noticed that ExcBuilder would no longer compile BGLs. However, it put out XMLs. I tried ADE (v1.47.7), which has been installed on my computer for some time, but it could not compile either. I then tried to drag a good XML to bglcomp.exe but that did not work -- on all instances of it (i.e. the ExcBuilder folder, the one in ADE and the one with the MS BGLComp SDK). I also tried Command Prompt, but no luck.

In all instances, I get the same infamous error message (see attachment "Error").

All of the above applies to FS9. I haven't tried compiling with FSX via ADE.

* I checked the Environment Checker and everything is as it should be, including decimal (see attachment "Environment Checker").

* I checked if any of the MS SDKs could have caused this problem. It is possible that the Microsoft ATC_Voicepack_SDK (not to be confused with EditVoicepack) caused it through some unusual or faulty registry change. This may or may not be the case, so there is no need to get into that debate.

* I de-installed the above SDK, but I still could not compile BGLs.

* I re-installed the above SDK, but I still could not compile BGLs.

* I de-installed MSXML 4.0 SP3 Update, SP3, SP2 Update and SP2, in that order, with UAC off and with a restart between every de-install.

* I re-installed the above in reverse order and following the same procedure (see attachment "Add-Remove Programs") and turned UAC back on. I still can't compile.

I am attaching two files that list the MSXML contents of the System32 and SysWOW64 folders. Notice that the contents are not quite the same. For example -- and possibly important -- msxml.dll and msxmlr.dll are not in System32. Should they be? Another thing that may be of importance is that the versions of MSXML 4.0 are not the same: System32 contains SP2 and SysWOW64 contains SP3. Should they be the same?

Also of note is the fact that msxml4.dll also resides (by default) in the root FS9 folder (as SP2) and in the Microsoft ATC_Voicepack_SDK (also as SP2, but set to "Read Only"). Please see attachments "FS9 Root" and "ATC_Voicepack_SDK".

I am at a total loss as to what could be causing bglcomp.exe to not compile. I can only think of the following things:

* Should I copy msxml.dll and msxmlr.dll from the SysWOW64 folder to the System32 folder?

* Should I un-register and re-register certain MSXML files via Command Prompt? (I did that twice, but maybe I did it the wrong way, even though the system said it was successful.)

* Should I uncheck the "Read Only" box mentioned above?

* Should I take out the empty FS2004SDK folder that somehow found its way into the Program Files (x86) folder? (I installed the SDKs into C:\Flight Simulation\Flight Simulator 9\FS2004SDK, so I have no idea how or why it created a folder in Program Files [x86].)

* Should I turn UAC off forever? (Not cool.)

* Should I de-install and re-install ADE?

* Is there something wrong in the registry that has to be fixed? (I use Uniblue's Registry Booster and it shows that everything is fine. I have never had a problem with this program, btw.)

* Should I use a combination of these?

I think that's it, guys. Please, please help me with this because I must be able to compile! Thanx.

PS: I have also attached a little exclude XML for FS9 to see if it compiles on your machine (see attachment "TUPW_exc"). I never had a problem with it before.

PPS: If someone could please attach a valid XML for FSX, that would be great. I would like to see if the FSX BGLComp is messed up too.
 

Attachments

Last edited by a moderator:
Welcome

Your attached file compiles fine using both the FS9 and the FSX compilers.

Exclusion rectangles are not FS version specific since few changes have been made to the coding since FS9 was released. That means either the FS9 or the FSX compiler will compile an exclusion rectangle as long as the correct .xsd file is nesting in the same compiler folder.

What is being excluded must also agree with the SDK.

Example:

excludeAllObjects is recognized by both the FS9 and FSX SDK.
excludeExtrusionBridgeObjects is a FSX only exclude

Now we need to see if ADE is pointing to the correct SDK folders or where the compilers are located. I am on my way out the door so someone will be here shortly.
 
Last edited:
I thought that was probably the case. Thanx for letting me know.

Any ideas regarding the problem I'm having?

Also, do you have msxml.dll and msxmlr.dll (both with no number) in your System32 folder? Which OS are you using?
 
Last edited:
arcueil

I am on my way out the door. Jon, George or someone will be along shortly :)

I am using Windows 7 64bit which I updated last week. Was using Vista 32
 
Last edited:
OK, I got time... been at this for four days!

When you get the chance, please check your System32 folder. I'll wait for the other fellows to drop by.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
The compiler error that you refer to is generally caused by not having MSXML 4 installed properly.

Even if the Environment Checker finds it I would recommend reinstalling the latest SP for MSXML 4

http://www.microsoft.com/download/en/details.aspx?id=15697

Just install using the full msi file and see if that helps.

Also please look in the FS9 folder inside ADE and find log_201107.log. Please email it to me - jon AT scruffyduck.co.uk
 
Last edited:
Thank you, Jon. I've already un-installed and re-installed MSXML 4.0 several times, but the problem persists.

Quote:

* I de-installed MSXML 4.0 SP3 Update, SP3, SP2 Update and SP2, in that order, with UAC off and with a restart between every de-install.

* I re-installed the above in reverse order and following the same procedure (see attachment "Add-Remove Programs") and turned UAC back on.

[end quote]

I used the MSI for both SPs and the .exe for the updates.

Am I doing something wrong or missing something? Do I have to manually un-register and re-register any of the files? If so, which ones and in exactly what manner?

Also, my question regarding the files in System32 and SysWOW64 is important. Please see the attached files regarding those.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
OK I am not going to be much help. The only time I see this error is when MSXML 4 is not properly installed or is missing.

Can you confirm for me that you are loading an airport into ADE and then click File > Compile.

A number of the errors refer to loadFrom.xml. This file only gets created when something (airport etc) is loaded into ADE via XML. I don't think this has anything to do with the problem because I see one faile attempt to compile:


INTERNAL COMPILER ERROR C1003: Failed to create MSXML object! (0x80040154)

Parsing document: C:\Users\Jose Carrero\Desktop\EGPG_ADE9_LMG.xml

ERROR C2470: Unrecoverable error parsing XML!
ERROR C2006: Parse failed (0x80004005)
ERROR C2003: Failed to process file: C:\Users\Jose Carrero\Desktop\EGPG_ADE9_LMG.xml
I assume from this that you have ADE pointed to your desktop to compile and save your bgl files...... Certainly you loaded an xml file into ADE from there:

23:38:54:INFO_: lastXml=C:\Users\Jose Carrero\Desktop
I see no save folders though si I assume you have not tried to save a project yet
 
Hi Jon,

I bought a new computer at the end of last year and have been gradually installing my FS stuff. ADE was installed into this computer only a couple of months ago. That's why no projects have been saved. (I had ADE on my old computer and used it often, but those projects are no longer with me due to catastrophic backup drive failure several months ago.)

I've tried loading a few XMLs. One of these is toward the end of the log -- EGPG_ADE9_LMG.xml. I think that's the only one that says "UNKNOWN BglComp". That test file was actually a simple and valid airport project that I found on this website. It loaded to ADE fine (as an airport project) and when I tested to see if it would compile, it did not. It only put out the XML. I tried loading that XML, but the program would not do it.

I have not set ADE to compile to the desktop or anywhere else, to my knowledge, because, like I said, I installed ADE on this machine two months ago and haven't had the chance to use it. I had only been using ExcBuilder lately.

Anyway, the whole "MSXML 4.0 is missing or not properly installed" has been ringing in my ears for days. The problem is that it is not missing or not installed. As for "properly", I don't know because I can't seem to be able to get a clear answer to my questions.

I basically need to start with the W7-64 folders/files question in order to have at least some sort of foundation as to where to begin. Can you or someone else please open the System32 and SysWOW64 folders and see what is in there vis-a-vis MSXML?

After I have an answer regarding that, then I can try to figure out if there is something missing. If there is, I'll deal with that. If there isn't, then I need to know if I must manually un-register/re-register any of these files (i.e. which ones) and how.

I'll stay posted. Thanx.
 
Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
OK

Here are the entries on my system (Win7 64bit):

System32


WOW64


To the best of my knowledge the only one that is significant here is MSXML 4 - that is the version that BglComp is targeted on.

Certainly my setup works as it should.
 
You're absolutely correct -- BGLComp only requires v4. However, I read in various tech forums that some functionality in 4 will not be available if there are certain earlier items missing. I have no idea how that applies to us, but it's worth keeping in mind. That's why I needed to see what you have.

I'm analyzing your attachment right now. I'll come back in a bit.
 
Your two folders have identical contents -- even the dates and times. That's amazing.

My v3 and v6 are the same versions (but different dates and times; SysWOW64 also contains msxml3a.dll), while v4 are different versions -- System32 is SP2, while SysWOW64 is SP3. Additionally, mine has msxml.dll and msxmlr.dll (no number) in SysWOW64.

I've installed MSXML 4.0 several times. I don't know what to do...
 
Last edited:
I'm going to de-install again MSXML 4.0 SP2 and SP3 (with updates). I'm hoping that if I re-install only SP3 (with no updates) things will work out. I'll come back tomorrow and report.
 
This is what W7 installed in my programs with the KB number



System32 Folder shows no msxml 4.0





SysWOW64 has the msxml 4.0

 
This is just nuts. I've done something like 80-90 restarts and have spent some 75 hours on this during the last five days. I've also tried just about every conceivable method of getting this simple thing to work, but no dice.

Today, I tried installing MSXML 4.0 SP3 only, as I said on my previous post, but it did not work. I tried installing the SP3 KB afterward, but it did not work. I copied msxml4.dll and msxml4r.dll from SysWOW64 to System32, but that didn't work either, even after manually un-registering and re-registering in System32.

I noticed that when I de-install SP2 or SP3, no changes are made at all in System32 or SysWOW64. The same happens when I install -- nothing. The items show on the add-remove, but if one goes to the two relevant folders, no changes have taken place.

I tried by using the CABs as well, but although I can extract the files and place them in System32, BGLComp still won't work, even after un-registering and re-registering...

Now, jvile posted an attachment that shows he's got no MSXML 4 at all in System32! Thanx very much for posting that piece of info, btw! :)

The attachment shows something that is totally contrary to everything I've read everywhere, and Jon's and yours truly's setup. Yet it works for him... I don't get it.

I suppose I can see if *not* placing MSXML 4.0 in System32 does anything, other than making my computer explode by re-starting it to destruction.

Anyhow, why can't the MSI(s) or the KB(s) make any changes in the System32 and SysWOW64 folders? I've turned UAC off for these procedures, and I'm the only Administrator or User on this computer. Is this some sort of "permissions" issue? I tried giving my Administrator account "full permission" instead of the default "special" but even that won't work! What the heck am I doing wrong?!

BTW, Jon, which SP are you using? 2 or 3?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
SP3 if you are referring to MSXML 4 - at least I think I am. I assume you have tried another program other than ADE that uses MSXML 4?
 
Yeah, man -- ADE, ExcBuilder and the MS BGLComp SDK. None work. When you get a chance, please confirm if it's SP2 or 3 (add-remove programs).

Do you suppose that the advice I was given elsewhere to turn UAC off while I do these un-install re-install procedures is bogus?
 
Last edited:
Top