• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Blende to MSFS - No longer have live editing

Messages
7
Country
australia
Hi all,
This is very strange. For over 6 months I’ve had no issue with live editing. For example, I work on a model in blender, I make a new object and texture it, then export. Without touching anything in the SDK, the sim pauses for a split second and then I see the changes in real time within the sim. This seems to have stopped working since SU5. So my work around was to do a build, close the Project, reopen and build and then load in editor. (Without closing the sim) For this current project I have about 30 models so far all of which I have been unable to live edit like I used to. Then yesterday, out of nowhere, after changing nothing my live editing started working again!! I finished that model and started a new one (within the same project) and my issue is back where I can no longer live edit. I have mymodelLib Type as ‘ModelLib’ and not as ‘ArtProj’ as someone suggested. Has anyone got any ideas?
 
Messages
39
Country
canada
Hi all,
This is very strange. For over 6 months I’ve had no issue with live editing. For example, I work on a model in blender, I make a new object and texture it, then export. Without touching anything in the SDK, the sim pauses for a split second and then I see the changes in real time within the sim. This seems to have stopped working since SU5. So my work around was to do a build, close the Project, reopen and build and then load in editor. (Without closing the sim) For this current project I have about 30 models so far all of which I have been unable to live edit like I used to. Then yesterday, out of nowhere, after changing nothing my live editing started working again!! I finished that model and started a new one (within the same project) and my issue is back where I can no longer live edit. I have mymodelLib Type as ‘ModelLib’ and not as ‘ArtProj’ as someone suggested. Has anyone got any ideas?
I have been looking for an answer me too
 
Messages
23
Country
australia
Hi Dan, I have just got back into our project and noticed the same thing so wondering if you've gotten to the bottom of it?

I also have an issue where if I build in sim, all my buildings change to unkown and no longer display. Building the package in the package tool out of the sim restores everything to normal. I am unable to follow your process above as every time I try to close my project my sim crashes.

Do you have any wisdom on either of these subjects?
 
Messages
7
Country
australia
Hi Dan, I have just got back into our project and noticed the same thing so wondering if you've gotten to the bottom of it?

I also have an issue where if I build in sim, all my buildings change to unkown and no longer display. Building the package in the package tool out of the sim restores everything to normal. I am unable to follow your process above as every time I try to close my project my sim crashes.

Do you have any wisdom on either of these subjects?
Unfortunately I haven’t worked it out. It’s been this way since SU5 for me. I can still see updates on sim but I need to:

1. export gltf in blender as normal
2. Build Package
3. Close project
4. Open project
5. build package again
6. Load in editor

And hopefully then I’m able to see any changes made in blender. If that doesn’t work I just repeat the above steps until it works.
Previously I could just export in blender and go back to the sim, it’ll pause for a second and then automatically update the changes in sim.
 
Messages
23
Country
australia
Previously I could just export in blender and go back to the sim, it’ll pause for a second and then automatically update the changes in sim.
Yeah same here. Unfortunately I can't build in the sim either (all my buildings disappear and become "unkown") so my process is even longer....

1. export gltf in blender as normal
2. Close sim
3. Build Package using fspackagetool
4. Open sim
5. Open project
6. Load in editor

Asobo need to sort their shit out
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,866
Country
us-wisconsin
Yeah same here. Unfortunately I can't build in the sim either (all my buildings disappear and become "unkown") so my process is even longer....

1. export gltf in blender as normal
2. Close sim
3. Build Package using fspackagetool
4. Open sim
5. Open project
6. Load in editor

Asobo need to sort their shit out
Do you have the Steam version or the MS version?
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,866
Country
us-wisconsin
With the Steam version, I'm able to use a batchfile to compile a package outside the sim while it's running in DevMode. For example:

Code:
D:\Programs\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator -I ";" BuildAssetPackages "D:\MSFS_Projects\LakeLawnAirport\AirportProject.xml" "D:\MSFS_Projects\LakeLawnAirport" "D:\MSFS_Projects\LakeLawnAirport" FORCE CONSOLE
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,866
Country
us-wisconsin
The above batch compilation doesn't help. It does create a new package, but that was never the problem. The problem is the sim refuses to accept a change to the package because the package is cached to the Virtual File System.

To un-cache the package, you need to ESC to the main menu. Then, change your model or texture, open the project in DevMode, Clean All, Build All, while still in the main menu. Then click on the World Map and re-enter the airport. Click Ready to Fly, and now the change will show as the Virtual File System has reloaded the changes into it's cache. This apparently VFS loads the cache when entering the world map. This is quite awkward and time wasting.

There is a slight shortcut that will do this. Create a flight plan with the airport as both the departure and destination. (This creates a PLN and a FLT file, which I place on the desktop for convenience).
When in the sim, at the airport, with your scenery loaded in DevMode, press ESC to escape. While in the escape screen, make your changes to the package (changed model or textures, etc...). Now Clean ALL, and Build All from that escape screen. Then load your pre-saved FLT of your airport. Your changes should now be re-loaded to the VFS cache.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,866
Country
us-wisconsin
I found something I think is faster.

Sim in windows mode. DevMode active and at your airport. Minimize the sim and open the folder holding your project.
Delete the Packages folder and the _PackageInt folder ( this is essentially a Clean All ).
Copy the changed model and textures to the appropriate PackaceSources sub-folder.
Expand the sim window (still in DevMode with your package loaded). Click Build All.
The change should load.
 
Last edited:
Messages
96
Country
russia
I found something I think is faster.

Copy the changed model and textures to the appropriate PackaceSources sub-folder.
It is not entirely clear where you need to take and copy the modified model and textures. Blender modifies these files in the PackaceSources sub-folder immediately after building.
 
Messages
39
Country
canada
Spent hours trying to figure out what is going on with any success ended up in scenary editor with all my buildings listed as unknown it is a real mess and real pain working with such program. I just wanted to correct some of my models very frustrating
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,866
Country
us-wisconsin
It is not entirely clear where you need to take and copy the modified model and textures. Blender modifies these files in the PackaceSources sub-folder immediately after building.
At that point, gelete the Packages and _PackageInt folders. In DevMode click Build All. The VFS rebuilds it's cache and the change should show.
 
Messages
110
Country
russia
Is there a way to make the Simobjects auto-reload as well? My scenery objects reloading currently works just fine, but I can't for the life of me make the static simobjects reload without restarting the sim altogether.
 
Messages
53
Country
nigeria
One thing i did that worked for me when live editing stopped working was as follows

Export the model from blender and then open the gltf in notepad++, then i just delete any random line and then i press ctrl+z to undo the delete action. This will cause notepad++ to think a change has been made and it will now allow you save the file , just ctrl+s and save and the model will be reloaded in the sim.
 
Messages
7
Country
australia
What Ive been doing as a workaround is after making any changes in blender and then doing an export, simply move the three files (gtlf, bin and xml) out of the modellib folder(simply drag it out to an empty folder which I named 'workaround') and simply drag it back to the modellib folder and it then updates in realtime in sim.
 
Messages
39
Country
canada
What Ive been doing as a workaround is after making any changes in blender and then doing an export, simply move the three files (gtlf, bin and xml) out of the modellib folder(simply drag it out to an empty folder which I named 'workaround') and simply drag it back to the modellib folder and it then updates in realtime in sim.
Thank you Dmajestic80 I tried your workaround and it works for me very useful because I am working on lightning my scenery I have to make a lot of tests to adjust the lights position, size and intensity much faster than reloading the simulator
 
Messages
35
Country
france
Sorry to reactivate this thread, maybe it has been updated somewhere elese, as I'm facing now this same annoying issue. What is the good parameters, from Blender or from MSFS, to keep this great Blender object update live inside MSFS? I did some test and didn't find anything relevant.

Why, when I export my Blender object (with the Asobo exporter), to my Modellibs folder, the .gltf/.bin file date changed but this doesn't trigger MSFS to reload the object? When I manually edit - as previously mentioned by @Risuali45 - this triggers immediately the reload from MSFS ?

Edit: Instead of editing with Notepad++ and faking a modification to change date of the file, I open the property window of the gltf file, set it to Hidden -> Apply, then untick Hidden and re-apply.

Thanks to the community :)
 
Last edited:
Messages
748
Country
italy
Sorry to reactivate this thread, maybe it has been updated somewhere elese, as I'm facing now this same annoying issue. What is the good parameters, from Blender or from MSFS, to keep this great Blender object update live inside MSFS?

Why, when I export my Blender object (with the Asobo exporter), to my Modellibs folder, the .gltf/.bin file date changed but this doesn't trigger MSFS to reload the object? When I manually edit - as previously mentioned by @Risuali45 - this triggers immediately the reload from MSFS ?

Thanks to the community :)
Why, you should ask Asobo 😅
An un-textured object reloads automatically
A textured one requires the manual edit/save of the gltf to show the update
That's because (the console tells) texture cannot be updated live (texture reloading unsupported).
Maybe, the reason is that textures too gets updated each exports, so the compiler reads a change in them before reading the glTF, and refuse continuing the loading .
Maybe, avoiding to export the textures will trigger the object reloading

But then you will have to remember to export the textures back again when finished the editing

So, the quick open glft with notepad and save is a viable and rather fast solution
 
Messages
35
Country
france
Why, you should ask Asobo 😅
[Mode Joke=ON] I'm stuck with them (on https://devsupport.flightsimulator....camera-suddenly-below-ground-level-or-wi.html) with the Developer Camera eratic behaviour and can't reproduce for sure the issue ;) [Mode Joke=OFF]

But then you will have to remember to export the textures back again when finished the editing
Just made a quick test. Thanks. Good idea. It reloads the object but I got pink texture if I set "Keep Original" on the GLTF exporter ;)

So, the quick open glft with notepad and save is a viable and rather fast solution
Did "faster" (if it worths it) by playing with the gltf file properties "Read-only" -> Apply (and reset to Read-only unticked)
 
Top