• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS (Blender) - Collision not working on a particular 3D asset

Messages
77
Country
france
Hi guys,


We were about to publish our scenery and we just view that the collision were not working at all of almost of our objects.

So, I decided to try with a test cube and a child cube with colision and it worked.
Then I tried to make lods just to be sure that was not the issue here and it worked good too.

Finally I decided to post here to see if someone could took an eye in this blender file and tell me if you have collision or not like me ?

I'm kinda lost on this problem and any help would be very nice :)


 
Messages
14
Country
france
How many vertices has your model ? Collision will not work if an object of your model has too much vertices. The solution is to create a less detailed version of your object (which can be linked in your blender model), add the collision extension on it, and remove the collision extension to the more detailed object.

Hope this helps.
 
Messages
77
Country
france
Hi and thanks,

I have already a child wich is a cube (6 faces) with the invisible material set and the collision checked. The parent has not more than 6k faces
But this is very weird since on my other sceneries, I didn't have that weird issue..
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
4,781
Country
us-wisconsin
I used your .blend file. I deleted the collision box. I made a huge icosa sphere, much larger than the hangar object ( maybe 50 meters), with 4 sub-divisions. I then selected the icosa sphere, and used a modifier: shrinkwrap, and chose the hangar as the target, setting the offset to 0.01m.

I then select everything and CTRL-A and apply to all transforms.

The new shrink-wrapped icosa is now the crash mesh. I set it's material as MSFS Invisible, and set the collision tag.

When you save as MSFS glTF, make sure you tick 'Apply Modifiers' under Geometry.

Untitled.png
 
Messages
77
Country
france
Hi, Have you tried it ?
I tried this way (with icosphese and shinkwrap too) and in my case the result was negative

I will check again tomorrow thanks


I just tried you method and I it still doesn't work
When I'm in the "y" mode, the plane goes on top of the collisionable icosphere but no collision on the wall so far
 
Last edited:
Messages
14
Country
france
Yes, it is important to check this option. Also, you can check the resulting gltf file: it must have those lines for the collision to work properly:

Code:
...
"ASOBO_tags" : {
                    "tags" : [
                        "Collision"
                    ]
                },

...
 
Messages
77
Country
france
The tag is here
I have compared the glft to the other one that are working and no differences..
 
Messages
14
Country
france
Do your model have different Lods ? However, MSFS/Asobo devs indicated that in the next SDK update, there will be a collision debug feature. Maybe wait for the next SDK update, and you will resolve your issue.
 
Messages
77
Country
france
Do your model have different Lods ? However, MSFS/Asobo devs indicated that in the next SDK update, there will be a collision debug feature. Maybe wait for the next SDK update, and you will resolve your issue.
Indeed, I have LOD0 -> LOD3, but I tried to make some lods on my blender cube and the collision works well. I guess the 3D may be the problem for some reasons
The collision can be felt in the game. I mean, when in "y" mode, the plane doesn't goes through but instead goes on the top of the collider object
Fun thing ^^
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
4,781
Country
us-wisconsin
The collision routine for MSFS doesn't work well. I'm not sure your original blend file wouldn't work if Asobo fixed the collisions. The method I offered sometimes works, and it is an easy way to get a collision shape. Oddly. I find the collision works better on the fence than on the hanger.
 
Last edited:
Messages
77
Country
france
Thanks for your help :)
I guess we "just" need to wait untill the collisions are fixed
 
Messages
14
Country
france
I don't mean it will be fixed (because maybe there is no necessity for a fix). I mean there will be tools to understand what happens i your case (maybe this will need a fix, but we cannot conclude for the moment).
 
Last edited:

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
4,781
Country
us-wisconsin
This seems to work:
c59-collision

The bad news is I used a ridiculous number of subdivisions in the crash enclosure. (icosa-sphere 6 divisions, and scaled to generally fit the hangar and fence).

Untitled.png



So it seems the more vertices the better. I suspect it is the spacing of the vertices, rather than the total number. Somewhere there may be an optimal number or spacing distance.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
4,781
Country
us-wisconsin
I went a little nuts:


Untitled.png


All those vertices seems to have little hit on the FPS. 20,000+ faces on each collision x 166 placements. And they work.

Somewhere in the Asobo code, there is a limit of sorts on the spacing of the vertices for the collision mesh. It's going to be a best guess unless the Asobo programmer gives us the info.
 
Messages
77
Country
france
I went a little nuts:


View attachment 77516

All those vertices seems to have little hit on the FPS. 20,000+ faces on each collision x 166 placements. And they work.

Somewhere in the Asobo code, there is a limit of sorts on the spacing of the vertices for the collision mesh. It's going to be a best guess unless the Asobo programmer gives us the info.
ahaha I loved the part when you said "I went a little nuts:" and then the screenshot :'D
Thanks for the info,

Indeed I think that you guessed good. I'll ask to devsupport about this

Awesome,

A big thanks !
 
Messages
343
Country
austria
Crazy stuff, i think you are using the github version of the blender exporter?

I almost never use collision. I dont think that it is that necessary unless you are making a heliport.

I also think many people disabled the crash feature because of that horrible implemented "you crashed" screen. :)
 
Messages
77
Country
france
Crazy stuff, i think you are using the github version of the blender exporter?

I almost never use collision. I dont think that it is that necessary unless you are making a heliport.

I also think many people disabled the crash feature because of that horrible implemented "you crashed" screen. :)
Yes, I use the last version from the fork (I'm btronquoy from github by the way ;) )
Well yes the crash screen is pretty horrible like you said :p

We will put the scenery on marketplace without collisions first. Maybe we will add these later this year..

Have a nice day guys
 
Messages
14
Country
france
on the FPS. 20,000+ faces on each collision x 166 placements. And they work.

I went a little nuts:


View attachment 77516

All those vertices seems to have little hit on the FPS. 20,000+ faces on each collision x 166 placements. And they work.

Somewhere in the Asobo code, there is a limit of sorts on the spacing of the vertices for the collision mesh. It's going to be a best guess unless the Asobo programmer gives us the info.

The problem is on the number of vertices per object. If the number of vertices for one object is too heavy, the collisions will not work (or the object will not be built).

This can be alleviate by splitting the model into several objects. And yes, the sim is able to deliver a very large amount of vertices until it impacts the fps.

The builder report a warning if it detects too many collidable meshes:
Code:
mesh[6] ('3060406071627162507_0') has a lot of collidable faces ('4310'), is this intended?

This warning can become an error if the number of vertices is way too big.
 
Top