Blender2FSX/P3D (v0.9.4 onwards)

#1
Hi everyone,

I am glad to inform that the update of the Blender2FSX/P3D is here now. After viewing message from Kris (here) stating he is facing some
health issues and not been able to do much more on the Blender2FSX/P3D tool-set, I have tried to continue developing the toolset. I would like to thank you @krispy1001 for developing such a great tool. I hope he will return to develop this soon with good health.

The new toolset is Blender2FSX/P3D (version 0.9.4).

Updates on version 0.9.4
1. Fixes some missing codes from the previous version that prevent from saving the numbers/values into .x and .mdl file.
2. Major changes on the arrangement of materials. This version will follow the exact arrangement of Arno's Model Converter X. So, you wont see any different when switching between Blender2FSX/P3D and MCX.
3. Newly added Prepar3D v4 material settings.
4. Supports Blender 2.79b


What you needed before installing this version?
1. If you have installed the previous version, please back up it before installing this version.
2. SDK documentation (FSX and Prepa3D v2, v3 or v4) which ever you are working for.

See the attachment to download Blender2FSX/P3D (version 0.9.4).

How to back up previous version?
1. The best way to backup the file is to keep the downloaded previous toolset zip file. In case if you have missed it you may download it here. Otherwise, you can follow the following steps.
2. Copy the following code and paste it in the Quick Access bar:
Code:
%AppData%\Blender Foundation\Blender\2.79\scripts\addons
Blender2FSXP3D-1.jpg


2. Copy the following files: "__pycache__", "io_scene_fsx", FSX_Material4FSX", and "FSX_Toolset4FSX
3. Paste it on your desired location (This will be your backup files).
4. Delete all the files (in step 2) from Blender Addon folder.

How to install Blender2FSX/P3D toolset?
1. Open Blender and click File > User Preferences (Ctrl + Alt + U)
Blender2FSXP3D-2.jpg


2. Click Install Add-on from File
Blender2FSXP3D-3.jpg


3. a) Choose the downloaded Blender2FSXP3D (v0.9.4).zip file from the location that you have saved it.
b) Click Install Add-on from File button
Blender2FSXP3D-4.jpg


5. a) Click on TESTING.
b) Click on the search space and type 'FSX'
Blender2FSXP3D-5.jpg


6. Click on the 3 Boolean (empty space). You will see all marked.
Blender2FSXP3D-6.jpg


7. Click Save User Settings
Blender2FSXP3D-7.jpg


8. You can now close the Blender User Preferences screen and you're good to go ;).

Thank you.

Edit:

About the file name: Blender2FSXP3D (v0.9.4)-(i)
Blue: Toolset Name
Red: Version Number
Green: File number

*Note: The version (0.9.4) will be continued until new feature(s)/major change(s) on the toolset is applied. Therefore, any updates on the toolset will be followed by the green letter at the end of the toolset name.

04.02.2018: [File name: Blender2FSX/P3D (version 0.9.4)]
1. Some changes on the material properties values. Reflection scale now be able to insert values of less than 1.
[Please be informed that the reflection scale values used with previous version toolset have to be manually changed in the latest version of toolset. If not it will be converted to the new value. Example: 0.25 (previous version value) will be converted to 25 (latest version toolset)].

2. Z-bias value was set from 0 to -50. Previously it was from -1 to -50.

07.02.2018: [File name: Blender2FSX/P3D (version 0.9.4)-(i)]
1. "Do not use specular map" is changed to "No Base Material Specular".
In the previous version toolset, if you checked "Do not use specular map" and load your model in MCX, it will show "No Base Material Specular" = "False" and vice versa. That has been solved in this release. If you load your model now into MCX, it will be exactly similar as what you have selected in the toolset.

21.02.2018: [File name: Blender2FSX/P3D (version 0.9.4)-(ii)]
1. "Import >.mdl" file function code is Removed.
 

Attachments

Last edited:
#3
One small thing I noticed: In the previous version of the toolkit, "Special Functionality/Reflection Scale" was translated as 1/100th of the Blender value, now it's 1/1 (so, a value of 35 entered in Blender previously yielded "0.35", now it yields "35"). This means that it is now impossible to use values smaller than 1. I suppose only values between 0 (no reflection) and 1 (100% reflection) make sense really, although values higher that 1 are accepted by the XtoMDL compiler (and make VERY reflective surfaces!).

I think it is the line in export_fsx.py that previously read:
"RefScale = Material.fsxm_refscale * 0.01 # "Reflection scale" is scaled down for output"

It looks like this in the new version:
"RefScale = Material.fsxm_refscale # "Reflection scale" is scaled down for output"

I tried editing the line back to how it was in the old version, it seemed to do the trick nicely, and my "shiny" materials are no longer "hypermirrors" in the simulator. :cool:

Apart from this small "nag" the new version works great as far as I can tell, and it's wonderful to have the P3DV4 materials in the toolkit! :)
 
Last edited:
#5
Hi JP,

Thanks for testing out the new version toolset.
One small thing I noticed: In the previous version of the toolkit, "Special Functionality/Reflection Scale" was translated as 1/100th of the Blender value, now it's 1/1 (so, a value of 35 entered in Blender previously yielded "0.35", now it yields "35"). This means that it is now impossible to use values smaller than 1. I suppose only values between 0 (no reflection) and 1 (100% reflection) make sense really, although values higher that 1 are accepted by the XtoMDL compiler (and make VERY reflective surfaces!).

I think it is the line in export_fsx.py that previously read:
"RefScale = Material.fsxm_refscale * 0.01 # "Reflection scale" is scaled down for output"

It looks like this in the new version:
"RefScale = Material.fsxm_refscale # "Reflection scale" is scaled down for output"

I tried editing the line back to how it was in the old version, it seemed to do the trick nicely, and my "shiny" materials are no longer "hypermirrors" in the simulator. :cool:
I am aware of the changes. Previous version toolset will scale down the value to 0-1. However, according to the SDK, the reflection scale values are from 0-100. Version 0.9.4 follow exactly what is described in the SDK. So I change the value from being scaled down.

What I noticed on my code is that one of the code property prevent you to insert the value of less than 1. I have reedited it and you can download the latest file in the 1st thread above. You can now insert values less than 1 ;). I haven't try exporting this into simulator. So, kindly PM me the different scale screenshot (for example: 0.3, 3 and 30) so I can see the result :).

Apart from this small "nag" the new version works great as far as I can tell, and it's wonderful to have the P3DV4 materials in the toolkit! :)
Thank you very much:).
 
Last edited:
#6
How to use Blender2FSX/P3D toolset
Follow the following steps in the image:

Blender2FSXP3D-8.jpg


Blender2FSXP3D-9.jpg


Blender2FSXP3D-10.jpg


That's it. You can now see your .x file and other files in the location you have saved.
 
#8
One tiny nitpick more if I may ... notice that this has been the same in all version of the toolkit as far as I know:

You have to check Enhanced Parameters\Do Not Use Specular Map in Blender to make "No base material specular" FALSE in the model. That has always seemed to be "the wrong way around" to me. If you check it, you actually USE base material specular.
 
#9
Hi @MANOCHVARMA RAMAN,

I am very happy that you have continued the development of this wonderful extension for Blender. A huge thank you to you!

I just tested the implementation of material script for rain effect on the windshield, and it works perfectly ... THANK YOU!

On the other hand, I noticed that a material, without texture, but only with a color coming from Blender, appears badly in the simulator: the material becomes very white and "brilliant", even if its color and matte black, for example!

But I'm very impressed by what you, @krispy1001, @capt_x (initiator of the project), @Dutcheeseblend, @ronh... (maybe I forget ...) have allowed us to work with a superb modeling program (Blender), for all lovers of virtual flying ... Another big thank you to all!
 
#10
Hi @MANOCHVARMA RAMAN,

I was wrong ...! It is not the materials without texture that work badly, but the materials with the Special Funcionality "Use global environment map as reflection"! The reflection "eats" the texture, and everything becomes very bright white ... It worked well in the previous version!

Thank you to check the thing ... ;)
 
#11
Hi @MANOCHVARMA RAMAN,

I was wrong ...! It is not the materials without texture that work badly, but the materials with the Special Funcionality "Use global environment map as reflection"! The reflection "eats" the texture, and everything becomes very bright white ... It worked well in the previous version!

Thank you to check the thing ... ;)
Hi Chrismot,

Thank you very much for testing out the new version and thanks for the complements :)

As I mentioned in the first thread, the previous version will scale down the reflection scale. But this version will not do it since it follows exactly what SDK describes. So, if you are loading the similar files used with the previous version of toolset, then you might notice the reflection scale is scaled up. For example if you insert a value of 0.3 in reflection scale column in previous version of toolset, now it will be scaled up as 30. That is why you find the model is very bright. So, what I would suggest is to insert the exact value (example 0.3) you used in the previous version and try export it again to the simulator. I think that will solve this issue. Please advise once you tried it out ;).
 
Last edited:
#12
One tiny nitpick more if I may ... notice that this has been the same in all version of the toolkit as far as I know:

You have to check Enhanced Parameters\Do Not Use Specular Map in Blender to make "No base material specular" FALSE in the model. That has always seemed to be "the wrong way around" to me. If you check it, you actually USE base material specular.
I will look on it and back to you
 
#13
Hi Chrismot,

Thank you very much for testing out the new version and thanks for the complements :)

As I mentioned in the first thread, the previous version will scale down the reflection scale. But this version will not do it since it follows exactly what SDK describes. So, if you are loading the similar files used with the previous version of toolset, then you might notice the reflection scale is scaled up. For example if you insert a value of 0.3 in reflection scale column in previous version of toolset, now it will be scaled up as 30. That is why you find the model is very bright. So, what I would suggest is to insert the exact value (example 0.3) you used in the previous version and try export it again to the simulator. I think that will solve this issue. Please advise once you tried it out ;).
I'm sorry, but the only value that gives a result is 1 ... or 0! All that is superior gives the brilliant white result .... So, there is really a problem. In the previous version, I could put a value between 0 and 100 ...
 
#14
I'm sorry, but the only value that gives a result is 1 ... or 0! All that is superior gives the brilliant white result .... So, there is really a problem. In the previous version, I could put a value between 0 and 100 ...
Hi Chrismot,

I think you need to download the latest toolset from this thread. It has been updated. That allows you to enter the value below 1. Can I know what is the reflection scale value you have used in the previous toolset?
 
#15
Hi Raman,

I can actually enter values between 0 and 100 with this new version which is the one I use. But, if I put a value greater than 1, everything becomes white! This is the problem: only a value of 0 or 1 gives a correct result. 2 or higher, everything is white ...
 
#16
Hi Chrismot,

Can you try import the similar model and try put some values more than 1 in MCX and see the result. If you don't mind, can you please PM me your model and let see I can reproduce it here.
 
#17
Hi Raman,

With MCX, it works perfectly, but not with Blender3FSXP3D (v0.9.4). When I used MCX to test raindrops, I had no texture problems with the values above 1 used in Blender...
 
#18
Chris, due to the changes regarding Reflection Scale, you have to use values 1/100 of what you previously used. In previous versions of the toolkit the value you entered was divided by 100 when generating the model.

So, if you previously used a value of, for example, 40, you now have to use 0.40 instead.
 
#19
One tiny nitpick more if I may ... notice that this has been the same in all version of the toolkit as far as I know:

You have to check Enhanced Parameters\Do Not Use Specular Map in Blender to make "No base material specular" FALSE in the model. That has always seemed to be "the wrong way around" to me. If you check it, you actually USE base material specular.
Hi JP,

That is how it should work. I have asked Arno about this and he said:
In the SDK this is written:

Code:
AllowBaseMaterialSpecular: Set to 1 (the default) if specular effects are to apply to the base material.
In GMax the option is called NoBaseMaterialSpecular, so that is exactly the reverse of what is written in the X file. That's why MCX reverses things on export. I think this was done because the default is on, so this option allows to turn it off.
 
#20
Chris, due to the changes regarding Reflection Scale, you have to use values 1/100 of what you previously used. In previous versions of the toolkit the value you entered was divided by 100 when generating the model.

So, if you previously used a value of, for example, 40, you now have to use 0.40 instead.
Yes, but in Blender, with Blender2FSXP3D ultimate version, I can not use a value less than 1 ...! 0.40 = 1 :p
 
Last edited:
Top