• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Blender2MSFS Limitation? Color Multipliers

Messages
1,185
Country
canada
I must be blind!! Where and how am I to download the updated zip file, please?
You should be able to click on green download button and download the zip, use the zip to install.

EDIT: depending on how you installed the previous one you may need to unzip and rezip it into separate zip file as the folder structure may not be suitable for people's install.
eg. my current one is MSFSToolkit, this will install under Blender2MSFS2-main
 
Last edited:
Messages
34
Country
unitedstates
I must be blind!! Where and how am I to download the updated zip file, please?

Yeah I am attaching the zip for install in Blender Preferences INSTALL.
But for any updates please see this link:


Select CODE > Download ZIP
 

Attachments

  • Blender2MSFS2-main_v0.41.3.zip
    153.5 KB · Views: 43
  • 2021-08-25_11-38-11_chrome.jpg
    2021-08-25_11-38-11_chrome.jpg
    51.1 KB · Views: 32

Pyscen

Resource contributor
Messages
2,550
Country
us-texas
Thanks to All,...

I Re-Zipped the (main) as the Original. No Problem.

Thanks, Again!
 
Messages
237
Country
england
Up to my ears with something else thanks to the 7 inches of rain we had over the weekend. I'm 2.93 also.
Thanks for the test files.
More later.

How do you get this to install in Blender 2.93? On my 2.93 installation it throws up several errors when trying to enable the addon, although it works perfectly with 2.91.
 
Messages
343
Country
austria
How do you get this to install in Blender 2.93? On my 2.93 installation it throws up several errors when trying to enable the addon, although it works perfectly with 2.91.
Delete every old version, restart blender, install the new version. That should work. :)
 

Pyscen

Resource contributor
Messages
2,550
Country
us-texas
You don't need to delete the old at all (especially for version 2.93), Re-zipping with the original folder name installs correctly
 
Messages
343
Country
austria
If you download directly from github as a .zip file you dont have to rezipp at all. Just use the downloaded zip. Go to blender addons install from file. :)
 
Messages
237
Country
england
Thanks for the pointers, but I think I've tried all of those tips already. The 2.93 install of blender was fresh, with no other 3rd party add-ons installed. Only thing i haven't tried is removing blender 2.91, which I'm a bit nervous about as that's working fine and I don't want to screw that up! I'll post a screenshot of the error message later to see if that gives anyone a clue. Thanks.
 
Messages
41
Country
unitedstates
Thanks for the pointers, but I think I've tried all of those tips already. The 2.93 install of blender was fresh, with no other 3rd party add-ons installed. Only thing i haven't tried is removing blender 2.91, which I'm a bit nervous about as that's working fine and I don't want to screw that up! I'll post a screenshot of the error message later to see if that gives anyone a clue. Thanks.
I had that problem with old versions, too. There's some lore on the Blender site about how to keep older versions still runnable, as I do. I won't try to relay their explanation, but I don't "install" Blender; rather I put all the files in a documents folder properly labeled and then find the .exe and run that. But, really, there's help on the Blender site - I just can't remember where. If you have a Windows-install, there's something in your user app data. Hope these vague anecdotes help.
 
Messages
237
Country
england
Thanks. I did end up removing all traces of blender entirely, then reinstalling just 2.93. That worked, but I'll look into that info you mentioned for future reference.
 
Messages
265
Country
italy
Thanks @Mikea.at and all other contributors for all your work on this, really appreciated

I Hope you can add another feature to the Exporter:
The msfs glass material does not render properly in Blender (full transparent)
I lived with that too much, eventually looking in the shader editor and find a really Easy fix

Going backwards, the msfs bsdf shader has its alpha connected to a multiply node (the value of our selected transparency)
Going up in the chain, the multiply Is connected with the color of an EMPYT texture node
This makes literally no sense to me !zero from a texture multiply by any value Always gives zero!
Killing that last binding did the work
Of course exported models looks good to me in the Sim!

Thanks again for all your effort!
IMG_20210917_095629.jpg


Inviato dal mio Mi 9 Lite utilizzando Tapatalk
 
Messages
41
Country
unitedstates
I Hope you can add another feature to the Exporter:
The msfs glass material does not render properly in Blender (full transparent)
I lived with that too much, eventually looking in the shader editor and find a really Easy fix

Going backwards, the msfs bsdf shader has its alpha connected to a multiply node (the value of our selected transparency)
Going up in the chain, the multiply Is connected with the color of an EMPYT texture node
This makes literally no sense to me !zero from a texture multiply by any value Always gives zero!
Killing that last binding did the work
Of course exported models looks good to me in the Sim!
Just a quick note, I'm still working on the problem you raise:
I believe I've duplicated what you are seeing. In the left picture (I hope it's really on the left when I attach it!), you see a simple building with a desk inside and double-sided brick walls for comparison. You can see the desk through the top of the window on the right, and you can also see the desk through the bottom of the window on the right. The top is simply some text with an alpha channel as an albedo texture on the Asobo glass material. The bottom is some dirt texture with an alpha channel as an albedo texture. In this way, I used the albedo channel to add dirt to the window. That way, the alpha output is not zero, as you noticed when there is no texture. You can see the alpha settings at the right. I was able to make the window dirty but transparent to a degree. The alpha slider allows me to vary the effect.
Glass Material in Blender.jpgGlass Material in FS2020.jpg
On the right, you see the same model in the sim. Clearly there is more here than just the problem with the glass material nodes with no texture in the albedo alpha channel .
I will not go into detail until I know more. I learned a lot about the exporter when I worked on the LOD batch export, and I believe the problem lies with the source node output that is actually exported by the glTF exporter that ships with Blender. Glass is one of the Asobo extensions, but the inputs to the Kronos glTF exporter are difficult to find.
Thank you for bringing this analysis up. I agree that deleting the alpha_multiply input fixes the immediate problem, but I would like to fix the entire problem so I can make dirty glass.
I hope I've used the reply function properly.
I have to go now: KLGA tower is yelling at me to "get that box off the runway!"
 
Top