• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v5 Blender2P3D/FSX

Messages
3
Country
mexico
Hi, I am currently starting with my project of Bellanca Pacemaker for FSX and P3D, but I have problems to install the plugin to blender and it does not appear, I have tried with the current version 3.0 and it does not work, I have installed the 2.83 LTS also Blender2FSX has not appeared in my blender in any version. Does anyone know how I can fix it?
 

Pyscen

Resource contributor
Messages
2,776
Country
us-texas
Have you installed the SDK's for FSX and/ or P3D? Is this for FSX: SE?

How did you install the toolset?
 
Messages
3
Country
mexico
Have you installed the SDK's for FSX and/ or P3D? Is this for FSX: SE?

How did you install the toolset?
Yes I have only installed for now the SDK for FSX updated with SP1 and SP2, the SDK for P3D I have not installed.

I installed it following the steps explained above.
 

Pyscen

Resource contributor
Messages
2,776
Country
us-texas
Do you have FSX Steam or FSX Acceleration Pack? Which toolset? Which version do you have? There are a few versions on installing and activating, so you will need to give more info on how you installed it.
 
Messages
3
Country
mexico
Do you have FSX Steam or FSX Acceleration Pack? Which toolset? Which version do you have? There are a few versions on installing and activating, so you will need to give more info on how you installed it.

Do you have FSX Steam or FSX Acceleration Pack? Which toolset? Which version do you have? There are a few versions on installing and activating, so you will need to give more info on how you installed it.
FSX Steam, I installed the SDK with the original FSX disk, the Blender2FSX case I downloaded 0.98.21 it in the original topic and installed it in blender 3.0.
 

Pyscen

Resource contributor
Messages
2,776
Country
us-texas
If.you have installed the Toolset prior to any of the SDK were installed, the toolset will not.recognize the SDK was Installed. You will need to remove the toolset and then reinstall and activate it. Make sure.you do activate the toolset. Otherwise, it will not appear installed.


What location was the SDK Installed, was it in the default location or else where? I'm not using Blender v3.0, so I can't say that the toolset works with it. But also, you mentioned that you also Installed v2.83 of Blender, the toolset should have worked then.
 

Lagaffe

Resource contributor
Messages
715
Country
france
This toolset has been developped for Blender 2.83 not for 3.0.
After each SDK installation you should run Config.exe which is at the SDK root directory. If you don't run this tool your SDK is not configured.
 

Pyscen

Resource contributor
Messages
2,776
Country
us-texas
Just for Reference: Both of the LTS (Long-Term Support) versions, v2.83 and v2.93. work with the FSX/P3D Toolset. The Toolset was created after v2.79 of Blender. This means any version after 2.79 of Blender should work but has only been tested with the latest LTS of v2.93, and not v3.0.

With that being said, I do not know if it functions correctly or not with v3.0 (but it might since nothing of the internals functions has changed, only the "Library Assets" was added that I know of).

Either of the LTS versions (as of this writing: v2.83.xx & v2.93.xx) can be obtained from: https://www.blender.org/download/lts/
 
Last edited:
Messages
29
Country
sudan
Greetings all,

Which blender version is supported, I'm about to begin designing commercially, I want to make sure of the plugin which is made for production, plus the blender version.
 

Pyscen

Resource contributor
Messages
2,776
Country
us-texas
Hello...

Your question on "which plugin or toolset is made for production, along with the Blender version?" Quite simply, there isn't a Toolset or plugin that is "made for production" or for designing commercially. As you may know or not, Blender is free and can be used by anyone for any reason (per the website). The latest version of Blender that was tested with Toolset is LTS ( Long-Term Support) v2.93.xx ( currently v2.93.07 ). It can be downloaded at:


Blender v3.01, which was just released, hasn't been tested with the Toolset.

The latest Toolset, which isn't available on this site, can be downloaded by clicking (here). This version of the Toolset is v0.98.34. The version that is in the Resource section on this site is v0.98.21. Unfortunately, one of the attributes (within P3D v5.3), the Clear-Coat texture map, is not a part of the Toolset. Of course, If you have the skills (in python) please add it to the Toolset and allow others to use it also, please.

Edit:
The Toolset has been made compatible with Blender LTS v3.3. The Toolset is now v0.98.38. and only should be used in Blender LTS v3.3. Download: Here

More information can be found here: https://www.fsdeveloper.com/forum/threads/blender2p3d-fsx-for-blender-3-x-maybe.455922/
 
Last edited:
Messages
157
FWIW,

For FSX SP2, either of the toolsets Doug mentioned in reply #290 don't appear to work correctly in either Blender 3.0, or 3.0.1.

When exporting a textured only, Specular Material Mode selected, MDL it throws an error "[02/03/2022 09:04:42] EXPORT ERROR! Couldn't find the corresponding shader node for material <cube>. It should be a 'Specular BSDF' for specular material.".

I was getting this error with something for FSX I made, but it also throws it as shown for a textured default cube.

The parts were UV unwrapped and the textures made in GIMP.

In case someone else has encountered this problem, this hack has worked for me: I found that with a part I had already made in Blender 3.0.1, if I opened the file in 2.93.7 and saved it and reopened it in 2.93.7, that the textured MDL would then export.

Edit: This hack seems to be OK if you only want to export a completed simple model. If you are going to do any futher work on the object, I have since found that it is better to copy the object from 3.x and paste it into 2.93.x. The warning from Blender when you open the newer file in the older version (expect loss of data) at the minmum refers to some UI items missing, e.g., no snapping option in the UV Editing window header. .

If one needs to use this toolset, it looks like staying Blender 2.93.x will be easier.
 
Last edited:
Messages
230
Country
ecuador
Hello to all,

I just installed Blender 3.1 and I see that the Blender2P3D v 0.98.21 extension is not working anymore...!!! Impossible to export!

I reinstall Blender 3.0.1, and there everything works again...

I know that P3Dv5 is maybe out of date..., even if I'm sorry..., but do you think that Blender2P3D tool will be updated for the new version of Blender?

EDIT : I specify that Doug's version 0.98.34 (above...) does not work with Blender 3.1 either
 
Last edited:

Pyscen

Resource contributor
Messages
2,776
Country
us-texas
FYI: v0.98.34 is not mine. Vitus did it, but never updated it in the Resource area here. Blender's LTS v2.83.xx & LTS v2.93.xx both still work with the toolset. The LTS v2.83.xx will end in June 2022 (this year). The LTS v2.93.xx will end the following year in June (2023)..
 

Pyscen

Resource contributor
Messages
2,776
Country
us-texas
Just so more people can test, please download the new updated Toolset for Blender LTS v3.3. This Toolset (v0.98.38) only works with Blender LTS v3.3. Download: Here

More information can be found here: https://www.fsdeveloper.com/forum/threads/blender2p3d-fsx-for-blender-3-x-maybe.455922/

A portable zip version of Blender LTS v3.3 without an installer is also available:

Drop-down— blender.org.png
 
Last edited:
Top