Blurry Textures

I'm getting blurry textures in a model that I exported from 3DS Max. Textures on the default aircraft look fine. The ones that I exported are DDS DXT5, and look fine when I load them into DXTBmp. I've tried exporting the textures thru DXTBmp, Imagetool, and the NVidia Photoshop plugins; it doesn't seem to matter which I use - I get the same problem. Is there maybe some weird setting in the Max SFX material that's set wrong?
________
Redhead Girl Live
 
Last edited:
Mick, when you save your texture in DXTBmp do not include mip maps. That's a known cause for blurred textures on the model when viewed in the sim.

Robert
 
Although I'm no expert, my understanding of MipMaps is that they give the user a choice of quality as set through the Settings > Graphics Tab > Global texture resolution slider.

A texture containing MipMaps includes several versions of the image in ever decreasing size. A low Global texture resolution setting = FS uses smaller sized textures resulting in fuzzy graphics on aircraft. High setting = FS uses larger sized textures offering more crisp graphics. If you create your textures without MipMaps I guess FS is forced to use the texture at full size.

Another variable is the initial size that you make your textures. For example most of the default FSX aircraft's main texture files are 1024x1024 pixels. As long as the texture is square in shape it can be 64x64, 128x128, 256x256, 512x512, 1024x1024 etc. The larger the crisper. At least that's how I understand it.
 
These textures are all 1024 by 1024. The problem isn't due to a low setting in FSX, because the textures on the default aircraft look fine.

Thanks for the tip, Robert. That worked for the external model. But the VC textures are still blurry, even with no mip maps.
________
VAPORIZER TV
 
Last edited:
VC textures

The sharpness of your texture in the VC has to do with how many parts are included in your texture. If I were to map a 1024 x 1024 texture to a small poly and map that same texture to a larger poly the small one would look sharper. In the same way, if I use 1 texture for all the parts in my VC it would not look as sharp as it would if I used 2 textures and divided up the VC parts between the 2 textures. There is no rule that says you have to do everything on 1 texture.

Robert
 
Got the VC textures working. After I removed all the mips I couldn't figure out why the external textures worked ok but the VC was still blurry. But it turns out that even though I removed all the mips from the VCs materials, the objects were still mapped with the older versions of the materials. The new multi/subobject material was in the material editor, but the older version of it - with the same name - was still in the scene and assigned to the objects. Good ol' Max, with its redundant materials.
________
ZOLOFT ATTORNEYS
 
Last edited:
Top