• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Bugs in the Forest

Please use this thread to report bugs found in the latest version of Forest - Build 133. You can verify you have the latest version installed by going to Programs and Features and looking at the Version listed for the application Forest Ver 1.03.
I am currently taking a couple weeks off from coding - getting Forest ready for upload was a draining process. Once I get back to the code I have several improvements I plan to add and lots of additional documentation to write. Eventually I hope to fix the editor zoom performance problem but that is probably going to take a different approach to image zooming and a lot of coding. I hope you all are able to enjoy the program in its current state and I look forward to seeing what the tool can do in the hands of the many talented scenery designers out there.

painfully... I have upgraded to Win 10. Alas, it appears Forest will not start


Here are the "Details"

Windows : 10.0.10240.0 (Win32NT)
Common Language Runtime : 4.0.30319.42000
System.Deployment.dll : built by: NETFXREL2
clr.dll : built by: NETFXREL2STAGE
dfdll.dll : built by: NETFXREL2
dfshim.dll : 10.0.10240.16384 (th1.150709-1700)

Deployment url : file:///D:/Flight%20Simulator%20Tools/Forest/Forest%201.03.application

Deployment Identity : Forest 1.03.application, Version=, Culture=neutral, PublicKeyToken=0000000000000000, processorArchitecture=amd64

* Installable application.

Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of D:\Flight Simulator Tools\Forest\Forest 1.03.application resulted in exception. Following failure messages were detected:
+ Deployment and application do not have matching security zones.

No transaction error was detected.

* The manifest for this application does not have a signature. Signature validation will be ignored.

* [8/18/2015 9:21:11 PM] : Activation of D:\Flight Simulator Tools\Forest\Forest 1.03.application has started.
* [8/18/2015 9:21:11 PM] : Processing of deployment manifest has successfully completed.
* [8/18/2015 9:21:11 PM] : Installation of the application has started.

Following errors were detected during this operation.
* [8/18/2015 9:21:11 PM] System.Deployment.Application.InvalidDeploymentException (Zone)
- Deployment and application do not have matching security zones.
- Source: System.Deployment
- Stack trace:
at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, IDownloadNotification notification, DownloadOptions options, Uri& appSourceUri, String& appManifestPath)
at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

No transaction information is available.

This has been an all day affair. Not sure I want to try to go back to Win 7, but I'll have to explore.
Eric, there is a work around. If I run setup as administrator, and go through a couple of security clicks it will run. I cannot run the

The program is not recognized and Windows Defender blocked it. I had to re "set up" as administrator, and Forest is back "Forest 1.03 application file--and if there is a run as administrator option for it, I've not found it yet

sorry for the multiple posts.... I found that I could run Forest 1.02... Just deleted all, reinstalled (something in there bothers Defender--lots of multi screen responses to get through--and Forest 1.03 is working.

So, much ado about nothing. Been a long day of frustrating tries to get this thing working--barely

Glad to hear you got it all sorted. I have upgraded almost all my machines to Windows 10 an while it has been a pleasant experience overall there are several OS bugs I have discovered and I noticed that Forest (or rather the click once installer) does not properly register .fdef and .fdefauto anymore so under Windows 10 I can't double click a project and have it load in Forest. Oh well, I guess that's a minor hassle and I was planning to explore alternate installer software anyway.
How have things been going otherwise?

I'd been using Forest a lot. about to post some pictures several time, but the last two days (vacation days) have been all Win 10 frustration. And looking at last night's posts, I was on the verge of psychotic!!!

Win 10 installation has been a real problem. Failed on first few attempts, and in the aborted installs, the boot sector was corrupted (0xc000000f error, Windows fails to start as software or hardware as changed)--never got to Win 10, and Win 7 would not start. Fortunately, I discovered that from BIOS , my Gigabyte UEFI bios has a "windows boot manager" which really seems to do nothing but boot the computer into windows.!!

MS suggested I reinstall Win 7 completely--the repair option on my two year old Win 7 disk won't work as the current win 7 is "newer". Tried to create a current Win 7 repair disk but no joy. Using the bios boot workaround, I was able to install Win 10 by downloading ISO, etc... but still can't boot directly. Today I'm building a Win 10 repair/restore option now, and hopefully can create a "newer OS" repair/restore 8 GB usb drive to get running .

the idea of reinstalling everything is overwhelming to me.... I may just have to teach my wife the work around. But, it seems long term, this is no good.

I'm making a list of everything, backed up on drive...

Forest is much easier and more responsible than Windows!!! And I had no problems with Win 7.... but I do like Win 10, and everything seems to run just fine, and most things feel faster to me on my homebuilt I3770 based system
I'd been using Forest a lot. about to post some pictures several time, but the last two days (vacation days) have been all Win 10 frustration. And looking at last night's posts, I was on the verge of psychotic!!!

I'm glad to hear the program is working for you and I look forward to seeing your work. Remember to post your efforts in the Share Your Work thread.

If you intend to allow others to edit the project take note of how I have included KML files with most of my example projects within the info sub directory. This will help others create a project image with the correct location and scale.

You are welcome to share your compressed BGL scenery files and/or source project files there as well. Just don't include the source imagery or mask backups as those would greatly increase the project file size and make them too big for upload here.
First of I would like to say thank you for making such a program, but if only I could get about using it.

I get the following error code when trying to work on my Almaty Scenery.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
   at WindowsFormsApplication1.formViewSurvey.formViewSurvey_Load(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
    Assembly Version:
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
Forest 1.03
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/Users/simon/AppData/Local/Apps/2.0/6JOK6RXO.BB7/HGZVO3WW.PED/fore..tion_0000000000000000_0001.0000_6b8f60e318af4d9f/Forest%201.03.exe
    Assembly Version:
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    Assembly Version:
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    Assembly Version:
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    Assembly Version:
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    Assembly Version:
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    Assembly Version:
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging

For example:

    <system.windows.forms jitDebugging="true" />

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.