• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSXA Building Autogen Disappear

jtanabodee

Resource contributor
Hi,
I'm so new to annotator tool in FSX. I place my trees and building using Annotation tool. Something like the first picture I attached. I select roof and press on GUID in control panel. Everything looked like what described in SDK. But when I get in FSX, trees are visible but buildings disappear like 2nd pic. What could be wrong? It is not bounding box issue since I add <No autogensuppression> in all the objects and nothing changes. Besides that, trees should disappear too if bounding box is an issue.
Thanks for any reply.
P.S. Opps! I mixed up. The first picture is in FSX, the second one is annotation tool
 

Attachments

  • autogenhouse disappear.jpg
    autogenhouse disappear.jpg
    97.5 KB · Views: 587
  • autogenhouse disappear02.jpg
    autogenhouse disappear02.jpg
    98.2 KB · Views: 555
Last edited:

jtanabodee

Resource contributor
I have done that both row housse and other type of houses still invisible.
Just only the trees are visible:confused:
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Did you verify if it is not an issue with the autogen density?
 

jtanabodee

Resource contributor
I set autogen to full already, Arno. But the buildings still invisible. Even I change to other computer, this still happen.
 
Hi,
may be you just exceed your display limits.
How many "houses" have you got in this lod13 ?
Did you set TERRAIN_MAX_AUTOGEN_BULDINGS_PER_CELL in your cfg ?
Could you screen the entire lod13 ?
 

jtanabodee

Resource contributor
Hi,
may be you just exceed your display limits.
How many "houses" have you got in this lod13 ?
Did you set TERRAIN_MAX_AUTOGEN_BULDINGS_PER_CELL in your cfg ?
Could you screen the entire lod13 ?
No, I didn't set any thing in cfg file. May be you are right about the limits. I'll try to make a change in cfg. What can I do to tweak that? and it's effect to performance or fps?
 
Hi,
in the [TERRAIN] section of fsx.cfg add the line:

TERRAIN_MAX_AUTOGEN_BULDINGS_PER_CELL=600

Default is 300 I think
 
Hi Alain:

In regard to prior communications on this topic of "displayed" Autogen in FS and the effect of "attenuation" options for Autogen in the FSX.Cfg file:

http://www.fsdeveloper.com/forum/showthread.php?t=20381


If indeed the 'default' settings for maximum number of "displayed" autogen objects in FSX is as seen in the FSX.Cfg:


[TERRAIN]
TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=4500
TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=3000

[EDITED]
Isn't it true that in a FSX.Cfg file newly-created by the FS setup / restore engine those strings above do not appear, yet one already has the equivalent of these settings by internal default behavior of the FSX rendering engine at run-time (when no such Autogen "attenuation" or "proliferation" / "extension" tweaks have been applied in FSX.Cfg) ? :rolleyes:

http://www.newsite.fsdeveloper.com/forum/showthread.php?p=95608


In other words, that default autogen density behavior associated (somewhat) with the autogen FSX slider only changes when we specify different behavior for autogen density via the slider... by adding the above "TERRAIN_MAX_AUTOGEN_[x]_PER_CELL" parameters within the [Terrain] sub-section of FSX.Cfg ?
[END_EDIT]


And if that were the case, wouldn't using

TERRAIN_MAX_AUTOGEN_BULDINGS_PER_CELL=600

...end up limiting further the amount of "displayed" autogen on the FSX platform ? :confused:


Thanks for any further clarification on this. :)



[EDITED]
PS: I just did some computations on the LOD-13 Quad / QMID15 "Cell"; one such Cell is reportedly 1,223 Meters x 1,223 Meters = 1,495,729 square Meters in area

Hmmm... I am compelled to wonder: :stirthepo

If one were at risk for a footprint / bounding box conflict that resulted in Autogen object suppression by neighboring / overlapping Autogen objects, what would the "safe" proximity distance be between such objects to avoid inter-object conflict (only theoretically, of course... as IIUC, Autogen objects don't suppress each other) ?

If for the sake of hypothetical exploration we assumed an 'average' conifer tree footprint was a specified size in square Meters, and an 'average' building footprint was a specified size in square Meters, if we divided the total available 1,495,729 square Meters in an LOD-13 (QMID15) "Cell", how many Autogen "objects" could even be displayed without overlap between adjacent Autogen objects (assuming they were all in a single AGN Annotation "layer") ?


Based on info posted at:

http://lc0277.gratisim.fr/sceneobjects/


If we assumed the average House was:

ag_eurhouse04
{C0962B27-0AA7-473E-942C-14C69199E4BE}
size: 14.51, 9.80, 10.88
(Depth, Height, Width)

%7BC0962B27-0AA7-473E-942C-14C69199E4BE%7D.jpg



Then...

1,495,729 square Meters per Cell / 147.8688 square Meters per House = 9,474.506 'MAX_AUTOGEN_[Houses]_PER_CELL'


If we assumed the average tree was:

veg_tc_DouglasFir1_30m
{2294AACA-DC68-4D5E-89A0-BD9CD363615C}
size: 19.14, 32.52, 19.64
(Depth, Height, Width)

%7B2294AACA-DC68-4D5E-89A0-BD9CD363615C%7D.thumb.jpg



Then...

1,495,729 square Meters per Cell / 375.9096 square Meters per Tree = 3,978.959 'MAX_AUTOGEN_[Trees]_PER_CELL' :D


NOTE: If I have mis-interpreted / mis-calculated anything here, someone please correct me ! :eek:
[END_EDIT]

GaryGB
 
Last edited:
I didn't test in fsx as I told you previously. ;)
But I guess fsx works the same than fs9, except for the max displayable buildings that can be changed in cfg. The slider doesn't change that max, it only changes the number really displayed and which ones are displayed.

Anyway it seems the default value is 3000 ! Not 300. So our friend should try 6000 to test.
 
Last edited:
I can assure you that agn buildings and vegetation can coexist.

This shot from Annotator shows 5448 buildings and 91,310 vegetation areas in a particular photo-scenery bgl:



and in FSX:



Analysing one of the agn files shows 1534 builldings and 385 vegetation areas:



The agn file is in FS9 format but is recognised by both FSX and the FSX Annotator.

Edit.

Can you attach your agn file so that I might analyse it?
 
Last edited:

jtanabodee

Resource contributor
Thanks for the replies.
My autogen is far less than maximal since just begin to make autogen buildings.
Anyway, I put autogen model by using SbuilderX instead and it is quite OK now.
I don't know what happen exactly.
 
Top